linuxppc-dev.lists.ozlabs.org archive mirror
 help / color / mirror / Atom feed
From: John Hubbard <jhubbard@nvidia.com>
To: Jan Kara <jack@suse.cz>
Cc: "Michal Hocko" <mhocko@suse.com>,
	kvm@vger.kernel.org, linux-doc@vger.kernel.org,
	"David Airlie" <airlied@linux.ie>,
	"Dave Chinner" <david@fromorbit.com>,
	dri-devel@lists.freedesktop.org,
	LKML <linux-kernel@vger.kernel.org>,
	linux-mm@kvack.org, "Paul Mackerras" <paulus@samba.org>,
	linux-kselftest@vger.kernel.org,
	"Ira Weiny" <ira.weiny@intel.com>,
	"Jonathan Corbet" <corbet@lwn.net>,
	linux-rdma@vger.kernel.org,
	"Christoph Hellwig" <hch@infradead.org>,
	"Jason Gunthorpe" <jgg@ziepe.ca>,
	"Vlastimil Babka" <vbabka@suse.cz>,
	"Björn Töpel" <bjorn.topel@intel.com>,
	linux-media@vger.kernel.org, "Shuah Khan" <shuah@kernel.org>,
	linux-block@vger.kernel.org, "Jérôme Glisse" <jglisse@redhat.com>,
	"Al Viro" <viro@zeniv.linux.org.uk>,
	"Dan Williams" <dan.j.williams@intel.com>,
	"Mauro Carvalho Chehab" <mchehab@kernel.org>,
	bpf@vger.kernel.org,
	"Magnus Karlsson" <magnus.karlsson@intel.com>,
	"Jens Axboe" <axboe@kernel.dk>,
	netdev@vger.kernel.org,
	"Alex Williamson" <alex.williamson@redhat.com>,
	"Daniel Vetter" <daniel@ffwll.ch>,
	linux-fsdevel@vger.kernel.org,
	"Andrew Morton" <akpm@linux-foundation.org>,
	linuxppc-dev@lists.ozlabs.org,
	"David S . Miller" <davem@davemloft.net>,
	"Kirill A . Shutemov" <kirill.shutemov@linux.intel.com>,
	"Mike Kravetz" <mike.kravetz@oracle.com>
Subject: Re: [PATCH v9 23/25] mm/gup: track FOLL_PIN pages
Date: Wed, 11 Dec 2019 21:53:45 -0800	[thread overview]
Message-ID: <f961d0b6-c660-85b9-ad01-53bce74e39e9@nvidia.com> (raw)
In-Reply-To: <20191211112807.GN1551@quack2.suse.cz>

On 12/11/19 3:28 AM, Jan Kara wrote:
...
> 
> The patch looks mostly good to me now. Just a few smaller comments below.
> 
>> Suggested-by: Jan Kara <jack@suse.cz>
>> Suggested-by: Jérôme Glisse <jglisse@redhat.com>
>> Reviewed-by: Jan Kara <jack@suse.cz>
>> Reviewed-by: Jérôme Glisse <jglisse@redhat.com>
>> Reviewed-by: Ira Weiny <ira.weiny@intel.com>
> 
> I think you inherited here the Reviewed-by tags from the "add flags" patch
> you've merged into this one but that's not really fair since this patch
> does much more... In particular I didn't give my Reviewed-by tag for this
> patch yet.

OK, I've removed those reviewed-by's. (I felt bad about dropping them, after
people had devoted time to reviewing, but I do see that it's wrong to imply
that they've reviewed this much much larger thing.)

...
> 
> I somewhat wonder about the asymmetry of try_grab_compound_head() vs
> try_grab_page() in the treatment of 'flags'. How costly would it be to make
> them symmetric (i.e., either set FOLL_GET for try_grab_compound_head()
> callers or make sure one of FOLL_GET, FOLL_PIN is set for try_grab_page())?
> 
> Because this difference looks like a subtle catch in the long run...

Done. It is only a modest code-level change, at least the way I've done it, which is
setting FOLL_GET for try_grab_compound_head(). In order to do that, I set
it at the top of the internal gup fast calling stacks, which is actually a good
design anyway: gup fast is logically doing FOLL_GET in all cases. So setting
the flag internally is accurate and consistent with the overall design.


> ...
> 
>> @@ -1522,8 +1536,8 @@ struct page *follow_trans_huge_pmd(struct vm_area_struct *vma,
>>   skip_mlock:
>>   	page += (addr & ~HPAGE_PMD_MASK) >> PAGE_SHIFT;
>>   	VM_BUG_ON_PAGE(!PageCompound(page) && !is_zone_device_page(page), page);
>> -	if (flags & FOLL_GET)
>> -		get_page(page);
>> +	if (!try_grab_page(page, flags))
>> +		page = ERR_PTR(-EFAULT);
> 
> I think you need to also move the try_grab_page() earlier in the function.
> At this point the page may be marked as mlocked and you'd need to undo that
> in case try_grab_page() fails.


OK, I've moved it up, adding a "subpage" variable in order to make that work.

> 
>> diff --git a/mm/hugetlb.c b/mm/hugetlb.c
>> index ac65bb5e38ac..0aab6fe0072f 100644
>> --- a/mm/hugetlb.c
>> +++ b/mm/hugetlb.c
>> @@ -4356,7 +4356,13 @@ long follow_hugetlb_page(struct mm_struct *mm, struct vm_area_struct *vma,
>>   same_page:
>>   		if (pages) {
>>   			pages[i] = mem_map_offset(page, pfn_offset);
>> -			get_page(pages[i]);
>> +			if (!try_grab_page(pages[i], flags)) {
>> +				spin_unlock(ptl);
>> +				remainder = 0;
>> +				err = -ENOMEM;
>> +				WARN_ON_ONCE(1);
>> +				break;
>> +			}
>>   		}
> 
> This function does a refcount overflow check early so that it doesn't have
> to do try_get_page() here. So that check can be now removed when you do
> try_grab_page() here anyway since that early check seems to be just a tiny
> optimization AFAICT.
> 
> 								Honza
> 

Yes. I've removed it, good spot.


thanks,
-- 
John Hubbard
NVIDIA

  reply	other threads:[~2019-12-12  5:58 UTC|newest]

Thread overview: 34+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-12-11  2:52 [PATCH v9 00/25] mm/gup: track dma-pinned pages: FOLL_PIN John Hubbard
2019-12-11  2:52 ` [PATCH v9 01/25] mm/gup: factor out duplicate code from four routines John Hubbard
2019-12-11  2:52 ` [PATCH v9 02/25] mm/gup: move try_get_compound_head() to top, fix minor issues John Hubbard
2019-12-11  2:52 ` [PATCH v9 03/25] mm: Cleanup __put_devmap_managed_page() vs ->page_free() John Hubbard
2019-12-11  2:52 ` [PATCH v9 04/25] mm: devmap: refactor 1-based refcounting for ZONE_DEVICE pages John Hubbard
2019-12-11  2:52 ` [PATCH v9 05/25] goldish_pipe: rename local pin_user_pages() routine John Hubbard
2019-12-11  2:52 ` [PATCH v9 06/25] mm: fix get_user_pages_remote()'s handling of FOLL_LONGTERM John Hubbard
2019-12-11  2:53 ` [PATCH v9 07/25] vfio: fix FOLL_LONGTERM use, simplify get_user_pages_remote() call John Hubbard
2019-12-11  2:53 ` [PATCH v9 08/25] mm/gup: allow FOLL_FORCE for get_user_pages_fast() John Hubbard
2019-12-11  2:53 ` [PATCH v9 09/25] IB/umem: use get_user_pages_fast() to pin DMA pages John Hubbard
2019-12-11  2:53 ` [PATCH v9 10/25] mm/gup: introduce pin_user_pages*() and FOLL_PIN John Hubbard
2019-12-11 20:57   ` Jonathan Corbet
2019-12-11 21:25     ` John Hubbard
2019-12-11  2:53 ` [PATCH v9 11/25] goldish_pipe: convert to pin_user_pages() and put_user_page() John Hubbard
2019-12-11  2:53 ` [PATCH v9 12/25] IB/{core, hw, umem}: set FOLL_PIN via pin_user_pages*(), fix up ODP John Hubbard
2019-12-11  2:53 ` [PATCH v9 13/25] mm/process_vm_access: set FOLL_PIN via pin_user_pages_remote() John Hubbard
2019-12-11  2:53 ` [PATCH v9 14/25] drm/via: set FOLL_PIN via pin_user_pages_fast() John Hubbard
2019-12-11  2:53 ` [PATCH v9 15/25] fs/io_uring: set FOLL_PIN via pin_user_pages() John Hubbard
2019-12-11  2:53 ` [PATCH v9 16/25] net/xdp: " John Hubbard
2019-12-11  2:53 ` [PATCH v9 17/25] media/v4l2-core: set pages dirty upon releasing DMA buffers John Hubbard
2019-12-11  2:53 ` [PATCH v9 18/25] media/v4l2-core: pin_user_pages (FOLL_PIN) and put_user_page() conversion John Hubbard
2019-12-11  2:53 ` [PATCH v9 19/25] vfio, mm: " John Hubbard
2019-12-11  2:53 ` [PATCH v9 20/25] powerpc: book3s64: convert to pin_user_pages() and put_user_page() John Hubbard
2019-12-11 10:42   ` Jan Kara
2019-12-11  2:53 ` [PATCH v9 21/25] mm/gup_benchmark: use proper FOLL_WRITE flags instead of hard-coding "1" John Hubbard
2019-12-11  2:53 ` [PATCH v9 22/25] mm, tree-wide: rename put_user_page*() to unpin_user_page*() John Hubbard
2019-12-11  2:53 ` [PATCH v9 23/25] mm/gup: track FOLL_PIN pages John Hubbard
2019-12-11 11:28   ` Jan Kara
2019-12-12  5:53     ` John Hubbard [this message]
2019-12-17  8:03   ` kbuild test robot
2019-12-17  8:03   ` [RFC PATCH] mm/gup: try_pin_compound_head() can be static kbuild test robot
2019-12-17 13:56     ` John Hubbard
2019-12-11  2:53 ` [PATCH v9 24/25] mm/gup_benchmark: support pin_user_pages() and related calls John Hubbard
2019-12-11  2:53 ` [PATCH v9 25/25] selftests/vm: run_vmtests: invoke gup_benchmark with basic FOLL_PIN coverage John Hubbard

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=f961d0b6-c660-85b9-ad01-53bce74e39e9@nvidia.com \
    --to=jhubbard@nvidia.com \
    --cc=airlied@linux.ie \
    --cc=akpm@linux-foundation.org \
    --cc=alex.williamson@redhat.com \
    --cc=axboe@kernel.dk \
    --cc=bjorn.topel@intel.com \
    --cc=bpf@vger.kernel.org \
    --cc=corbet@lwn.net \
    --cc=dan.j.williams@intel.com \
    --cc=daniel@ffwll.ch \
    --cc=davem@davemloft.net \
    --cc=david@fromorbit.com \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=hch@infradead.org \
    --cc=ira.weiny@intel.com \
    --cc=jack@suse.cz \
    --cc=jgg@ziepe.ca \
    --cc=jglisse@redhat.com \
    --cc=kirill.shutemov@linux.intel.com \
    --cc=kvm@vger.kernel.org \
    --cc=linux-block@vger.kernel.org \
    --cc=linux-doc@vger.kernel.org \
    --cc=linux-fsdevel@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-kselftest@vger.kernel.org \
    --cc=linux-media@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=linux-rdma@vger.kernel.org \
    --cc=linuxppc-dev@lists.ozlabs.org \
    --cc=magnus.karlsson@intel.com \
    --cc=mchehab@kernel.org \
    --cc=mhocko@suse.com \
    --cc=mike.kravetz@oracle.com \
    --cc=netdev@vger.kernel.org \
    --cc=paulus@samba.org \
    --cc=shuah@kernel.org \
    --cc=vbabka@suse.cz \
    --cc=viro@zeniv.linux.org.uk \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).