live-patching.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Petr Mladek <pmladek@suse.com>
To: Josh Poimboeuf <jpoimboe@redhat.com>
Cc: Jiri Kosina <jikos@kernel.org>, Miroslav Benes <mbenes@suse.cz>,
	Joe Lawrence <joe.lawrence@redhat.com>,
	Kamalesh Babulal <kamalesh@linux.vnet.ibm.com>,
	Nicolai Stange <nstange@suse.de>,
	live-patching@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH v3 3/5] livepatch: Allow to distinguish different version of system state changes
Date: Thu, 24 Oct 2019 14:13:44 +0200	[thread overview]
Message-ID: <20191024121344.rieej3qckp5xirq6@pathway.suse.cz> (raw)
In-Reply-To: <20191023211528.nfstzbuzzxsyffqh@treble>

On Wed 2019-10-23 16:15:28, Josh Poimboeuf wrote:
> Hi Petr,
> 
> Sorry for taking so long...
> 
> On Thu, Oct 03, 2019 at 11:01:35AM +0200, Petr Mladek wrote:
> > diff --git a/include/linux/livepatch.h b/include/linux/livepatch.h
> > index 726947338fd5..42907c4a0ce8 100644
> > --- a/include/linux/livepatch.h
> > +++ b/include/linux/livepatch.h
> > @@ -133,10 +133,12 @@ struct klp_object {
> >  /**
> >   * struct klp_state - state of the system modified by the livepatch
> >   * @id:		system state identifier (non-zero)
> > + * @version:	version of the change (non-zero)
> 
> Is it necessary to assume that 'version' is non-zero?  It would be easy
> for a user to not realize that and start with version 0.  Then the patch
> state would be silently ignored.
> 
> I have the same concern about 'id', but I guess at least one of them has
> to be non-zero to differentiate valid entries from the array terminator.

Exactly. At least one struct member must be non-zero to differentiate
the array terminator.

I do not mind to allow zero version. Will do so in v4.


> > +/* Check if the patch is able to deal with the given system state. */
> > +static bool klp_is_state_compatible(struct klp_patch *patch,
> > +				    struct klp_state *state)
> > +{
> > +	struct klp_state *new_state;
> > +
> > +	new_state = klp_get_state(patch, state->id);
> > +
> > +	if (new_state)
> > +		return new_state->version >= state->version;
> > +
> > +	/* Cumulative livepatch must handle all already modified states. */
> > +	return !patch->replace;
> > +}
> 
> >From my perspective I view '!new_state' as an error condition.  I'd find
> it easier to read if the ordering were changed to check for the error
> first:
> 
> 	if (!new_state) {
> 		/*
> 		 * A cumulative livepatch must handle all already
> 		 * modified states.
> 		 */
> 		return !patch->replace;
> 	}
> 
> 	return new_state->version >= state->version;

-> v4


> > +
> > +/*
> > + * Check that the new livepatch will not break the existing system states.
> > + * Cumulative patches must handle all already modified states.
> > + * Non-cumulative patches can touch already modified states.
> > + */
> > +bool klp_is_patch_compatible(struct klp_patch *patch)
> > +{
> > +	struct klp_patch *old_patch;
> > +	struct klp_state *state;
> > +
> > +
> > +	klp_for_each_patch(old_patch) {
> 
> Extra newline above.
> 
> > +		klp_for_each_state(old_patch, state) {
> > +			if (!klp_is_state_compatible(patch, state))
> > +				return false;
> > +		}
> > +	}
> 
> I think renaming 'state' to 'old_state' would make the intention a
> little clearer, and would be consistent with 'old_patch'.

Makes sense. I'll make the names consistent also in klp_is_state_compatible():


/* Check if the patch is able to deal with the given system state. */
static bool klp_is_state_compatible(struct klp_patch *patch,
				    struct klp_state *old_state)
{
	struct klp_state *state = klp_get_state(patch, state->id);

	if (!state) {
		/*
		 * A cumulative livepatch must handle all already
		 * modified states.
		 */
		return !patch->replace;
	}

	return state->version >= old_state->version;
}

Best Regards,
Petr

  reply	other threads:[~2019-10-24 12:13 UTC|newest]

Thread overview: 13+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-10-03  9:01 [PATCH v3 0/5] livepatch: new API to track system state changes Petr Mladek
2019-10-03  9:01 ` [PATCH v3 1/5] livepatch: Keep replaced patches until post_patch callback is called Petr Mladek
2019-10-03  9:01 ` [PATCH v3 2/5] livepatch: Basic API to track system state changes Petr Mladek
2019-10-03  9:01 ` [PATCH v3 3/5] livepatch: Allow to distinguish different version of " Petr Mladek
2019-10-23 21:15   ` Josh Poimboeuf
2019-10-24 12:13     ` Petr Mladek [this message]
2019-10-03  9:01 ` [PATCH v3 4/5] livepatch: Documentation of the new API for tracking " Petr Mladek
2019-10-03  9:01 ` [PATCH v3 5/5] livepatch: Selftests of the " Petr Mladek
2019-10-04 14:47   ` Joe Lawrence
2019-10-09 14:18     ` Petr Mladek
2019-10-09 14:27       ` Joe Lawrence
2019-10-08 22:19   ` kbuild test robot
2019-10-04 14:39 ` [PATCH v3 0/5] livepatch: new API to track " Joe Lawrence

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20191024121344.rieej3qckp5xirq6@pathway.suse.cz \
    --to=pmladek@suse.com \
    --cc=jikos@kernel.org \
    --cc=joe.lawrence@redhat.com \
    --cc=jpoimboe@redhat.com \
    --cc=kamalesh@linux.vnet.ibm.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=live-patching@vger.kernel.org \
    --cc=mbenes@suse.cz \
    --cc=nstange@suse.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).