live-patching.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
 messages from 2022-01-03 13:55:47 to 2022-02-11 11:09:38 UTC [more...]

[PATCH v5 00/13] module: core code clean up
 2022-02-11 11:09 UTC  (22+ messages)
` [PATCH v5 01/13] module: Move all into module/
` [PATCH v5 02/13] module: Simple refactor in preparation for split
` [PATCH v5 03/13] module: Make internal.h more compliant
` [PATCH v5 04/13] module: Move livepatch support to a separate file
` [PATCH v5 05/13] module: Move latched RB-tree "
` [PATCH v5 06/13] module: Move strict rwx "

[PATCH] livepatch: Skip livepatch tests if ftrace cannot be configured
 2022-02-10 20:58 UTC  (10+ messages)
` [PATCH v2] "

[PATCH v5 11/13] module: Move sysfs support into a separate file
 2022-02-10 14:28 UTC  (6+ messages)
` [PATCH v5 12/13] module: Move kdb_modules list out of core code
` [PATCH v5 13/13] module: Move version support into a separate file

[PATCH v5 07/13] module: Move extra signature support out of core code
 2022-02-10 13:46 UTC  (10+ messages)
` [PATCH v5 08/13] module: Move kmemleak support to a separate file
` [PATCH v5 09/13] module: Move kallsyms support into "
` [PATCH v5 10/13] module: Move procfs "

[PATCH v10 00/15] Function Granular KASLR
 2022-02-09 18:57 UTC  (16+ messages)
` [PATCH v10 01/15] modpost: fix removing numeric suffixes
` [PATCH v10 02/15] livepatch: avoid position-based search if `-z unique-symbol` is available
` [PATCH v10 03/15] kallsyms: randomize /proc/kallsyms output order
` [PATCH v10 04/15] arch: introduce asm function sections
` [PATCH v10 05/15] x86: support "
` [PATCH v10 06/15] x86: decouple ORC table sorting into a separate file
` [PATCH v10 07/15] Makefile: add config options and build scripts for FG-KASLR
` [PATCH v10 08/15] x86/tools: Add relative relocs for randomized functions
` [PATCH v10 09/15] x86: Add support for function granular KASLR
` [PATCH v10 10/15] FG-KASLR: use a scripted approach to handle .text.* sections
` [PATCH v10 11/15] x86/boot: allow FG-KASLR to be selected
` [PATCH v10 12/15] module: add arch-indep FG-KASLR for randomizing function layout
` [PATCH v10 13/15] module: use a scripted approach for FG-KASLR
` [PATCH v10 14/15] Documentation: add documentation "
` [PATCH v10 15/15] maintainers: add MAINTAINERS entry "

[RFC PATCH v4 00/13] module: core code clean up
 2022-02-09 14:37 UTC  (39+ messages)
` [RFC PATCH v4 01/13] module: Move all into module/
` [RFC PATCH v4 02/13] module: Simple refactor in preparation for split
` [RFC PATCH v4 03/13] module: Move livepatch support to a separate file
` [RFC PATCH v4 04/13] module: Move latched RB-tree "
` [RFC PATCH v4 05/13] module: Move arch strict rwx "
` [RFC PATCH v4 06/13] module: Move "
` [RFC PATCH v4 07/13] module: Move extra signature support out of core code
` [RFC PATCH v4 08/13] module: Move kmemleak support to a separate file
` [RFC PATCH v4 09/13] module: Move kallsyms support into "
` [RFC PATCH v4 10/13] module: Move procfs "
` [RFC PATCH v4 11/13] module: Move sysfs "
` [RFC PATCH v4 12/13] module: Move kdb_modules list out of core code
` [RFC PATCH v4 13/13] module: Move version support into a separate file

[PATCH v13 00/11] arm64: Reorganize the unwinder and implement stack trace reliability checks
 2022-02-03 14:45 UTC  (27+ messages)
  ` [PATCH v13 01/11] arm64: Remove NULL task check from unwind_frame()
  ` [PATCH v13 02/11] arm64: Rename unwinder functions
  ` [PATCH v13 03/11] arm64: Rename stackframe to unwind_state
  ` [PATCH v13 04/11] arm64: Split unwind_init()
  ` [PATCH v13 05/11] arm64: Copy the task argument to unwind_state
  ` [PATCH v13 06/11] arm64: Use stack_trace_consume_fn and rename args to unwind()
  ` [PATCH v13 07/11] arm64: Make the unwind loop in unwind() similar to other architectures
  ` [PATCH v13 08/11] arm64: Introduce stack trace reliability checks in the unwinder
  ` [PATCH v13 09/11] arm64: Create a list of SYM_CODE functions, check return PC against list
  ` [PATCH v13 10/11] arm64: Introduce arch_stack_walk_reliable()
  ` [PATCH v13 11/11] arm64: Select HAVE_RELIABLE_STACKTRACE

[RFC PATCH v3 00/13] module: core code clean up
 2022-01-29  7:27 UTC  (16+ messages)
` [RFC PATCH v3 01/13] module: Move all into module/
` [RFC PATCH v3 02/13] module: Simple refactor in preparation for split
` [RFC PATCH v3 03/13] module: Move livepatch support to a separate file
` [RFC PATCH v3 04/13] module: Move latched RB-tree "
` [RFC PATCH v3 05/13] module: Move arch strict rwx "
` [RFC PATCH v3 06/13] module: Move "
` [RFC PATCH v3 07/13] module: Move extra signature support out of core code
` [RFC PATCH v3 08/13] module: Move kmemleak support to a separate file
` [RFC PATCH v3 09/13] module: Move kallsyms support into "
` [RFC PATCH v3 10/13] module: Move procfs "
` [RFC PATCH v3 11/13] module: Move sysfs "
` [RFC PATCH v3 12/13] module: Move kdb_modules list out of core code
` [RFC PATCH v3 13/13] module: Move version support into a separate file

[PATCH v9 00/15] Function Granular KASLR
 2022-01-26 14:49 UTC  (20+ messages)
` [PATCH v9 02/15] livepatch: use `-z unique-symbol` if available to nuke pos-based search
` [PATCH v9 03/15] kallsyms: Hide layout
` [PATCH v9 04/15] arch: introduce ASM function sections
` [PATCH v9 05/15] x86: support "

[GIT PULL] livepatching for 5.17
 2022-01-16  8:22 UTC  (2+ messages)

[RFC PATCH v2 03/13] module: Move livepatch support to a separate file
 2022-01-14  9:14 UTC  (3+ messages)

[PATCH] livepatch: Avoid CPU hogging with cond_resched
 2022-01-11  1:49 UTC  (10+ messages)

[PATCH] livepatch: Avoid CPU hogging with cond_resched
 2022-01-10 14:38 UTC  (3+ messages)

[PATCH v12 00/10] arm64: Reorganize the unwinder and implement stack trace reliability checks
 2022-01-06 20:17 UTC  (23+ messages)
  ` [PATCH v12 01/10] arm64: Remove NULL task check from unwind_frame()
  ` [PATCH v12 02/10] arm64: Rename unwinder functions
  ` [PATCH v12 03/10] arm64: Rename stackframe to unwind_state
  ` [PATCH v12 04/10] arm64: Split unwind_init()
  ` [PATCH v12 05/10] arm64: Copy unwind arguments to unwind_state
  ` [PATCH v12 06/10] arm64: Make the unwind loop in unwind() similar to other architectures
  ` [PATCH v12 07/10] arm64: Introduce stack trace reliability checks in the unwinder
  ` [PATCH v12 08/10] arm64: Create a list of SYM_CODE functions, check return PC against list
  ` [PATCH v12 09/10] arm64: Introduce arch_stack_walk_reliable()
  ` [PATCH v12 10/10] arm64: Select HAVE_RELIABLE_STACKTRACE

[PATCH v2 00/13] Implement livepatch on PPC32 and more
 2022-01-04 19:44 UTC  (5+ messages)
` [PATCH v2 01/13] livepatch: Fix build failure on 32 bits processors
` [PATCH v2 03/13] powerpc/module_32: Fix livepatching for RO modules

[PATCH -next] livepatch: Fix missing unlock on error in klp_enable_patch()
 2022-01-04 13:09 UTC  (3+ messages)


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).