linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Baolu Lu <baolu.lu@linux.intel.com>
To: Jacob Pan <jacob.jun.pan@linux.intel.com>,
	Jason Gunthorpe <jgg@nvidia.com>
Cc: baolu.lu@linux.intel.com, iommu@lists.linux-foundation.org,
	LKML <linux-kernel@vger.kernel.org>,
	dmaengine@vger.kernel.org, Joerg Roedel <joro@8bytes.org>,
	David Woodhouse <dwmw2@infradead.org>,
	Jean-Philippe Brucker <jean-philippe@linaro.com>,
	vkoul@kernel.org, robin.murphy@arm.com, will@kernel.org,
	Yi Liu <yi.l.liu@intel.com>, Dave Jiang <dave.jiang@intel.com>,
	"Tian, Kevin" <kevin.tian@intel.com>,
	Raj Ashok <ashok.raj@intel.com>,
	Eric Auger <eric.auger@redhat.com>
Subject: Re: [PATCH v3 1/4] iommu/vt-d: Implement domain ops for attach_dev_pasid
Date: Thu, 12 May 2022 09:16:17 +0800	[thread overview]
Message-ID: <00a972f4-1fe2-2eb0-fcf5-d454f3b9dcc6@linux.intel.com> (raw)
In-Reply-To: <20220511102521.6b7c578c@jacob-builder>

On 2022/5/12 01:25, Jacob Pan wrote:
> Hi Jason,
> 
> On Wed, 11 May 2022 14:00:25 -0300, Jason Gunthorpe <jgg@nvidia.com> wrote:
> 
>> On Wed, May 11, 2022 at 10:02:16AM -0700, Jacob Pan wrote:
>>>>> If not global, perhaps we could have a list of pasids (e.g. xarray)
>>>>> attached to the device_domain_info. The TLB flush logic would just
>>>>> go through the list w/o caring what the PASIDs are for. Does it
>>>>> make sense to you?
>>>>
>>>> Sort of, but we shouldn't duplicate xarrays - the group already has
>>>> this xarray - need to find some way to allow access to it from the
>>>> driver.
>>>>    
>>> I am not following,  here are the PASIDs for devTLB flush which is per
>>> device. Why group?
>>
>> Because group is where the core code stores it.
> I see, with singleton group. I guess I can let dma-iommu code call
> 
> iommu_attach_dma_pasid {
> 	iommu_attach_device_pasid();
> Then the PASID will be stored in the group xa.
> The flush code can retrieve PASIDs from device_domain_info.device -> group
> -> pasid_array.
> Thanks for pointing it out, I missed the new pasid_array.
>>
>>> We could retrieve PASIDs from the device PASID table but xa would be
>>> more efficient.
>>>    
>>>>>>> Are you suggesting the dma-iommu API should be called
>>>>>>> iommu_set_dma_pasid instead of iommu_attach_dma_pasid?
>>>>>>
>>>>>> No that API is Ok - the driver ops API should be 'set' not
>>>>>> attach/detach
>>>>> Sounds good, this operation has little in common with
>>>>> domain_ops.dev_attach_pasid() used by SVA domain. So I will add a
>>>>> new domain_ops.dev_set_pasid()
>>>>
>>>> What? No, their should only be one operation, 'dev_set_pasid' and it
>>>> is exactly the same as the SVA operation. It configures things so that
>>>> any existing translation on the PASID is removed and the PASID
>>>> translates according to the given domain.
>>>>
>>>> SVA given domain or UNMANAGED given domain doesn't matter to the
>>>> higher level code. The driver should implement per-domain ops as
>>>> required to get the different behaviors.
>>> Perhaps some code to clarify, we have
>>> sva_domain_ops.dev_attach_pasid() = intel_svm_attach_dev_pasid;
>>> default_domain_ops.dev_attach_pasid() = intel_iommu_attach_dev_pasid;
>>
>> Yes, keep that structure
>>   
>>> Consolidate pasid programming into dev_set_pasid() then called by both
>>> intel_svm_attach_dev_pasid() and intel_iommu_attach_dev_pasid(), right?
>>>   
>>
>> I was only suggesting that really dev_attach_pasid() op is misnamed,
>> it should be called set_dev_pasid() and act like a set, not a paired
>> attach/detach - same as the non-PASID ops.
>>
> Got it. Perhaps another patch to rename, Baolu?

Yes. I can rename it in my sva series if others are also happy with this
naming.

Best regards,
baolu

  parent reply	other threads:[~2022-05-12  1:16 UTC|newest]

Thread overview: 22+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-05-10 21:07 [PATCH v3 0/4] Enable PASID for DMA API users Jacob Pan
2022-05-10 21:07 ` [PATCH v3 1/4] iommu/vt-d: Implement domain ops for attach_dev_pasid Jacob Pan
2022-05-10 23:21   ` Jason Gunthorpe
2022-05-11  0:23     ` Jacob Pan
2022-05-11 11:54       ` Jason Gunthorpe
2022-05-11 15:35         ` Jacob Pan
2022-05-11 16:12           ` Jason Gunthorpe
2022-05-11 17:02             ` Jacob Pan
2022-05-11 17:00               ` Jason Gunthorpe
2022-05-11 17:25                 ` Jacob Pan
2022-05-11 18:29                   ` Jason Gunthorpe
2022-05-18 18:42                     ` Jacob Pan
2022-05-18 18:52                       ` Jason Gunthorpe
2022-05-19 21:05                         ` Jacob Pan
2022-05-12  1:16                   ` Baolu Lu [this message]
2022-05-12  6:22                 ` Baolu Lu
2022-05-12 11:52                   ` Jason Gunthorpe
2022-05-10 21:07 ` [PATCH v3 2/4] iommu: Add PASID support for DMA mapping API users Jacob Pan
2022-05-10 23:28   ` Jason Gunthorpe
2022-05-11  0:43     ` Jacob Pan
2022-05-10 21:07 ` [PATCH v3 3/4] dmaengine: idxd: Use DMA API for in-kernel DMA with PASID Jacob Pan
2022-05-10 21:07 ` [PATCH v3 4/4] iommu/vt-d: Delete unused SVM flag Jacob Pan

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=00a972f4-1fe2-2eb0-fcf5-d454f3b9dcc6@linux.intel.com \
    --to=baolu.lu@linux.intel.com \
    --cc=ashok.raj@intel.com \
    --cc=dave.jiang@intel.com \
    --cc=dmaengine@vger.kernel.org \
    --cc=dwmw2@infradead.org \
    --cc=eric.auger@redhat.com \
    --cc=iommu@lists.linux-foundation.org \
    --cc=jacob.jun.pan@linux.intel.com \
    --cc=jean-philippe@linaro.com \
    --cc=jgg@nvidia.com \
    --cc=joro@8bytes.org \
    --cc=kevin.tian@intel.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=robin.murphy@arm.com \
    --cc=vkoul@kernel.org \
    --cc=will@kernel.org \
    --cc=yi.l.liu@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).