linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Vincenzo Frascino <vincenzo.frascino@arm.com>
To: Andrey Konovalov <andreyknvl@google.com>,
	Dmitry Vyukov <dvyukov@google.com>,
	Catalin Marinas <catalin.marinas@arm.com>
Cc: Will Deacon <will.deacon@arm.com>,
	kasan-dev <kasan-dev@googlegroups.com>,
	Andrey Ryabinin <aryabinin@virtuozzo.com>,
	Alexander Potapenko <glider@google.com>,
	Marco Elver <elver@google.com>,
	Evgenii Stepanov <eugenis@google.com>,
	Elena Petrova <lenaptr@google.com>,
	Branislav Rankov <Branislav.Rankov@arm.com>,
	Kevin Brodsky <kevin.brodsky@arm.com>,
	Andrew Morton <akpm@linux-foundation.org>,
	Linux ARM <linux-arm-kernel@lists.infradead.org>,
	Linux-MM <linux-mm@kvack.org>,
	LKML <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH v5 02/40] arm64: mte: Add in-kernel MTE helpers
Date: Wed, 4 Nov 2020 17:49:10 +0000	[thread overview]
Message-ID: <03d63c72-52fa-70e1-ecb9-657b2f300acd@arm.com> (raw)
In-Reply-To: <CAAeHK+wCO+J7D1_T89DG+jJrPLk3X9RsGFKxJGd0ZcUFjQT-9Q@mail.gmail.com>

Hi Andrey/Dmitry,

sorry I missed this one.

On 10/29/20 4:50 PM, Andrey Konovalov wrote:
> On Wed, Oct 28, 2020 at 12:28 PM Dmitry Vyukov <dvyukov@google.com> wrote:
>>
> 
> [...]
> 
>>> +void *mte_set_mem_tag_range(void *addr, size_t size, u8 tag)
>>> +{
>>> +       void *ptr = addr;
>>> +
>>> +       if ((!system_supports_mte()) || (size == 0))
>>> +               return addr;
>>> +
>>> +       /* Make sure that size is MTE granule aligned. */
>>> +       WARN_ON(size & (MTE_GRANULE_SIZE - 1));
>>> +
>>> +       /* Make sure that the address is MTE granule aligned. */
>>> +       WARN_ON((u64)addr & (MTE_GRANULE_SIZE - 1));
>>> +
>>> +       tag = 0xF0 | tag;
>>> +       ptr = (void *)__tag_set(ptr, tag);
>>> +
>>> +       mte_assign_mem_tag_range(ptr, size);
>>
>> This function will be called on production hot paths. I think it makes
>> sense to shave off some overheads here.
>>
>> The additional debug checks may be useful, so maybe we need an
>> additional debug mode (debug of MTE/KASAN itself)?
>>
>> Do we ever call this when !system_supports_mte()? I think we wanted to
>> have static_if's higher up the stack. Having additional checks
>> scattered across lower-level functions is overhead for every
>> malloc/free.
>>
>> Looking at how this is called from KASAN code.
>> KASAN code already ensures addr/size are properly aligned. I think we
>> should either remove the duplicate alignment checks, or do them only
>> in the additional debugging mode.
>> Does KASAN also ensure proper tag value (0xF0 mask)?
>>
>> KASAN wrapper is inlined in this patch:
>> https://linux-review.googlesource.com/c/linux/kernel/git/torvalds/linux/+/3699
>> but here we still have 2 non-inlined calls. The
>> mte_assign_mem_tag_range is kinda inherent since it's in .S. But then
>> I think this wrapper should be inlinable.
>>
>> Also, can we move mte_assign_mem_tag_range into inline asm in the
>> header? This would avoid register spills around the call in
>> malloc/free.
>>
>> The asm code seems to do the rounding of the size up at no additional
>> cost (checks remaining size > 0, right?). I think it makes sense to
>> document that as the contract and remove the additional round_up(size,
>> KASAN_GRANULE_SIZE) in KASAN code.
> 
> These are all valid concerns. It would be great to have inline asm
> mte_assign_mem_tag_range() implementation. We can also call it
> directly from KASAN code without all these additional checks.
> 
> Perhaps it makes sense to include this change into the other series
> that adds the production mode. And then squash if we decide to put
> both changes into a single one.
> 
> Vincenzo, could you write a patch that adds inline asm
> mte_assign_mem_tag_range() implementation?
> 

As Andrey said those are valid concerns, this function was originally thought
for the debugging version of kasan, but since we are planning to use it in
production the inline optimization sounds a good approach.

-- 
Regards,
Vincenzo

  reply	other threads:[~2020-11-04 17:46 UTC|newest]

Thread overview: 46+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-10-12 20:44 [PATCH v5 00/40] kasan: add hardware tag-based mode for arm64 Andrey Konovalov
2020-10-12 20:44 ` [PATCH v5 01/40] arm64: Enable armv8.5-a asm-arch option Andrey Konovalov
2020-10-12 20:44 ` [PATCH v5 02/40] arm64: mte: Add in-kernel MTE helpers Andrey Konovalov
2020-10-28 11:28   ` Dmitry Vyukov
2020-10-29 16:50     ` Andrey Konovalov
2020-11-04 17:49       ` Vincenzo Frascino [this message]
2020-10-12 20:44 ` [PATCH v5 03/40] arm64: mte: Reset the page tag in page->flags Andrey Konovalov
2020-10-12 20:44 ` [PATCH v5 04/40] arm64: kasan: Add arch layer for memory tagging helpers Andrey Konovalov
2020-10-12 20:44 ` [PATCH v5 05/40] arm64: mte: Add in-kernel tag fault handler Andrey Konovalov
2020-10-12 20:44 ` [PATCH v5 06/40] arm64: kasan: Enable in-kernel MTE Andrey Konovalov
2020-10-12 20:44 ` [PATCH v5 07/40] arm64: mte: Convert gcr_user into an exclude mask Andrey Konovalov
2020-10-12 20:44 ` [PATCH v5 08/40] arm64: mte: Switch GCR_EL1 in kernel entry and exit Andrey Konovalov
2020-10-28 10:06   ` Dmitry Vyukov
2020-10-29 16:52     ` Andrey Konovalov
2020-10-12 20:44 ` [PATCH v5 09/40] arm64: kasan: Align allocations for HW_TAGS Andrey Konovalov
2020-10-12 20:44 ` [PATCH v5 10/40] kasan: drop unnecessary GPL text from comment headers Andrey Konovalov
2020-10-12 20:44 ` [PATCH v5 11/40] kasan: KASAN_VMALLOC depends on KASAN_GENERIC Andrey Konovalov
2020-10-12 20:44 ` [PATCH v5 12/40] kasan: group vmalloc code Andrey Konovalov
2020-10-12 20:44 ` [PATCH v5 13/40] kasan: shadow declarations only for software modes Andrey Konovalov
2020-10-12 20:44 ` [PATCH v5 14/40] kasan: rename (un)poison_shadow to (un)poison_memory Andrey Konovalov
2020-10-12 20:44 ` [PATCH v5 15/40] kasan: rename KASAN_SHADOW_* to KASAN_GRANULE_* Andrey Konovalov
2020-10-12 20:44 ` [PATCH v5 16/40] kasan: only build init.c for software modes Andrey Konovalov
2020-10-12 20:44 ` [PATCH v5 17/40] kasan: split out shadow.c from common.c Andrey Konovalov
2020-10-12 20:44 ` [PATCH v5 18/40] kasan: define KASAN_GRANULE_PAGE Andrey Konovalov
2020-10-12 20:44 ` [PATCH v5 19/40] kasan: rename report and tags files Andrey Konovalov
2020-10-12 20:44 ` [PATCH v5 20/40] kasan: don't duplicate config dependencies Andrey Konovalov
2020-10-12 20:44 ` [PATCH v5 21/40] kasan: hide invalid free check implementation Andrey Konovalov
2020-10-12 20:44 ` [PATCH v5 22/40] kasan: decode stack frame only with KASAN_STACK_ENABLE Andrey Konovalov
2020-10-12 20:44 ` [PATCH v5 23/40] kasan, arm64: only init shadow for software modes Andrey Konovalov
2020-10-12 20:44 ` [PATCH v5 24/40] kasan, arm64: only use kasan_depth " Andrey Konovalov
2020-10-12 20:44 ` [PATCH v5 25/40] kasan: rename addr_has_shadow to addr_has_metadata Andrey Konovalov
2020-10-12 20:44 ` [PATCH v5 26/40] kasan: rename print_shadow_for_address to print_memory_metadata Andrey Konovalov
2020-10-12 20:44 ` [PATCH v5 27/40] kasan: kasan_non_canonical_hook only for software modes Andrey Konovalov
2020-10-12 20:44 ` [PATCH v5 28/40] kasan: rename SHADOW layout macros to META Andrey Konovalov
2020-10-12 20:44 ` [PATCH v5 29/40] kasan: separate metadata_fetch_row for each mode Andrey Konovalov
2020-10-12 20:44 ` [PATCH v5 30/40] kasan, arm64: don't allow SW_TAGS with ARM64_MTE Andrey Konovalov
2020-10-12 20:44 ` [PATCH v5 31/40] kasan: introduce CONFIG_KASAN_HW_TAGS Andrey Konovalov
2020-10-12 20:44 ` [PATCH v5 32/40] kasan: define KASAN_GRANULE_SIZE for HW_TAGS Andrey Konovalov
2020-10-12 20:44 ` [PATCH v5 33/40] kasan, x86, s390: update undef CONFIG_KASAN Andrey Konovalov
2020-10-12 20:44 ` [PATCH v5 34/40] kasan, arm64: expand CONFIG_KASAN checks Andrey Konovalov
2020-10-12 20:44 ` [PATCH v5 35/40] kasan, arm64: implement HW_TAGS runtime Andrey Konovalov
2020-10-12 20:44 ` [PATCH v5 36/40] kasan, arm64: print report from tag fault handler Andrey Konovalov
2020-10-12 20:44 ` [PATCH v5 37/40] kasan, mm: reset tags when accessing metadata Andrey Konovalov
2020-10-12 20:44 ` [PATCH v5 38/40] kasan, arm64: enable CONFIG_KASAN_HW_TAGS Andrey Konovalov
2020-10-12 20:44 ` [PATCH v5 39/40] kasan: add documentation for hardware tag-based mode Andrey Konovalov
2020-10-12 20:44 ` [PATCH v5 40/40] kselftest/arm64: Check GCR_EL1 after context switch Andrey Konovalov

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=03d63c72-52fa-70e1-ecb9-657b2f300acd@arm.com \
    --to=vincenzo.frascino@arm.com \
    --cc=Branislav.Rankov@arm.com \
    --cc=akpm@linux-foundation.org \
    --cc=andreyknvl@google.com \
    --cc=aryabinin@virtuozzo.com \
    --cc=catalin.marinas@arm.com \
    --cc=dvyukov@google.com \
    --cc=elver@google.com \
    --cc=eugenis@google.com \
    --cc=glider@google.com \
    --cc=kasan-dev@googlegroups.com \
    --cc=kevin.brodsky@arm.com \
    --cc=lenaptr@google.com \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=will.deacon@arm.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).