linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: William Kucharski <william.kucharski@oracle.com>
To: Steven Rostedt <rostedt@goodmis.org>
Cc: Ingo Molnar <mingo@redhat.com>, Tejun Heo <tj@kernel.org>,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH] cgroup: Trace event cgroup id fields should be u64
Date: Wed, 1 Dec 2021 15:47:24 +0000	[thread overview]
Message-ID: <087E34E0-A259-4BC2-82DF-8FD7665CF22C@oracle.com> (raw)
In-Reply-To: <20211201104558.230196a7@gandalf.local.home>

No problem, it makes my life easier for V2. :-)

Thanks!!

> On Dec 1, 2021, at 8:45 AM, Steven Rostedt <rostedt@goodmis.org> wrote:
> 
> On Wed,  1 Dec 2021 07:40:43 -0700
> William Kucharski <william.kucharski@oracle.com> wrote:
> 
>> Various trace event fields that store cgroup IDs were declared
>> as ints, but cgroup_id(() returns a u64 and the conversion was
>> not intended.
>> 
>> Also remove extraneous spaces in fields that are no longer proper C style.
> 
> Um, actually, please do not do this!
> 
>> 
>> Fixes: 743210386c03 ("cgroup: use cgrp->kn->id as the cgroup ID")
>> Signed-off-by: William Kucharski <william.kucharski@oracle.com>
>> ---
>> include/trace/events/cgroup.h | 42 +++++++++++++++++------------------
>> 1 file changed, 21 insertions(+), 21 deletions(-)
>> 
>> diff --git a/include/trace/events/cgroup.h b/include/trace/events/cgroup.h
>> index 7f42a3de59e6..a85b01aa1fff 100644
>> --- a/include/trace/events/cgroup.h
>> +++ b/include/trace/events/cgroup.h
>> @@ -15,9 +15,9 @@ DECLARE_EVENT_CLASS(cgroup_root,
>> 	TP_ARGS(root),
>> 
>> 	TP_STRUCT__entry(
>> -		__field(	int,		root			)
>> -		__field(	u16,		ss_mask			)
>> -		__string(	name,		root->name		)
>> +		__field(int, root)
>> +		__field(u16, ss_mask)
>> +		__string(name, root->name)
> 
> The spaces are there for a reason. These are special macros and not C code.
> It's defining a structure, and the spacing is to imitate just that!
> 
> struct __entry {
> 	int		root;
> 	u16		ss_mask;
> 	name		root->name;
> };
> 
> 
> See the difference. You just made it less readable than the original.
> 
> So leave it alone.
> 
> NACK on the style changes.
> 
> -- Steve
> 
> 
>> 	),
>> 
>> 	TP_fast_assign(
>> @@ -58,10 +58,10 @@ DECLARE_EVENT_CLASS(cgroup,
>> 	TP_ARGS(cgrp, path),
>> 
>> 	TP_STRUCT__entry(
>> -		__field(	int,		root			)
>> -		__field(	int,		id			)
>> -		__field(	int,		level			)
>> -		__string(	path,		path			)
>> +		__field(int, root)
>> +		__field(u64, id)
>> +		__field(int, level)
>> +		__string(path, path)
>> 	),
>> 
>> 	TP_fast_assign(
>> @@ -71,7 +71,7 @@ DECLARE_EVENT_CLASS(cgroup,
>> 		__assign_str(path, path);
>> 	),
>> 
>> -	TP_printk("root=%d id=%d level=%d path=%s",
>> +	TP_printk("root=%d id=%llu level=%d path=%s",
>> 		  __entry->root, __entry->id, __entry->level, __get_str(path))
>> );
>> 
>> @@ -125,12 +125,12 @@ DECLARE_EVENT_CLASS(cgroup_migrate,
>> 	TP_ARGS(dst_cgrp, path, task, threadgroup),
>> 
>> 	TP_STRUCT__entry(
>> -		__field(	int,		dst_root		)
>> -		__field(	int,		dst_id			)
>> -		__field(	int,		dst_level		)
>> -		__field(	int,		pid			)
>> -		__string(	dst_path,	path			)
>> -		__string(	comm,		task->comm		)
>> +		__field(int, dst_root)
>> +		__field(u64, dst_id)
>> +		__field(int, dst_level)
>> +		__field(int, pid)
>> +		__string(dst_path, path)
>> +		__string(comm, task->comm)
>> 	),
>> 
>> 	TP_fast_assign(
>> @@ -142,7 +142,7 @@ DECLARE_EVENT_CLASS(cgroup_migrate,
>> 		__assign_str(comm, task->comm);
>> 	),
>> 
>> -	TP_printk("dst_root=%d dst_id=%d dst_level=%d dst_path=%s pid=%d comm=%s",
>> +	TP_printk("dst_root=%d dst_id=%llu dst_level=%d dst_path=%s pid=%d comm=%s",
>> 		  __entry->dst_root, __entry->dst_id, __entry->dst_level,
>> 		  __get_str(dst_path), __entry->pid, __get_str(comm))
>> );
>> @@ -170,11 +170,11 @@ DECLARE_EVENT_CLASS(cgroup_event,
>> 	TP_ARGS(cgrp, path, val),
>> 
>> 	TP_STRUCT__entry(
>> -		__field(	int,		root			)
>> -		__field(	int,		id			)
>> -		__field(	int,		level			)
>> -		__string(	path,		path			)
>> -		__field(	int,		val			)
>> +		__field(int, root)
>> +		__field(u64, id)
>> +		__field(int, level)
>> +		__string(path, path)
>> +		__field(int, val)
>> 	),
>> 
>> 	TP_fast_assign(
>> @@ -185,7 +185,7 @@ DECLARE_EVENT_CLASS(cgroup_event,
>> 		__entry->val = val;
>> 	),
>> 
>> -	TP_printk("root=%d id=%d level=%d path=%s val=%d",
>> +	TP_printk("root=%d id=%llu level=%d path=%s val=%d",
>> 		  __entry->root, __entry->id, __entry->level, __get_str(path),
>> 		  __entry->val)
>> );
> 


  reply	other threads:[~2021-12-01 15:49 UTC|newest]

Thread overview: 6+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-12-01 14:40 [PATCH] cgroup: Trace event cgroup id fields should be u64 William Kucharski
2021-12-01 14:54 ` Greg Kroah-Hartman
2021-12-01 15:16   ` William Kucharski
2021-12-01 15:45 ` Steven Rostedt
2021-12-01 15:47   ` William Kucharski [this message]
2021-12-01 15:59   ` William Kucharski

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=087E34E0-A259-4BC2-82DF-8FD7665CF22C@oracle.com \
    --to=william.kucharski@oracle.com \
    --cc=gregkh@linuxfoundation.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@redhat.com \
    --cc=rostedt@goodmis.org \
    --cc=tj@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).