linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: "Norman Diamond" <ndiamond@wta.att.ne.jp>
To: <linux-kernel@vger.kernel.org>
Subject: Re: Tried to run 2.6.0-test1
Date: Mon, 21 Jul 2003 14:48:59 +0900	[thread overview]
Message-ID: <0be401c34f4b$e33775b0$64ee4ca5@DIAMONDLX60> (raw)
In-Reply-To: <200307201526.h6KFQs9K003972@turing-police.cc.vt.edu>

Again I cannot keep up with the mailing list.  If anyone wishes to advise or
has questions, please kindly contact me directly.

1.  Trying to upgrade modutils.

I've downloaded modutils-2.4.21-18.src.rpm from Rusty Russell's directory on
ftp.kernel.org.  Not being an rpm expert, I tried "rpm --rebuild" on it.
The compilation steps assume -mcpu=i686.  I need to specify that the cpu is
an i586.

"man rpm" and "info rpm" both say that arch-vendor-os can be designated,
but -march=i486 is already fine with me, the problem is the cpu not the
arch.  I'm not sure what it would mean to try specifying a vendor (Intel) or
OS (Linux).  There seems to be no way to specify the cpu in "rpm --rebuild".

I also tried rpm -ivh and finally found where three files got installed to.
Two gzipped tarballs and one spec file.  The spec file doesn't specify the
cpu, as far as I can tell.

Odds are I can probably gunzip and tar and compile the new modutils, but
will the resulting executables get installed into the right places without
using the rpm command and its spec file, I'm not sure I want to chance it.

My .config file for the kernel sources correctly designates the cpu as an
i586mmx, but I guess modutils shouldn't be expected to guess which kernel
sources to find and extract the cpu type from it.

2.  Blank screen during/after boot.

Two people recommended alternative locations for the "post-halloween"
document and I got one.

> Known gotchas.
> Certain known bugs are being reported over and over. Here are the
>     workarounds.
> - Blank screen after decompressing kernel?
>   Make sure your .config has
>   CONFIG_INPUT=y, CONFIG_VT=y, CONFIG_VGA_CONSOLE=y and
>     CONFIG_VT_CONSOLE=y

It has.  The screen is still blank after decompressing the kernel.  In SuSE
8.1 the screen goes completely blank and never recovers.  In Red Hat  the
screen continues displaying the message about decompressing the kernel but
freezes there until X comes up, and then returns to that same frozen text
screen during shutdown, so I have to guess when it's OK to turn off the
power.


  parent reply	other threads:[~2003-07-21  5:35 UTC|newest]

Thread overview: 12+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2003-07-20 15:03 Norman Diamond
2003-07-20 15:26 ` Valdis.Kletnieks
2003-07-20 15:48   ` Norman Diamond
2003-07-20 16:02     ` Diego Calleja García
2003-07-20 19:20     ` Gabor MICSKO
2003-07-21  5:48   ` Norman Diamond [this message]
2003-07-21  6:23 Norman Diamond
2003-07-21  6:52 ` Brett
2003-07-21  7:06   ` Norman Diamond
2003-07-21  7:18     ` Brett
2003-07-21 10:07 ` Gene Heskett
2003-07-21  6:56 Norman Diamond

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to='0be401c34f4b$e33775b0$64ee4ca5@DIAMONDLX60' \
    --to=ndiamond@wta.att.ne.jp \
    --cc=linux-kernel@vger.kernel.org \
    --subject='Re: Tried to run 2.6.0-test1' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).