linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* Linux 2.6-pre1 Does not boot on ASUS L3800C: lock up in acpi while "Executing all Devices _STA and_INIT methods"
@ 2003-07-14 13:24 Eric Valette
  2003-07-14 16:40 ` [ACPI] " Karol Kozimor
  2003-07-14 18:38 ` Tugrul Galatali
  0 siblings, 2 replies; 6+ messages in thread
From: Eric Valette @ 2003-07-14 13:24 UTC (permalink / raw)
  To: linux-kernel, andrew.grover; +Cc: acpi-devel

I happily run 2.4.21-pre5 with ACPI enabled and everything works just 
fine. I tried today 2.6-pre1 with exactly the same hardware 
configuration as the 2.4 one and the laptop does not boot. It hangs 
while dispaying : "Executing all Devices _STA and_INIT methods" 
allthough it has already printed several '.'



-- 
    __
   /  `                   	Eric Valette
  /--   __  o _.          	6 rue Paul Le Flem
(___, / (_(_(__         	35740 Pace

Tel: +33 (0)2 99 85 26 76	Fax: +33 (0)2 99 85 26 76
E-mail: eric.valette@free.fr


^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [ACPI] Linux 2.6-pre1 Does not boot on ASUS L3800C: lock up in acpi while "Executing all Devices _STA and_INIT methods"
  2003-07-14 13:24 Linux 2.6-pre1 Does not boot on ASUS L3800C: lock up in acpi while "Executing all Devices _STA and_INIT methods" Eric Valette
@ 2003-07-14 16:40 ` Karol Kozimor
  2003-07-14 18:38 ` Tugrul Galatali
  1 sibling, 0 replies; 6+ messages in thread
From: Karol Kozimor @ 2003-07-14 16:40 UTC (permalink / raw)
  To: Eric Valette; +Cc: linux-kernel, andrew.grover, acpi-devel

Thus wrote Eric Valette:
> I happily run 2.4.21-pre5 with ACPI enabled and everything works just 
> fine. I tried today 2.6-pre1 with exactly the same hardware 
> configuration as the 2.4 one and the laptop does not boot. It hangs 
> while dispaying : "Executing all Devices _STA and_INIT methods" 
> allthough it has already printed several '.'

I reported the same on ACPI devel several (18?) hours ago. For now, the
solution is to compile a kernel without APIC support. No, the noapic option
doesn't help.

The problem appeared in 2.5.74, along with changes in handling a
BIOS-disabled APIC, or so I suppose.

Best regards,

-- 
Karol 'sziwan' Kozimor
sziwan@hell.org.pl

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: Linux 2.6-pre1 Does not boot on ASUS L3800C: lock up in acpi while "Executing all Devices _STA and_INIT methods"
  2003-07-14 13:24 Linux 2.6-pre1 Does not boot on ASUS L3800C: lock up in acpi while "Executing all Devices _STA and_INIT methods" Eric Valette
  2003-07-14 16:40 ` [ACPI] " Karol Kozimor
@ 2003-07-14 18:38 ` Tugrul Galatali
  1 sibling, 0 replies; 6+ messages in thread
From: Tugrul Galatali @ 2003-07-14 18:38 UTC (permalink / raw)
  To: linux-kernel, andrew.grover, acpi-devel

On Mon, 2003-07-14 at 09:24, Eric Valette wrote:
> I happily run 2.4.21-pre5 with ACPI enabled and everything works just 
> fine. I tried today 2.6-pre1 with exactly the same hardware 
> configuration as the 2.4 one and the laptop does not boot. It hangs 
> while dispaying : "Executing all Devices _STA and_INIT methods" 
> allthough it has already printed several '.'

	I get that error plus the message I've been getting from >2.5.69
kernels when booting with ACPI on my Compaq W8000. dmesg/lspci/configs
at 

	http://acm.cs.nyu.edu/~tugrul/acpi/

	The 2.6.0-test1 error is pretty big for hand transcription, but I'll
try setting up serial console if requested.

	Tugrul Galatali



^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: Linux 2.6-pre1 Does not boot on ASUS L3800C: lock up in acpi while  "Executing all Devices _STA and_INIT methods"
  2003-07-20 13:18 ` Eric Valette
@ 2003-07-20 18:00   ` Karol Kozimor
  0 siblings, 0 replies; 6+ messages in thread
From: Karol Kozimor @ 2003-07-20 18:00 UTC (permalink / raw)
  To: Eric Valette; +Cc: Grover, Andrew, linux-kernel, acpi-devel

Thus wrote Eric Valette:
> BTW : I still cannot boot as the radeon framebuffer driver make things 
> unreable. I will stcik with 2.4 for a while...

Boot the framebuffer into 1024x768@60 mode, every other I tried simply
doesn't work.
Best regards,

-- 
Karol 'sziwan' Kozimor
sziwan@hell.org.pl

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: Linux 2.6-pre1 Does not boot on ASUS L3800C: lock up in acpi while  "Executing all Devices _STA and_INIT methods"
  2003-07-14 18:56 Grover, Andrew
@ 2003-07-20 13:18 ` Eric Valette
  2003-07-20 18:00   ` Karol Kozimor
  0 siblings, 1 reply; 6+ messages in thread
From: Eric Valette @ 2003-07-20 13:18 UTC (permalink / raw)
  To: Grover, Andrew; +Cc: linux-kernel, acpi-devel, sziwan

Grover, Andrew wrote:
>>From: Eric Valette [mailto:eric.valette@free.fr] 
>>I happily run 2.4.21-pre5 with ACPI enabled and everything works just 
>>fine. I tried today 2.6-pre1 with exactly the same hardware 
>>configuration as the 2.4 one and the laptop does not boot. It hangs 
>>while dispaying : "Executing all Devices _STA and_INIT methods" 
>>allthough it has already printed several '.'
> 
> 
> That's weird. They should have the same version of the ACPI code...


Just to try to help, as suggested by Karol Kasimor, disabling the APIC 
make the code pass this section. The APIC is now really unconditionnaly 
enabled (regardless of BIOS settings) due to this change in 2.5.74...

<http://lists.insecure.org/lists/linux-kernel/2003/Jun/5840.html>

So this is an interaction between APIC and ACPI... I still think it 
should not crash at least...

BTW : I still cannot boot as the radeon framebuffer driver make things 
unreable. I will stcik with 2.4 for a while...

-- eric


^ permalink raw reply	[flat|nested] 6+ messages in thread

* RE: Linux 2.6-pre1 Does not boot on ASUS L3800C: lock up in acpi while  "Executing all Devices _STA and_INIT methods"
@ 2003-07-14 18:56 Grover, Andrew
  2003-07-20 13:18 ` Eric Valette
  0 siblings, 1 reply; 6+ messages in thread
From: Grover, Andrew @ 2003-07-14 18:56 UTC (permalink / raw)
  To: eric.valette, linux-kernel; +Cc: acpi-devel

> From: Eric Valette [mailto:eric.valette@free.fr] 
> I happily run 2.4.21-pre5 with ACPI enabled and everything works just 
> fine. I tried today 2.6-pre1 with exactly the same hardware 
> configuration as the 2.4 one and the laptop does not boot. It hangs 
> while dispaying : "Executing all Devices _STA and_INIT methods" 
> allthough it has already printed several '.'

That's weird. They should have the same version of the ACPI code...

-- Andy

^ permalink raw reply	[flat|nested] 6+ messages in thread

end of thread, other threads:[~2003-07-20 17:43 UTC | newest]

Thread overview: 6+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2003-07-14 13:24 Linux 2.6-pre1 Does not boot on ASUS L3800C: lock up in acpi while "Executing all Devices _STA and_INIT methods" Eric Valette
2003-07-14 16:40 ` [ACPI] " Karol Kozimor
2003-07-14 18:38 ` Tugrul Galatali
2003-07-14 18:56 Grover, Andrew
2003-07-20 13:18 ` Eric Valette
2003-07-20 18:00   ` Karol Kozimor

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).