linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Joe Perches <joe@perches.com>
To: Rob Herring <robh@kernel.org>
Cc: linux-kernel@vger.kernel.org,
	Andrew Morton <akpm@linux-foundation.org>,
	Andy Whitcroft <apw@canonical.com>
Subject: Re: [PATCH] checkpatch: DT bindings should be a separate patch
Date: Thu, 09 Aug 2018 18:07:47 -0700	[thread overview]
Message-ID: <13b3efc8ba75f3e857934580effcdc8675bad6c8.camel@perches.com> (raw)
In-Reply-To: <20180809205032.22205-1-robh@kernel.org>

On Thu, 2018-08-09 at 14:50 -0600, Rob Herring wrote:
> Devicetree bindings should be their own patch as documented in
> Documentation/devicetree/bindings/submitting-patches.txt section I.1.
> This is because bindings are logically independent from a driver
> implementation, they have a different maintainer (even though they often
> are applied via the same tree), and it makes for a cleaner history in
> the DT only tree created with git-filter-branch.
[]
> diff --git a/scripts/checkpatch.pl b/scripts/checkpatch.pl
[]
> @@ -2236,6 +2236,7 @@ sub process {
>  	our $clean = 1;
>  	my $signoff = 0;
>  	my $is_patch = 0;
> +	my $is_binding_patch = -1;
>  	my $in_header_lines = $file ? 0 : 1;
>  	my $in_commit_log = 0;		#Scanning lines before patch
>  	my $has_commit_log = 0;		#Encountered lines before patch
> @@ -2485,6 +2486,27 @@ sub process {
>  				$check = $check_orig;
>  			}
>  			$checklicenseline = 1;
> +
> +			if ($realfile !~ /MAINTAINERS/) {

Should probably be /^MAINTAINERS/

> +				my $mixed = 0;
> +				if ($realfile =~ /(Documentation\/devicetree|include\/dt-bindings).*/) {

This should have a ^ for the start of the filename and
generally, this is easier to read using m@...@ like:

				if ($realfile =~ m@^(?:Documentation/devicetree/|include/dt-bindings/)@) {

> +					if ($is_binding_patch == 0) {
> +						$mixed = 1;
> +					}
> +					$is_binding_patch = 1;
> +				} else {
> +					if ($is_binding_patch == 1) {
> +						$mixed = 1;
> +					}
> +					$is_binding_patch = 0;
> +				}

Perhaps there is simpler logic using an xor.

> +				if ($mixed == 1) {
> +					WARN("DT_SPLIT_BINDING_PATCH",
> +					     "DT binding docs and includes should be a separate patch\n");
> +				}

Perhaps add 'see: Documentation/devicetree/bindings/submitting-patches.txt'

> +			}



      parent reply	other threads:[~2018-08-10  1:07 UTC|newest]

Thread overview: 3+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-08-09 20:50 [PATCH] checkpatch: DT bindings should be a separate patch Rob Herring
2018-08-10  0:53 ` Andrew Morton
2018-08-10  1:07 ` Joe Perches [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=13b3efc8ba75f3e857934580effcdc8675bad6c8.camel@perches.com \
    --to=joe@perches.com \
    --cc=akpm@linux-foundation.org \
    --cc=apw@canonical.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=robh@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).