From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1754076AbbDGRmv (ORCPT ); Tue, 7 Apr 2015 13:42:51 -0400 Received: from g4t3426.houston.hp.com ([15.201.208.54]:45296 "EHLO g4t3426.houston.hp.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1750983AbbDGRmr (ORCPT ); Tue, 7 Apr 2015 13:42:47 -0400 Message-ID: <1428428561.2556.63.camel@j-VirtualBox> Subject: Re: sched: Improve load balancing in the presence of idle CPUs From: Jason Low To: Tim Chen Cc: Morten Rasmussen , Preeti U Murthy , "peterz@infradead.org" , "mingo@kernel.org" , Daniel Lezcano , "riel@redhat.com" , "vincent.guittot@linaro.org" , "srikar@linux.vnet.ibm.com" , "pjt@google.com" , "benh@kernel.crashing.org" , "efault@gmx.de" , "linux-kernel@vger.kernel.org" , "iamjoonsoo.kim@lge.com" , "svaidy@linux.vnet.ibm.com" , jason.low2@hp.com Date: Tue, 07 Apr 2015 10:42:41 -0700 In-Reply-To: <1428100518.660.34.camel@schen9-desk2.jf.intel.com> References: <1427741729.5694.24.camel@j-VirtualBox> <551A5CCE.70008@linux.vnet.ibm.com> <1427828056.2492.24.camel@j-VirtualBox> <551B9514.80701@linux.vnet.ibm.com> <20150401170418.GX18994@e105550-lin.cambridge.arm.com> <1427954347.2556.43.camel@j-VirtualBox> <1428100518.660.34.camel@schen9-desk2.jf.intel.com> Content-Type: text/plain; charset="UTF-8" X-Mailer: Evolution 3.2.3-0ubuntu6 Content-Transfer-Encoding: 7bit Mime-Version: 1.0 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Fri, 2015-04-03 at 15:35 -0700, Tim Chen wrote: > I think we can get rid of the done_balancing boolean > and make it a bit easier to read if we change the above code to > > diff --git a/kernel/sched/fair.c b/kernel/sched/fair.c > index bcfe320..08317dc 100644 > --- a/kernel/sched/fair.c > +++ b/kernel/sched/fair.c > @@ -7557,8 +7557,13 @@ static void nohz_idle_balance(struct rq *this_rq, enum cpu_idle_type idle) > * work being done for other cpus. Next load > * balancing owner will pick it up. > */ > - if (need_resched()) > - break; > + if (need_resched()) { > + /* preparing to bail, kicking other cpu to continue */ > + clear_bit(NOHZ_BALANCE_KICK, nohz_flags(this_cpu)); > + if (nohz_kick_needed(this_rq)) > + nohz_balance_kick(); > + return; > + } Hi Tim, We would also need the nohz_kick_needed/nohz_balance_kick if we initially find that the current CPU is not idle (at the beginning of nohz_idle_balance). In the above case, we would need to add the code to 2 locations. Would it be better to still keep the done_balancing to avoid having duplicate code?