From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1753430AbbDGTju (ORCPT ); Tue, 7 Apr 2015 15:39:50 -0400 Received: from mga14.intel.com ([192.55.52.115]:59811 "EHLO mga14.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1750883AbbDGTjs (ORCPT ); Tue, 7 Apr 2015 15:39:48 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.11,539,1422950400"; d="scan'208";a="676523777" Message-ID: <1428435564.660.39.camel@schen9-desk2.jf.intel.com> Subject: Re: sched: Improve load balancing in the presence of idle CPUs From: Tim Chen To: Jason Low Cc: Morten Rasmussen , Preeti U Murthy , "peterz@infradead.org" , "mingo@kernel.org" , Daniel Lezcano , "riel@redhat.com" , "vincent.guittot@linaro.org" , "srikar@linux.vnet.ibm.com" , "pjt@google.com" , "benh@kernel.crashing.org" , "efault@gmx.de" , "linux-kernel@vger.kernel.org" , "iamjoonsoo.kim@lge.com" , "svaidy@linux.vnet.ibm.com" Date: Tue, 07 Apr 2015 12:39:24 -0700 In-Reply-To: <1428428561.2556.63.camel@j-VirtualBox> References: <1427741729.5694.24.camel@j-VirtualBox> <551A5CCE.70008@linux.vnet.ibm.com> <1427828056.2492.24.camel@j-VirtualBox> <551B9514.80701@linux.vnet.ibm.com> <20150401170418.GX18994@e105550-lin.cambridge.arm.com> <1427954347.2556.43.camel@j-VirtualBox> <1428100518.660.34.camel@schen9-desk2.jf.intel.com> <1428428561.2556.63.camel@j-VirtualBox> Content-Type: text/plain; charset="UTF-8" X-Mailer: Evolution 3.8.5 (3.8.5-2.fc19) Mime-Version: 1.0 Content-Transfer-Encoding: 7bit Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Tue, 2015-04-07 at 10:42 -0700, Jason Low wrote: > On Fri, 2015-04-03 at 15:35 -0700, Tim Chen wrote: > > I think we can get rid of the done_balancing boolean > > and make it a bit easier to read if we change the above code to > > > > diff --git a/kernel/sched/fair.c b/kernel/sched/fair.c > > index bcfe320..08317dc 100644 > > --- a/kernel/sched/fair.c > > +++ b/kernel/sched/fair.c > > @@ -7557,8 +7557,13 @@ static void nohz_idle_balance(struct rq *this_rq, enum cpu_idle_type idle) > > * work being done for other cpus. Next load > > * balancing owner will pick it up. > > */ > > - if (need_resched()) > > - break; > > + if (need_resched()) { > > + /* preparing to bail, kicking other cpu to continue */ > > + clear_bit(NOHZ_BALANCE_KICK, nohz_flags(this_cpu)); > > + if (nohz_kick_needed(this_rq)) > > + nohz_balance_kick(); > > + return; > > + } > > Hi Tim, > > We would also need the nohz_kick_needed/nohz_balance_kick if we > initially find that the current CPU is not idle (at the beginning of > nohz_idle_balance). In the above case, we would need to add the code to > 2 locations. > > Would it be better to still keep the done_balancing to avoid having > duplicate code? > How about consolidating the code for passing the nohz balancing and call it at both places. Something like below. Make the code more readable. Tim diff --git a/kernel/sched/fair.c b/kernel/sched/fair.c index 40667cb..16f6904 100644 --- a/kernel/sched/fair.c +++ b/kernel/sched/fair.c @@ -7531,6 +7531,15 @@ out: } #ifdef CONFIG_NO_HZ_COMMON +static inline int nohz_kick_needed(struct rq *rq); + +static void inline pass_nohz_balance(struct rq *this_rq, int this_cpu) +{ + clear_bit(NOHZ_BALANCE_KICK, nohz_flags(this_cpu)); + if (nohz_kick_needed(this_rq)) + nohz_balancer_kick(); +} + /* * In CONFIG_NO_HZ_COMMON case, the idle balance kickee will do the * rebalancing for all the cpus for whom scheduler ticks are stopped. @@ -7542,8 +7551,10 @@ static void nohz_idle_balance(struct rq *this_rq, enum cpu_idle_type idle) int balance_cpu; if (idle != CPU_IDLE || - !test_bit(NOHZ_BALANCE_KICK, nohz_flags(this_cpu))) - goto end; + !test_bit(NOHZ_BALANCE_KICK, nohz_flags(this_cpu))) { + pass_nohz_balance(this_rq, this_cpu); + return; + } for_each_cpu(balance_cpu, nohz.idle_cpus_mask) { if (balance_cpu == this_cpu || !idle_cpu(balance_cpu)) @@ -7554,8 +7565,10 @@ static void nohz_idle_balance(struct rq *this_rq, enum cpu_idle_type idle) * work being done for other cpus. Next load * balancing owner will pick it up. */ - if (need_resched()) - break; + if (need_resched()) { + pass_nohz_balance(this_rq, this_cpu); + return; + } rq = cpu_rq(balance_cpu); @@ -7575,7 +7588,6 @@ static void nohz_idle_balance(struct rq *this_rq, enum cpu_idle_type idle) this_rq->next_balance = rq->next_balance; } nohz.next_balance = this_rq->next_balance; -end: clear_bit(NOHZ_BALANCE_KICK, nohz_flags(this_cpu)); }