From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1751934AbcCKSf7 (ORCPT ); Fri, 11 Mar 2016 13:35:59 -0500 Received: from g4t3427.houston.hp.com ([15.201.208.55]:60442 "EHLO g4t3427.houston.hp.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751835AbcCKSf4 (ORCPT ); Fri, 11 Mar 2016 13:35:56 -0500 Message-ID: <1457724504.6393.151.camel@hpe.com> Subject: Re: [PATCH 1/2] x86/mm/pat: Change pat_disable() to emulate PAT table From: Toshi Kani To: Borislav Petkov Cc: "mingo@kernel.org" , "hpa@zytor.com" , "tglx@linutronix.de" , "mcgrof@suse.com" , "jgross@suse.com" , "paul.gortmaker@windriver.com" , "x86@kernel.org" , "linux-kernel@vger.kernel.org" Date: Fri, 11 Mar 2016 12:28:24 -0700 In-Reply-To: <20160311155439.GF4312@pd.tnic> References: <1457671546-13486-1-git-send-email-toshi.kani@hpe.com> <1457671546-13486-2-git-send-email-toshi.kani@hpe.com> <20160311091229.GA4347@pd.tnic> <1457713660.6393.55.camel@hpe.com> <20160311155439.GF4312@pd.tnic> Content-Type: text/plain; charset="UTF-8" X-Mailer: Evolution 3.18.4 (3.18.4-1.fc23) Mime-Version: 1.0 Content-Transfer-Encoding: 8bit Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Fri, 2016-03-11 at 16:54 +0100, Borislav Petkov wrote: > On Fri, Mar 11, 2016 at 09:27:40AM -0700, Toshi Kani wrote: > > How about pat_disable_setup()?  It's only used for the disabled case, > > so I'd prefer to keep the word "disable". > > What for? > > Renaming pat_init() to pat_setup() is perfectly fine as it sets up PAT > after looking at pat_disabled() setting and after looking at the CPU > vendor. Sounds like a perfectly sane design to me. Sorry, I meant to say -- "How about renaming pat_disable_init() to pat_disable_setup()?" since I thought you had suggested to rename pat_disable_init() to pat_setup().  I am still in favor of having a separate setup func for the disabled case. > > Yes, calling pat_init() from pat_disable() works too. I changed it in > > this way because: > >  - pat_bsp_init() calls pat_disabled() in an error case. It is simpler > > to avoid a recursive call to pat_init(). > > So do this: > > static inline void pat_disable(const char *reason) > { > if (!__pat_enabled) > return; Hmm...  I do not think I understand this.  When pat_bsp_init() calls pat_disable(), 'pat' has been set to the "Full PAT support" setup.  So, we need to reset 'pat' to the "No PAT" setup.  How is this handled in your case? > >  - pat_bsp_init() has two different error paths, 1) call pat_disable() > > and return, and 2) goto done and call pat_init_cache_modes(). We can > > remove case 2) to keep the error handling consistent in this way. > > Above. > > > > Then you don't have to add yet another static disable_init_done but > > > rely on boot_cpu_done which gets set in pat_init(). > > > > Right, but it will do 'boot_cpu_done = true' twice, and this implicit > > recursive call may cause an issue in future if someone makes change > > carelessly. > > So move boot_cpu_done into pat_bsp_init() and make it protect that > function from a being called a second time. I think this leads more complication in the end.  pat_init() covers (too) many scenarios already, and moving the disabled setup case out will simplify it, IMHO. Thanks, -Toshi