linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [RFC PATCH v2] tools: iio: Rename generic_buffer to iio_generic_buffer
@ 2016-05-24 15:03 Daniel Baluta
  2016-05-29 18:58 ` Jonathan Cameron
  0 siblings, 1 reply; 2+ messages in thread
From: Daniel Baluta @ 2016-05-24 15:03 UTC (permalink / raw)
  To: jic23; +Cc: knaack.h, lars, pmeerw, linux-iio, linux-kernel, daniel.baluta

This makes it clear that generic_buffer is an IIO tool
and also complies with filename conventions in tools/iio.

Signed-off-by: Daniel Baluta <daniel.baluta@intel.com>
---
Changes since v1:
	* use -M to detect renames and make the patch easier to review

 tools/iio/Makefile                                   | 6 +++---
 tools/iio/{generic_buffer.c => iio_generic_buffer.c} | 0
 2 files changed, 3 insertions(+), 3 deletions(-)
 rename tools/iio/{generic_buffer.c => iio_generic_buffer.c} (100%)

diff --git a/tools/iio/Makefile b/tools/iio/Makefile
index 3a7a54f..e8a009b 100644
--- a/tools/iio/Makefile
+++ b/tools/iio/Makefile
@@ -1,16 +1,16 @@
 CC = $(CROSS_COMPILE)gcc
 CFLAGS += -Wall -g -D_GNU_SOURCE
 
-all: iio_event_monitor lsiio generic_buffer
+all: iio_event_monitor lsiio iio_generic_buffer
 
 iio_event_monitor: iio_event_monitor.o iio_utils.o
 
 lsiio: lsiio.o iio_utils.o
 
-generic_buffer: generic_buffer.o iio_utils.o
+iio_generic_buffer: iio_generic_buffer.o iio_utils.o
 
 %.o: %.c iio_utils.h
 
 .PHONY: clean
 clean:
-	rm -f *.o iio_event_monitor lsiio generic_buffer
+	rm -f *.o iio_event_monitor lsiio iio_generic_buffer
diff --git a/tools/iio/generic_buffer.c b/tools/iio/iio_generic_buffer.c
similarity index 100%
rename from tools/iio/generic_buffer.c
rename to tools/iio/iio_generic_buffer.c
-- 
2.5.0

^ permalink raw reply related	[flat|nested] 2+ messages in thread

* Re: [RFC PATCH v2] tools: iio: Rename generic_buffer to iio_generic_buffer
  2016-05-24 15:03 [RFC PATCH v2] tools: iio: Rename generic_buffer to iio_generic_buffer Daniel Baluta
@ 2016-05-29 18:58 ` Jonathan Cameron
  0 siblings, 0 replies; 2+ messages in thread
From: Jonathan Cameron @ 2016-05-29 18:58 UTC (permalink / raw)
  To: Daniel Baluta; +Cc: knaack.h, lars, pmeerw, linux-iio, linux-kernel

On 24/05/16 16:03, Daniel Baluta wrote:
> This makes it clear that generic_buffer is an IIO tool
> and also complies with filename conventions in tools/iio.
> 
> Signed-off-by: Daniel Baluta <daniel.baluta@intel.com>
Pretty uncontroversial bit of common sense to my mind ;)

Applied to the togreg branch of iio.git with a few changes to merge it with
recent install patch.

Pushed out as testing for the autobuilders to ignore it (probably).

Thanks,

Jonathan
> ---
> Changes since v1:
> 	* use -M to detect renames and make the patch easier to review
> 
>  tools/iio/Makefile                                   | 6 +++---
>  tools/iio/{generic_buffer.c => iio_generic_buffer.c} | 0
>  2 files changed, 3 insertions(+), 3 deletions(-)
>  rename tools/iio/{generic_buffer.c => iio_generic_buffer.c} (100%)
> 
> diff --git a/tools/iio/Makefile b/tools/iio/Makefile
> index 3a7a54f..e8a009b 100644
> --- a/tools/iio/Makefile
> +++ b/tools/iio/Makefile
> @@ -1,16 +1,16 @@
>  CC = $(CROSS_COMPILE)gcc
>  CFLAGS += -Wall -g -D_GNU_SOURCE
>  
> -all: iio_event_monitor lsiio generic_buffer
> +all: iio_event_monitor lsiio iio_generic_buffer
>  
>  iio_event_monitor: iio_event_monitor.o iio_utils.o
>  
>  lsiio: lsiio.o iio_utils.o
>  
> -generic_buffer: generic_buffer.o iio_utils.o
> +iio_generic_buffer: iio_generic_buffer.o iio_utils.o
>  
>  %.o: %.c iio_utils.h
>  
>  .PHONY: clean
>  clean:
> -	rm -f *.o iio_event_monitor lsiio generic_buffer
> +	rm -f *.o iio_event_monitor lsiio iio_generic_buffer
> diff --git a/tools/iio/generic_buffer.c b/tools/iio/iio_generic_buffer.c
> similarity index 100%
> rename from tools/iio/generic_buffer.c
> rename to tools/iio/iio_generic_buffer.c
> 

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2016-05-29 18:58 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2016-05-24 15:03 [RFC PATCH v2] tools: iio: Rename generic_buffer to iio_generic_buffer Daniel Baluta
2016-05-29 18:58 ` Jonathan Cameron

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).