linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Nobuhiro Iwamatsu <nobuhiro.iwamatsu.kw@hitachi.com>
To: Anton Vorontsov <anton@enomsg.org>,
	Colin Cross <ccross@android.com>,
	Kees Cook <keescook@chromium.org>,
	Tony Luck <tony.luck@intel.com>
Cc: linux-kernel@vger.kernel.org,
	Nobuhiro Iwamatsu <nobuhiro.iwamatsu.kw@hitachi.com>
Subject: [PATCH v5 0/5] pstore: ramoops: support multiple pmsg instances
Date: Mon, 27 Feb 2017 10:53:54 +0900	[thread overview]
Message-ID: <1488160439-7140-1-git-send-email-nobuhiro.iwamatsu.kw@hitachi.com> (raw)

The following series implements multiple pmsg. This feature allows userspace
program to control individual content aging or priority.

If a pstore backend module(e.g. ramoops) requires the multiple pmsg instances
when registering itself to pstore, multiple /dev/pmsg[ID] are created. Writes
to each /dev/pmsg[ID] are isolated each other. After reboot, the contents are
available in /sys/fs/pstore/pmsg-[backend]-[ID].

In addition, we add multiple pmsg support for ramoops. We can specify multiple
pmsg area size by its module parameter as follows.

 pmsg_size=0x1000,0x2000,...

I did check the operation of this feature on CycloneV (socfpga) Helio board.

v5:
  Add commit: "pstore: Change parameter of ramoops_free_przs()"
    - I forgot addition to previous patch series.
  Update commit: "pstore: support multiple pmsg instances"
    - Fix comment.
    - Fix initialization of num_pmsg.

v4:
  Rebase to 4.10-rc5
  The following patches have been removed from this series as similar functions
  were modified by other commit.
     - pstore: Replace four kzalloc() calls by kcalloc() in ramoops_init_przs()
     - pstore: Change parameter of ramoops_free_przs()
     - pstore: Rename 'przs' to 'dprzs' in struct ramoops_context
     - ramoops: Rename ramoops_init_prz() to ramoops_init_dprzs()

v3:
  Rebase to v4.8.
  Split patch.
  merged device_create().
  Remove Blank lines.
  Update documentiation of DT binding.
  Update parsing function of ramoops_pmsg_size, add NULL termination.
  Update module parameters for pmsg_size list.

Hiraku Toyooka (2):
  pstore: support multiple pmsg instances
  selftests/pstore: add testcases for multiple pmsg instances

Nobuhiro Iwamatsu (3):
  pstore: Change parameter of ramoops_free_przs()
  ramoops: Add __ramoops_init_prz() as generic function
  ramoops: support multiple pmsg instances

 Documentation/admin-guide/ramoops.rst              |  22 ++
 .../bindings/reserved-memory/ramoops.txt           |   6 +-
 fs/pstore/pmsg.c                                   |  23 +-
 fs/pstore/ram.c                                    | 317 ++++++++++++++++-----
 include/linux/pstore.h                             |   1 +
 include/linux/pstore_ram.h                         |   8 +-
 tools/testing/selftests/pstore/common_tests        |  21 +-
 .../selftests/pstore/pstore_post_reboot_tests      |  27 +-
 tools/testing/selftests/pstore/pstore_tests        |  14 +-
 9 files changed, 342 insertions(+), 97 deletions(-)

-- 
2.11.0

             reply	other threads:[~2017-02-27  1:54 UTC|newest]

Thread overview: 8+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2017-02-27  1:53 Nobuhiro Iwamatsu [this message]
2017-02-27  1:53 ` [PATCH v5 1/5] pstore: Change parameter of ramoops_free_przs() Nobuhiro Iwamatsu
2017-02-27  1:53 ` [PATCH v5 2/5] ramoops: Add __ramoops_init_prz() as generic function Nobuhiro Iwamatsu
2017-02-27  1:53 ` [PATCH v5 3/5] pstore: support multiple pmsg instances Nobuhiro Iwamatsu
2017-02-27  1:53 ` [PATCH v5 4/5] ramoops: " Nobuhiro Iwamatsu
2017-02-27  1:53 ` [PATCH v5 5/5] selftests/pstore: add testcases for " Nobuhiro Iwamatsu
2018-11-29 23:33 ` [PATCH v5 0/5] pstore: ramoops: support " Kees Cook
2018-12-03  3:37   ` Nobuhiro Iwamatsu

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1488160439-7140-1-git-send-email-nobuhiro.iwamatsu.kw@hitachi.com \
    --to=nobuhiro.iwamatsu.kw@hitachi.com \
    --cc=anton@enomsg.org \
    --cc=ccross@android.com \
    --cc=keescook@chromium.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=tony.luck@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).