linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: "Naveen N. Rao" <naveen.n.rao@linux.vnet.ibm.com>
To: Masami Hiramatsu <mhiramat@kernel.org>
Cc: Ananth N Mavinakayanahalli <ananth@linux.vnet.ibm.com>,
	linux-kernel@vger.kernel.org, linuxppc-dev@lists.ozlabs.org,
	Ingo Molnar <mingo@kernel.org>,
	Michael Ellerman <mpe@ellerman.id.au>
Subject: Re: [PATCH v3 3/7] kprobes: validate the symbol name length
Date: Sun, 23 Apr 2017 15:44:32 +0000	[thread overview]
Message-ID: <1492962128.c0nhtlqdo4.astroid@naverao1-tp.none> (raw)
In-Reply-To: <20170421224236.d1c53002f0b3c4750fd6f664@kernel.org>

Excerpts from Masami Hiramatsu's message of April 21, 2017 19:12:
> On Wed, 19 Apr 2017 16:38:22 +0000
> "Naveen N. Rao" <naveen.n.rao@linux.vnet.ibm.com> wrote:
> 
>> Excerpts from Masami Hiramatsu's message of April 19, 2017 20:07:
>> > On Wed, 19 Apr 2017 18:21:02 +0530
>> > "Naveen N. Rao" <naveen.n.rao@linux.vnet.ibm.com> wrote:
>> > 
>> >> When a kprobe is being registered, we use the symbol_name field to
>> >> lookup the address where the probe should be placed. Since this is a
>> >> user-provided field, let's ensure that the length of the string is
>> >> within expected limits.
>> > 
>> > Would we really need this? Of course it may filter out longer
>> > strings... anyway such name should be rejected by kallsyms.
>> 
>> I felt this would be good to have generically, as kallsyms does many 
>> string operations on the symbol name, including an unbounded 
>> strchr().
> 
> OK, so this is actually for performance reason.
> 
>> 
>> > 
>> > [...]
>> >> diff --git a/kernel/kprobes.c b/kernel/kprobes.c
>> >> index 6a128f3a7ed1..bb86681c8a10 100644
>> >> --- a/kernel/kprobes.c
>> >> +++ b/kernel/kprobes.c
>> >> @@ -1382,6 +1382,28 @@ bool within_kprobe_blacklist(unsigned long addr)
>> >>  	return false;
>> >>  }
>> >>  
>> >> +bool is_valid_kprobe_symbol_name(const char *name)
>> > 
>> > This just check the length of symbol_name buffer, and can contain
>> > some invalid chars.
>> 
>> Yes, I kept the function name generic incase we would like to do more 
>> validation in future, plus it's shorter than 
>> is_valid_kprobe_symbol_name_len() ;-)
> 
> OK, if this is enough general, we'd better define this in
> kernel/kallsyms.c or in kallsyms.h. Of course the function
> should be called is_valid_symbol_name(). :-)

I actually think this should be done in kprobes itself. The primary 
intent is to perform such validation right when we first obtain the 
input from the user. In this case, however, kallsyms_lookup_name() is 
also an exported symbol, so I do think some validation there would be 
good to have as well.

> 
>> >> +{
>> >> +	size_t sym_len;
>> >> +	char *s;
>> >> +
>> >> +	s = strchr(name, ':');
>> 
>> Hmm.. this should be strnchr(). I re-factored the code that moved the 
>> strnlen() above this below. I'll fix this.
>> 
>> >> +	if (s) {
>> >> +		sym_len = strnlen(s+1, KSYM_NAME_LEN);
>> > 
>> > If you use strnlen() here, you just need to ensure sym_len < KSYM_NAME_LEN.
>> 
>> Hmm.. not sure I follow. Are you saying the check for sym_len <= 0 is 
>> not needed?
> 
> You can check sym_len != 0, but anyway, here we concern about
> "longer" string (for performance reason), we can focus on
> such case.
> (BTW, could you also check the name != NULL at first?)
> 
> So, what I think it can be;
> 
> if (strnlen(s+1, KSYM_NAME_LEN) == KSYM_NAME_LEN ||
>     (size_t)(s - name) >= MODULE_NAME_LEN)
> 	return false;

Sure, thanks. I clearly need to refactor this code better!

- Naveen

  reply	other threads:[~2017-04-23 15:45 UTC|newest]

Thread overview: 38+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2017-04-19 12:50 [PATCH v3 0/7] powerpc: a few kprobe fixes and refactoring Naveen N. Rao
2017-04-19 12:51 ` [PATCH v3 1/7] kprobes: convert kprobe_lookup_name() to a function Naveen N. Rao
2017-04-24 22:47   ` [v3,1/7] " Michael Ellerman
2017-04-19 12:51 ` [PATCH v3 2/7] powerpc: kprobes: fix handling of function offsets on ABIv2 Naveen N. Rao
2017-04-24 22:47   ` [v3,2/7] " Michael Ellerman
2017-04-19 12:51 ` [PATCH v3 3/7] kprobes: validate the symbol name length Naveen N. Rao
2017-04-19 14:37   ` Masami Hiramatsu
2017-04-19 16:38     ` Naveen N. Rao
2017-04-21 13:42       ` Masami Hiramatsu
2017-04-23 15:44         ` Naveen N. Rao [this message]
2017-04-25  3:18           ` Masami Hiramatsu
2017-04-20  6:08   ` Michael Ellerman
2017-04-20  7:19     ` Naveen N. Rao
2017-04-21 12:32   ` [PATCH v4 3/7] kprobes: validate the symbol name provided during probe registration Naveen N. Rao
2017-04-21 13:11     ` Paul Clarke
2017-04-21 13:25       ` Naveen N. Rao
2017-04-21 13:54     ` Masami Hiramatsu
2017-04-22  5:55     ` Michael Ellerman
2017-04-23 17:41       ` Naveen N. Rao
2017-04-21 12:33   ` [PATCH v4 4/7] powerpc/kprobes: Use safer string functions in kprobe_lookup_name() Naveen N. Rao
2017-04-21 13:33     ` Paul Clarke
2017-04-21 13:36       ` Paul Clarke
2017-04-21 13:52       ` Paul Clarke
2017-04-23 17:09         ` Naveen N. Rao
2017-04-19 12:51 ` [PATCH v3 4/7] powerpc: kprobes: use " Naveen N. Rao
2017-04-21 15:06   ` David Laight
2017-04-19 12:51 ` [PATCH v3 5/7] powerpc: kprobes: factor out code to emulate instruction into a helper Naveen N. Rao
2017-04-19 14:40   ` Masami Hiramatsu
2017-04-24 22:47   ` [v3, " Michael Ellerman
2017-04-19 12:51 ` [PATCH v3 6/7] powerpc: kprobes: emulate instructions on kprobe handler re-entry Naveen N. Rao
2017-04-19 14:43   ` Masami Hiramatsu
2017-04-19 16:42     ` Naveen N. Rao
2017-04-20  6:11       ` Michael Ellerman
2017-04-21 13:48         ` Masami Hiramatsu
2017-04-24 22:47   ` [v3, " Michael Ellerman
2017-04-19 12:51 ` [PATCH v3 7/7] powerpc: kprobes: remove duplicate saving of msr Naveen N. Rao
2017-04-19 14:43   ` Masami Hiramatsu
2017-04-23 11:53   ` [v3,7/7] " Michael Ellerman

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1492962128.c0nhtlqdo4.astroid@naverao1-tp.none \
    --to=naveen.n.rao@linux.vnet.ibm.com \
    --cc=ananth@linux.vnet.ibm.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linuxppc-dev@lists.ozlabs.org \
    --cc=mhiramat@kernel.org \
    --cc=mingo@kernel.org \
    --cc=mpe@ellerman.id.au \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).