linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
To: Christoph Hellwig <hch@lst.de>,
	Amir Goldstein <amir73il@gmail.com>,
	linux-fsdevel@vger.kernel.org
Cc: Shaohua Li <shli@kernel.org>,
	Dan Williams <dan.j.williams@intel.com>,
	David Howells <dhowells@redhat.com>,
	Steven Whitehouse <swhiteho@redhat.com>,
	Mimi Zohar <zohar@linux.vnet.ibm.com>,
	linux-xfs@vger.kernel.org, linux-raid@vger.kernel.org,
	linux-nvdimm@ml01.01.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH 13/23] md: namespace private helper names
Date: Mon, 22 May 2017 21:52:27 +0300	[thread overview]
Message-ID: <1495479147.6967.70.camel@linux.intel.com> (raw)
In-Reply-To: <20170518062705.25902-14-hch@lst.de>

On Thu, 2017-05-18 at 08:26 +0200, Christoph Hellwig wrote:
> From: Amir Goldstein <amir73il@gmail.com>
> 
> The md private helper uuid_equal() collides with a generic helper
> of the same name.
> 
> Rename the md private helper to md_uuid_equal() and do the same for
> md_sb_equal().
> 

While patch is good, shouldn't it go before we introduce those helpers?

> Cc: Shaohua Li <shli@kernel.org>
> Signed-off-by: Amir Goldstein <amir73il@gmail.com>
> Signed-off-by: Christoph Hellwig <hch@lst.de>
> ---
>  drivers/md/md.c | 8 ++++----
>  1 file changed, 4 insertions(+), 4 deletions(-)
> 
> diff --git a/drivers/md/md.c b/drivers/md/md.c
> index 82f798be964f..65795cc4cb7d 100644
> --- a/drivers/md/md.c
> +++ b/drivers/md/md.c
> @@ -825,7 +825,7 @@ static int read_disk_sb(struct md_rdev *rdev, int
> size)
>  	return -EINVAL;
>  }
>  
> -static int uuid_equal(mdp_super_t *sb1, mdp_super_t *sb2)
> +static int md_uuid_equal(mdp_super_t *sb1, mdp_super_t *sb2)
>  {
>  	return	sb1->set_uuid0 == sb2->set_uuid0 &&
>  		sb1->set_uuid1 == sb2->set_uuid1 &&
> @@ -833,7 +833,7 @@ static int uuid_equal(mdp_super_t *sb1,
> mdp_super_t *sb2)
>  		sb1->set_uuid3 == sb2->set_uuid3;
>  }
>  
> -static int sb_equal(mdp_super_t *sb1, mdp_super_t *sb2)
> +static int md_sb_equal(mdp_super_t *sb1, mdp_super_t *sb2)
>  {
>  	int ret;
>  	mdp_super_t *tmp1, *tmp2;
> @@ -1025,12 +1025,12 @@ static int super_90_load(struct md_rdev *rdev,
> struct md_rdev *refdev, int minor
>  	} else {
>  		__u64 ev1, ev2;
>  		mdp_super_t *refsb = page_address(refdev->sb_page);
> -		if (!uuid_equal(refsb, sb)) {
> +		if (!md_uuid_equal(refsb, sb)) {
>  			pr_warn("md: %s has different UUID to %s\n",
>  				b, bdevname(refdev->bdev,b2));
>  			goto abort;
>  		}
> -		if (!sb_equal(refsb, sb)) {
> +		if (!md_sb_equal(refsb, sb)) {
>  			pr_warn("md: %s has same UUID but different
> superblock to %s\n",
>  				b, bdevname(refdev->bdev, b2));
>  			goto abort;

-- 
Andy Shevchenko <andriy.shevchenko@linux.intel.com>
Intel Finland Oy

  parent reply	other threads:[~2017-05-22 18:52 UTC|newest]

Thread overview: 50+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2017-05-18  6:26 cleanup UUID types V3 Christoph Hellwig
2017-05-18  6:26 ` [PATCH 01/23] xfs: use uuid_copy() helper to abstract uuid_t Christoph Hellwig
2017-05-18 13:27   ` Brian Foster
2017-05-18 23:32   ` Darrick J. Wong
2017-05-18  6:26 ` [PATCH 02/23] xfs: use uuid_be to implement the uuid_t type Christoph Hellwig
2017-05-18 13:27   ` Brian Foster
2017-05-18 23:34   ` Darrick J. Wong
2017-05-18  6:26 ` [PATCH 03/23] uuid: remove uuid_be defintions from the uapi header Christoph Hellwig
2017-05-18  7:12   ` Joe Perches
2017-05-18  7:13     ` Christoph Hellwig
2017-05-19 10:58     ` David Howells
2017-05-21  6:55       ` Christoph Hellwig
2017-05-18  6:26 ` [PATCH 04/23] uuid: rename uuid types Christoph Hellwig
2017-05-18 17:42   ` Darrick J. Wong
2017-05-18  6:26 ` [PATCH 05/23] uuid: don't export guid_index and uuid_index Christoph Hellwig
2017-05-18  6:26 ` [PATCH 06/23] uuid: add the v1 layout to uuid_t Christoph Hellwig
2017-05-18  6:26 ` [PATCH 07/23] uuid: hoist helpers uuid_equal() and uuid_copy() from xfs Christoph Hellwig
2017-05-18  6:26 ` [PATCH 08/23] uuid: hoist uuid_is_null() helper from libnvdimm Christoph Hellwig
2017-05-18  6:26 ` [PATCH 09/23] S390/sysinfo: use uuid_is_null instead of opencoding it Christoph Hellwig
2017-05-18  6:26 ` [PATCH 10/23] afs: switch to use uuid_t and uuid_gen Christoph Hellwig
2017-05-22 18:49   ` Andy Shevchenko
2017-05-23  8:49     ` Christoph Hellwig
2017-05-23 13:11       ` Andy Shevchenko
2017-05-25 13:00         ` Christoph Hellwig
2017-05-25 13:29           ` Andy Shevchenko
2017-05-18  6:26 ` [PATCH 11/23] uuid: remove struct uuid_v1 Christoph Hellwig
2017-05-18  6:26 ` [PATCH 12/23] xfs: remove uuid_getnodeuniq and xfs_uu_t Christoph Hellwig
2017-05-18 13:27   ` Brian Foster
2017-05-18 23:35   ` Darrick J. Wong
2017-05-18  6:26 ` [PATCH 13/23] md: namespace private helper names Christoph Hellwig
2017-05-18 18:32   ` Shaohua Li
2017-05-22 18:52   ` Andy Shevchenko [this message]
2017-05-23  8:41     ` Christoph Hellwig
2017-05-18  6:26 ` [PATCH 14/23] xfs: use the common helper uuid_is_null() Christoph Hellwig
2017-05-18 13:27   ` Brian Foster
2017-05-18  6:26 ` [PATCH 15/23] block: remove blk_part_pack_uuid Christoph Hellwig
2017-05-18 23:15   ` Mimi Zohar
2017-05-18  6:26 ` [PATCH 16/23] ima/policy: switch to use uuid_t Christoph Hellwig
2017-05-18 23:16   ` Mimi Zohar
2017-05-18  6:26 ` [PATCH 17/23] fs: switch ->s_uuid to uuid_t Christoph Hellwig
2017-05-18 23:17   ` Mimi Zohar
2017-05-18  6:27 ` [PATCH 18/23] overlayfs: use uuid_t instead of uuid_be Christoph Hellwig
2017-05-18  6:27 ` [PATCH 19/23] partitions/ldm: switch to use uuid_t Christoph Hellwig
2017-05-18  6:27 ` [PATCH 20/23] sysctl: " Christoph Hellwig
2017-05-18  6:27 ` [PATCH 21/23] nvme: switch to uuid_t Christoph Hellwig
2017-05-18  6:27 ` [PATCH 22/23] scsi_debug: " Christoph Hellwig
2017-05-18  6:27 ` [PATCH 23/23] uuid: remove uuid_be Christoph Hellwig
2017-05-18  7:57   ` Amir Goldstein
2017-05-18  8:56     ` Christoph Hellwig
2017-05-22 18:59       ` Andy Shevchenko

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1495479147.6967.70.camel@linux.intel.com \
    --to=andriy.shevchenko@linux.intel.com \
    --cc=amir73il@gmail.com \
    --cc=dan.j.williams@intel.com \
    --cc=dhowells@redhat.com \
    --cc=hch@lst.de \
    --cc=linux-fsdevel@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-nvdimm@ml01.01.org \
    --cc=linux-raid@vger.kernel.org \
    --cc=linux-xfs@vger.kernel.org \
    --cc=shli@kernel.org \
    --cc=swhiteho@redhat.com \
    --cc=zohar@linux.vnet.ibm.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).