From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1752034AbdFOTYj (ORCPT ); Thu, 15 Jun 2017 15:24:39 -0400 Received: from mga01.intel.com ([192.55.52.88]:60691 "EHLO mga01.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751546AbdFOTYh (ORCPT ); Thu, 15 Jun 2017 15:24:37 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.39,344,1493708400"; d="scan'208";a="98394045" Message-ID: <1497554675.133434.3.camel@ranerica-desktop> Subject: Re: [PATCH v7 13/26] x86/insn-eval: Add function to get default params of code segment From: Ricardo Neri To: Borislav Petkov Cc: Ingo Molnar , Thomas Gleixner , "H. Peter Anvin" , Andy Lutomirski , Peter Zijlstra , Andrew Morton , Brian Gerst , Chris Metcalf , Dave Hansen , Paolo Bonzini , Masami Hiramatsu , Huang Rui , Jiri Slaby , Jonathan Corbet , "Michael S. Tsirkin" , Paul Gortmaker , Vlastimil Babka , Chen Yucong , Alexandre Julliard , Stas Sergeev , Fenghua Yu , "Ravi V. Shankar" , Shuah Khan , linux-kernel@vger.kernel.org, x86@kernel.org, linux-msdos@vger.kernel.org, wine-devel@winehq.org, Adam Buchbinder , Colin Ian King , Lorenzo Stoakes , Qiaowei Ren , Arnaldo Carvalho de Melo , Adrian Hunter , Kees Cook , Thomas Garnier , Dmitry Vyukov Date: Thu, 15 Jun 2017 12:24:35 -0700 In-Reply-To: <20170607125934.27jiyy636wgjrmck@pd.tnic> References: <20170505181724.55000-1-ricardo.neri-calderon@linux.intel.com> <20170505181724.55000-14-ricardo.neri-calderon@linux.intel.com> <20170607125934.27jiyy636wgjrmck@pd.tnic> Content-Type: text/plain; charset="UTF-8" X-Mailer: Evolution 3.10.4-0ubuntu2 Mime-Version: 1.0 Content-Transfer-Encoding: 7bit Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Wed, 2017-06-07 at 14:59 +0200, Borislav Petkov wrote: > On Fri, May 05, 2017 at 11:17:11AM -0700, Ricardo Neri wrote: > > This function returns the default values of the address and operand sizes > > as specified in the segment descriptor. This information is determined > > from the D and L bits. Hence, it can be used for both IA-32e 64-bit and > > 32-bit legacy modes. For virtual-8086 mode, the default address and > > operand sizes are always 2 bytes. > > > > The D bit is only meaningful for code segments. Thus, these functions > > always use the code segment selector contained in regs. > > > > Cc: Dave Hansen > > Cc: Adam Buchbinder > > Cc: Colin Ian King > > Cc: Lorenzo Stoakes > > Cc: Qiaowei Ren > > Cc: Arnaldo Carvalho de Melo > > Cc: Masami Hiramatsu > > Cc: Adrian Hunter > > Cc: Kees Cook > > Cc: Thomas Garnier > > Cc: Peter Zijlstra > > Cc: Borislav Petkov > > Cc: Dmitry Vyukov > > Cc: Ravi V. Shankar > > Cc: x86@kernel.org > > Signed-off-by: Ricardo Neri > > --- > > arch/x86/include/asm/insn-eval.h | 6 ++++ > > arch/x86/lib/insn-eval.c | 65 ++++++++++++++++++++++++++++++++++++++++ > > 2 files changed, 71 insertions(+) > > > > diff --git a/arch/x86/include/asm/insn-eval.h b/arch/x86/include/asm/insn-eval.h > > index 7f3c7fe..9ed1c88 100644 > > --- a/arch/x86/include/asm/insn-eval.h > > +++ b/arch/x86/include/asm/insn-eval.h > > @@ -11,9 +11,15 @@ > > #include > > #include > > > > +struct insn_code_seg_defaults { > > A whole struct for a function which gets called only once? > > Bah, that's a bit too much, if you ask me. > > So you're returning two small unsigned integers - i.e., you can just as > well return a single u8 and put address and operand sizes in there: > > ret = oper_sz | addr_sz << 4; > > No need for special structs for that. OK. This makes sense. Perhaps I can use a couple of #define's to set and get the the address and operand sizes in a single u8. This would make the code more readable. > > > + unsigned char address_bytes; > > + unsigned char operand_bytes; > > +}; > > + > > void __user *insn_get_addr_ref(struct insn *insn, struct pt_regs *regs); > > int insn_get_modrm_rm_off(struct insn *insn, struct pt_regs *regs); > > unsigned long insn_get_seg_base(struct pt_regs *regs, struct insn *insn, > > int regoff); > > +struct insn_code_seg_defaults insn_get_code_seg_defaults(struct pt_regs *regs); > > > > #endif /* _ASM_X86_INSN_EVAL_H */ > > diff --git a/arch/x86/lib/insn-eval.c b/arch/x86/lib/insn-eval.c > > index c77ed80..693e5a8 100644 > > --- a/arch/x86/lib/insn-eval.c > > +++ b/arch/x86/lib/insn-eval.c > > @@ -603,6 +603,71 @@ static unsigned long get_seg_limit(struct pt_regs *regs, struct insn *insn, > > } > > > > /** > > + * insn_get_code_seg_defaults() - Obtain code segment default parameters > > + * @regs: Structure with register values as seen when entering kernel mode > > + * > > + * Obtain the default parameters of the code segment: address and operand sizes. > > + * The code segment is obtained from the selector contained in the CS register > > + * in regs. In protected mode, the default address is determined by inspecting > > + * the L and D bits of the segment descriptor. In virtual-8086 mode, the default > > + * is always two bytes for both address and operand sizes. > > + * > > + * Return: A populated insn_code_seg_defaults structure on success. The > > + * structure contains only zeros on failure. > > s/failure/error/ Will correct. > > > + */ > > +struct insn_code_seg_defaults insn_get_code_seg_defaults(struct pt_regs *regs) > > +{ > > + struct desc_struct *desc; > > + struct insn_code_seg_defaults defs; > > + unsigned short sel; > > + /* > > + * The most significant byte of AR_TYPE_MASK determines whether a > > + * segment contains data or code. > > + */ > > + unsigned int type_mask = AR_TYPE_MASK & (1 << 11); > > + > > + memset(&defs, 0, sizeof(defs)); > > + > > + if (v8086_mode(regs)) { > > + defs.address_bytes = 2; > > + defs.operand_bytes = 2; > > + return defs; > > + } > > + > > + sel = (unsigned short)regs->cs; > > + > > + desc = get_desc(sel); > > + if (!desc) > > + return defs; > > + > > + /* if data segment, return */ > > + if (!(desc->b & type_mask)) > > + return defs; > > So you can simplify that into: > > /* A code segment? */ > if (!(desc->b & BIT(11))) > return defs; > > and remove that type_mask thing. Alternatively, I can do desc->type & BIT(3) to avoid using desc-b, which is less elegant. Thanks and BR, Ricardo