linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Honghui Zhang <honghui.zhang@mediatek.com>
To: Ryder Lee <ryder.lee@mediatek.com>
Cc: <lorenzo.pieralisi@arm.com>, <bhelgaas@google.com>,
	<linux-arm-kernel@lists.infradead.org>,
	<linux-mediatek@lists.infradead.org>, <linux-pci@vger.kernel.org>,
	<linux-kernel@vger.kernel.org>, <ulf.hansson@linaro.org>,
	<marc.zyngier@arm.com>, <matthias.bgg@gmail.com>,
	<devicetree@vger.kernel.org>, <yingjoe.chen@mediatek.com>,
	<eddie.huang@mediatek.com>, <youlin.pei@mediatek.com>,
	<yt.shen@mediatek.com>, <sean.wang@mediatek.com>
Subject: Re: [PATCH v5 4/9] PCI: mediatek: Convert to use pci_host_probe()
Date: Sat, 29 Sep 2018 08:16:45 +0800	[thread overview]
Message-ID: <1538180205.14753.20.camel@mhfsdcap03> (raw)
In-Reply-To: <1538149277.23182.7.camel@mtkswgap22>

On Fri, 2018-09-28 at 23:41 +0800, Ryder Lee wrote:
> On Fri, 2018-09-28 at 18:04 +0800, honghui.zhang@mediatek.com wrote:
> > From: Honghui Zhang <honghui.zhang@mediatek.com>
> > 
> > Part of mtk_pcie_register_host is an open-coded version of
> > pci_host_probe(). So instead of duplicating this code, use
> > pci_host_probe() directly and remove mtk_pcie_register_host.
> > 
> > Signed-off-by: Honghui Zhang <honghui.zhang@mediatek.com>
> > ---
> >  drivers/pci/controller/pcie-mediatek.c | 37 ++++++++--------------------------
> >  1 file changed, 8 insertions(+), 29 deletions(-)
> > 
> > diff --git a/drivers/pci/controller/pcie-mediatek.c b/drivers/pci/controller/pcie-mediatek.c
> > index e2c4127..cbf4543 100644
> > --- a/drivers/pci/controller/pcie-mediatek.c
> > +++ b/drivers/pci/controller/pcie-mediatek.c
> > @@ -1125,34 +1125,6 @@ static int mtk_pcie_request_resources(struct mtk_pcie *pcie)
> >  	return 0;
> >  }
> >  
> > -static int mtk_pcie_register_host(struct pci_host_bridge *host)
> > -{
> > -	struct mtk_pcie *pcie = pci_host_bridge_priv(host);
> > -	struct pci_bus *child;
> > -	int err;
> 
> To make the patch simple, could we keep these host->*. and return
> pci_host_probe() directly?

Well, I guess it's not necessary to keep the mtk_pcie_register_host just
wrap pci_host_probe(). Put those host->* directly in probe function is
no harm, it will reduce one function call and related parameter passing.

I may update this patch to keep the mtk_pcie_register_host if you insist
though I prefer the current way.

Thanks.
> 
> > -	host->busnr = pcie->busn.start;
> > -	host->dev.parent = pcie->dev;
> > -	host->ops = pcie->soc->ops;
> > -	host->map_irq = of_irq_parse_and_map_pci;
> > -	host->swizzle_irq = pci_common_swizzle;
> > -	host->sysdata = pcie;
> > -
> > -	err = pci_scan_root_bus_bridge(host);
> > -	if (err < 0)
> > -		return err;
> > -
> > -	pci_bus_size_bridges(host->bus);
> > -	pci_bus_assign_resources(host->bus);
> > -
> > -	list_for_each_entry(child, &host->bus->children, node)
> > -		pcie_bus_configure_settings(child);
> > -
> > -	pci_bus_add_devices(host->bus);
> > -
> > -	return 0;
> > -}
> > -
> >  static int mtk_pcie_probe(struct platform_device *pdev)
> >  {
> >  	struct device *dev = &pdev->dev;
> > @@ -1179,7 +1151,14 @@ static int mtk_pcie_probe(struct platform_device *pdev)
> >  	if (err)
> >  		goto put_resources;
> >  
> > -	err = mtk_pcie_register_host(host);
> > +	host->busnr = pcie->busn.start;
> > +	host->dev.parent = pcie->dev;
> > +	host->ops = pcie->soc->ops;
> > +	host->map_irq = of_irq_parse_and_map_pci;
> > +	host->swizzle_irq = pci_common_swizzle;
> > +	host->sysdata = pcie;
> > +
> > +	err = pci_host_probe(host);
> >  	if (err)
> >  		goto put_resources;
> >  
> 
> 



  reply	other threads:[~2018-09-29  0:16 UTC|newest]

Thread overview: 18+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-09-28 10:04 [PATCH v5 0/9] PCI: mediatek: fixup find_port, enable_msi and add pm, module support honghui.zhang
2018-09-28 10:04 ` [PATCH v5 1/9] PCI: mediatek: Using slot's devfn for compare to fix mtk_pcie_find_port logic honghui.zhang
2018-10-01 14:36   ` Lorenzo Pieralisi
2018-10-02 10:59     ` Lorenzo Pieralisi
2018-10-08  3:02       ` Honghui Zhang
2018-09-28 10:04 ` [PATCH v5 2/9] PCI: mediatek: Fixup class ID for MT7622 as PCI_CLASS_BRIDGE_PCI honghui.zhang
2018-09-28 10:04 ` [PATCH v5 3/9] PCI: mediatek: Remove the redundant dev->pm_domain check honghui.zhang
2018-09-28 10:04 ` [PATCH v5 4/9] PCI: mediatek: Convert to use pci_host_probe() honghui.zhang
2018-09-28 15:41   ` Ryder Lee
2018-09-29  0:16     ` Honghui Zhang [this message]
2018-09-29  5:55       ` Ryder Lee
2018-09-28 10:04 ` [PATCH v5 5/9] PCI: mediatek: Move the mtk_pcie_startup_port_v2 function's define after mtk_pcie_setup_irq honghui.zhang
2018-09-28 10:04 ` [PATCH v5 6/9] PCI: mediatek: Enable msi after clock enabled honghui.zhang
2018-10-02 11:01   ` Lorenzo Pieralisi
2018-09-28 10:04 ` [PATCH v5 7/9] PCI: mediatek: Add system pm support for MT2712 and MT7622 honghui.zhang
2018-09-28 10:04 ` [PATCH v5 8/9] PCI: mediatek: Save the GIC IRQ in mtk_pcie_port honghui.zhang
2018-09-28 10:04 ` [PATCH v5 9/9] PCI: mediatek: Add loadable kernel module support honghui.zhang
2018-09-29  5:58 ` [PATCH v5 0/9] PCI: mediatek: fixup find_port, enable_msi and add pm, " Ryder Lee

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1538180205.14753.20.camel@mhfsdcap03 \
    --to=honghui.zhang@mediatek.com \
    --cc=bhelgaas@google.com \
    --cc=devicetree@vger.kernel.org \
    --cc=eddie.huang@mediatek.com \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mediatek@lists.infradead.org \
    --cc=linux-pci@vger.kernel.org \
    --cc=lorenzo.pieralisi@arm.com \
    --cc=marc.zyngier@arm.com \
    --cc=matthias.bgg@gmail.com \
    --cc=ryder.lee@mediatek.com \
    --cc=sean.wang@mediatek.com \
    --cc=ulf.hansson@linaro.org \
    --cc=yingjoe.chen@mediatek.com \
    --cc=youlin.pei@mediatek.com \
    --cc=yt.shen@mediatek.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).