linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Ashish Kumar <Ashish.Kumar@nxp.com>
To: devicetree@vger.kernel.org, robh@kernel.org,
	mark.rutland@arm.com, shawnguo@kernel.org
Cc: linux-arm-kernel@lists.infradead.org,
	linux-kernel@vger.kernel.org, Ashish Kumar <Ashish.Kumar@nxp.com>,
	Kuldeep Singh <kuldeep.singh@nxp.com>
Subject: [PATCH] arm64: dts: ls208x: Remove non-compatible driver device from qspi node
Date: Tue, 10 Sep 2019 17:50:55 +0530	[thread overview]
Message-ID: <1568118055-9740-5-git-send-email-Ashish.Kumar@nxp.com> (raw)
In-Reply-To: <1568118055-9740-1-git-send-email-Ashish.Kumar@nxp.com>

Since device properties are different, so remove fsl, ls1021a-qspi.
ls1021a-qspi is to be used only for Big-endian verion of QSPI controller

Signed-off-by: Kuldeep Singh <kuldeep.singh@nxp.com>
Signed-off-by: Ashish Kumar <Ashish.Kumar@nxp.com>
---
 arch/arm64/boot/dts/freescale/fsl-ls208xa.dtsi | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/arch/arm64/boot/dts/freescale/fsl-ls208xa.dtsi b/arch/arm64/boot/dts/freescale/fsl-ls208xa.dtsi
index 64101c9..8e42ac9 100644
--- a/arch/arm64/boot/dts/freescale/fsl-ls208xa.dtsi
+++ b/arch/arm64/boot/dts/freescale/fsl-ls208xa.dtsi
@@ -619,7 +619,7 @@
 
 		qspi: spi@20c0000 {
 			status = "disabled";
-			compatible = "fsl,ls2080a-qspi", "fsl,ls1021a-qspi";
+			compatible = "fsl,ls2080a-qspi";
 			#address-cells = <1>;
 			#size-cells = <0>;
 			reg = <0x0 0x20c0000 0x0 0x10000>,
-- 
2.7.4


  parent reply	other threads:[~2019-09-10 12:21 UTC|newest]

Thread overview: 7+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-09-10 12:20 [PATCH] arm64: dts: ls1028a: Add FlexSPI support for NXP LS1028 Ashish Kumar
2019-09-10 12:20 ` [PATCH] arm64: dts: ls1046a: Add QSPI node for ls1046afrwy Ashish Kumar
2019-09-10 12:20 ` [PATCH] arm64: dts: ls1046a: Append missing properties of QSPI node on ls1046ardb Ashish Kumar
2019-09-10 12:20 ` [PATCH] arm64: dts: ls1088a: Add QSPI support for NXP LS1088 Ashish Kumar
2019-09-10 12:20 ` Ashish Kumar [this message]
2019-10-06  3:20 ` [PATCH] arm64: dts: ls1028a: Add FlexSPI support for NXP LS1028 Shawn Guo
2019-10-08  8:03   ` Xiaowei Bao

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1568118055-9740-5-git-send-email-Ashish.Kumar@nxp.com \
    --to=ashish.kumar@nxp.com \
    --cc=devicetree@vger.kernel.org \
    --cc=kuldeep.singh@nxp.com \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mark.rutland@arm.com \
    --cc=robh@kernel.org \
    --cc=shawnguo@kernel.org \
    --subject='Re: [PATCH] arm64: dts: ls208x: Remove non-compatible driver device from qspi node' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).