linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Mathieu Desnoyers <mathieu.desnoyers@efficios.com>
To: rostedt <rostedt@goodmis.org>
Cc: linux-kernel <linux-kernel@vger.kernel.org>,
	Ingo Molnar <mingo@kernel.org>,
	Andrew Morton <akpm@linux-foundation.org>,
	"Paul E. McKenney" <paulmck@linux.vnet.ibm.com>
Subject: Re: [PATCH 7/5 v3] tracing: Make sure rcu_irq_enter() can work for trace_*_rcuidle() trace events
Date: Fri, 7 Apr 2017 18:17:43 +0000 (UTC)	[thread overview]
Message-ID: <158560784.4550.1491589063819.JavaMail.zimbra@efficios.com> (raw)
In-Reply-To: <20170407141018.21e7d361@gandalf.local.home>

----- On Apr 7, 2017, at 2:10 PM, rostedt rostedt@goodmis.org wrote:

> From: "Steven Rostedt (VMware)" <rostedt@goodmis.org>
> 
> Stack tracing discovered that there's a small location inside the RCU
> infrastructure where calling rcu_irq_enter() does not work. As trace events
> use rcu_irq_enter() it must make sure that it is functionable. A check
> against rcu_irq_enter_disabled() is added with a WARN_ON_ONCE() as no trace
> event should ever be used in that part of RCU. If the warning is triggered,
> then the trace event is ignored.
> 
> Link: http://lkml.kernel.org/r/20170405093207.404f8deb@gandalf.local.home
> 
> Cc: Mathieu (making code boring) Desnoyers <mathieu.desnoyers@efficios.com>
> Signed-off-by: Steven Rostedt (VMware) <rostedt@goodmis.org>
> ---
> 
> Mathieu,
> 
> There! Are you now satisfied?

Since you reversed the boolean logic from my proposal, perhaps
rename the "rcucheck" argument to "rcudisabled" to reflect the
logic swap ?

Other than that:

Acked-by: Mathieu Desnoyers <mathieu.desnoyers@efficios.com>

Thanks,

Mathieu

> 
> 
> 
> include/linux/tracepoint.h | 9 ++++++---
> 1 file changed, 6 insertions(+), 3 deletions(-)
> 
> diff --git a/include/linux/tracepoint.h b/include/linux/tracepoint.h
> index f72fcfe..7f98d50 100644
> --- a/include/linux/tracepoint.h
> +++ b/include/linux/tracepoint.h
> @@ -128,7 +128,7 @@ extern void syscall_unregfunc(void);
>  * as "(void *, void)". The DECLARE_TRACE_NOARGS() will pass in just
>  * "void *data", where as the DECLARE_TRACE() will pass in "void *data, proto".
>  */
> -#define __DO_TRACE(tp, proto, args, cond, prercu, postrcu)		\
> +#define __DO_TRACE(tp, proto, args, cond, rcucheck, prercu, postrcu)	\
> 	do {								\
> 		struct tracepoint_func *it_func_ptr;			\
> 		void *it_func;						\
> @@ -136,6 +136,8 @@ extern void syscall_unregfunc(void);
> 									\
> 		if (!(cond))						\
> 			return;						\
> +		if (rcucheck)						\
> +			return;						\
> 		prercu;							\
> 		rcu_read_lock_sched_notrace();				\
> 		it_func_ptr = rcu_dereference_sched((tp)->funcs);	\
> @@ -151,7 +153,7 @@ extern void syscall_unregfunc(void);
> 	} while (0)
> 
> #ifndef MODULE
> -#define __DECLARE_TRACE_RCU(name, proto, args, cond, data_proto, data_args)	\
> +#define __DECLARE_TRACE_RCU(name, proto, args, cond, data_proto, data_args) \
> 	static inline void trace_##name##_rcuidle(proto)		\
> 	{								\
> 		if (static_key_false(&__tracepoint_##name.key))		\
> @@ -159,6 +161,7 @@ extern void syscall_unregfunc(void);
> 				TP_PROTO(data_proto),			\
> 				TP_ARGS(data_args),			\
> 				TP_CONDITION(cond),			\
> +				WARN_ON_ONCE(rcu_irq_enter_disabled()),\
> 				rcu_irq_enter_irqson(),			\
> 				rcu_irq_exit_irqson());			\
> 	}
> @@ -186,7 +189,7 @@ extern void syscall_unregfunc(void);
> 			__DO_TRACE(&__tracepoint_##name,		\
> 				TP_PROTO(data_proto),			\
> 				TP_ARGS(data_args),			\
> -				TP_CONDITION(cond),,);			\
> +				TP_CONDITION(cond),0,,);		\
> 		if (IS_ENABLED(CONFIG_LOCKDEP) && (cond)) {		\
> 			rcu_read_lock_sched_notrace();			\
> 			rcu_dereference_sched(__tracepoint_##name.funcs);\
> --
> 2.9.3

-- 
Mathieu Desnoyers
EfficiOS Inc.
http://www.efficios.com

  reply	other threads:[~2017-04-07 18:16 UTC|newest]

Thread overview: 39+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2017-04-07 14:01 [PATCH 0/5 v2] tracing: Add usecase of synchronize_rcu_tasks() and stack_tracer_disable() Steven Rostedt
2017-04-07 14:01 ` [PATCH 1/5 v2] ftrace: Add use of synchronize_rcu_tasks() with dynamic trampolines Steven Rostedt
2017-04-07 14:01 ` [PATCH 2/5 v2] tracing: Replace the per_cpu() with this_cpu() in trace_stack.c Steven Rostedt
2017-04-07 14:36   ` Paul E. McKenney
2017-04-07 14:48     ` Steven Rostedt
2017-04-07 15:08       ` Paul E. McKenney
2017-04-07 14:01 ` [PATCH 3/5 v2] tracing: Add stack_tracer_disable/enable() functions Steven Rostedt
2017-04-07 14:22   ` Steven Rostedt
2017-04-07 14:25   ` [PATCH 3/5 v2.1] " Steven Rostedt
2017-04-07 14:01 ` [PATCH 4/5 v2] tracing: Rename trace_active to disable_stack_tracer and inline its modification Steven Rostedt
2017-04-07 14:01 ` [PATCH 5/5 v2] rcu: Fix dyntick-idle tracing Steven Rostedt
2017-04-07 14:40   ` Paul E. McKenney
2017-04-07 14:53     ` Steven Rostedt
2017-04-07 15:09       ` Paul E. McKenney
2017-04-07 15:29         ` Steven Rostedt
2017-04-07 14:43 ` [PATCH 0/5 v2] tracing: Add usecase of synchronize_rcu_tasks() and stack_tracer_disable() Paul E. McKenney
2017-04-07 14:58   ` Steven Rostedt
2017-04-07 15:11     ` Paul E. McKenney
2017-04-07 15:28       ` Steven Rostedt
2017-04-07 16:35 ` [PATCH 6/5]rcu/tracing: Add rcu_disabled to denote when rcu_irq_enter() will not work Steven Rostedt
2017-04-07 16:42   ` Paul E. McKenney
2017-04-07 16:44     ` Steven Rostedt
2017-04-07 16:53       ` Paul E. McKenney
2017-04-07 17:03     ` [PATCH 6/5 v2] rcu/tracing: " Steven Rostedt
2017-04-07 17:15       ` Paul E. McKenney
2017-04-07 17:06 ` [PATCH 7/5] tracing: Make sure rcu_irq_enter() can work for trace_*_rcuidle() trace events Steven Rostedt
2017-04-07 17:15   ` Paul E. McKenney
2017-04-07 17:19   ` Mathieu Desnoyers
2017-04-07 17:26     ` Steven Rostedt
2017-04-07 17:32       ` Steven Rostedt
2017-04-07 17:49       ` Mathieu Desnoyers
2017-04-07 17:55         ` Steven Rostedt
2017-04-07 18:10         ` [PATCH 7/5 v3] " Steven Rostedt
2017-04-07 18:17           ` Mathieu Desnoyers [this message]
2017-04-07 19:41             ` [PATCH 7/5 v4] " Steven Rostedt
2017-04-07 19:43               ` Steven Rostedt
2017-04-10 17:11                 ` Mathieu Desnoyers
2017-04-07 17:28     ` [PATCH 7/5] " Steven Rostedt
2017-04-07 17:48     ` [PATCH 7/5 v2] " Steven Rostedt

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=158560784.4550.1491589063819.JavaMail.zimbra@efficios.com \
    --to=mathieu.desnoyers@efficios.com \
    --cc=akpm@linux-foundation.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@kernel.org \
    --cc=paulmck@linux.vnet.ibm.com \
    --cc=rostedt@goodmis.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).