linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Colin Ian King <colin.king@canonical.com>
To: Joe Perches <joe@perches.com>,
	Siva Reddy Kallam <siva.kallam@broadcom.com>,
	Prashant Sreedharan <prashant@broadcom.com>,
	Michael Chan <mchan@broadcom.com>,
	"David S . Miller" <davem@davemloft.net>,
	netdev@vger.kernel.org
Cc: kernel-janitors@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH] net: tg3: tidy up loop, remove need to compute off with a multiply
Date: Sat, 9 May 2020 00:31:03 +0100	[thread overview]
Message-ID: <160ce1ee-3bb5-3357-64f3-e5dea8c0538d@canonical.com> (raw)
In-Reply-To: <1890306fc8c9306abe11186d419d84f784ee6144.camel@perches.com>

On 09/05/2020 00:21, Joe Perches wrote:
> On Fri, 2020-05-08 at 23:53 +0100, Colin King wrote:
>> From: Colin Ian King <colin.king@canonical.com>
>>
>> Currently the value for 'off' is computed using a multiplication and
>> a couple of statements later off is being incremented by len and
>> this value is never read.  Clean up the code by removing the
>> multiplication and just increment off by len on each iteration. Also
>> use len instead of TG3_OCIR_LEN.
> 
> I think this is a lot harder to read.
> 
>> diff --git a/drivers/net/ethernet/broadcom/tg3.c b/drivers/net/ethernet/broadcom/tg3.c
> []
>> @@ -10798,16 +10798,14 @@ static int tg3_init_hw(struct tg3 *tp, bool reset_phy)
>>  static void tg3_sd_scan_scratchpad(struct tg3 *tp, struct tg3_ocir *ocir)
>>  {
>>  	int i;
>> +	u32 off, len = TG3_OCIR_LEN;
>>  
>> -	for (i = 0; i < TG3_SD_NUM_RECS; i++, ocir++) {
>> -		u32 off = i * TG3_OCIR_LEN, len = TG3_OCIR_LEN;
>> -
>> +	for (i = 0, off = 0; i < TG3_SD_NUM_RECS; i++, ocir++, off += len) {
>>  		tg3_ape_scratchpad_read(tp, (u32 *) ocir, off, len);
>> -		off += len;
>>  
>>  		if (ocir->signature != TG3_OCIR_SIG_MAGIC ||
>>  		    !(ocir->version_flags & TG3_OCIR_FLAG_ACTIVE))
>> -			memset(ocir, 0, TG3_OCIR_LEN);
>> +			memset(ocir, 0, len);
>>  	}
>>  }
> 
> My preference would be for
> 
> {
> 	int i;
> 	u32 off = 0;
> 
> 	for (i = 0; i < TG3_SD_NUM_RECS; i++) {
> 		tg3_ape_scratchpad_read(tp, (u32 *)ocir, off, TC3_OCIR_LEN);
> 
> 		if (ocir->signature != TG3_OCIR_SIG_MAGIC ||
> 		    !(ocir->version_flags & TG3_OCIR_FLAG_ACTIVE))
> 			memset(ocir, 0, TG3_OCIR_LEN);
> 
> 		off += TG3_OCIR_LEN;
> 		ocir++;
> 	}
> 
OK, I'll send a V3 tomorrow.


  reply	other threads:[~2020-05-08 23:31 UTC|newest]

Thread overview: 7+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-05-08 22:53 [PATCH] net: tg3: tidy up loop, remove need to compute off with a multiply Colin King
2020-05-08 23:04 ` Michael Chan
2020-05-08 23:21 ` Joe Perches
2020-05-08 23:31   ` Colin Ian King [this message]
2020-05-09  1:48     ` Jakub Kicinski
2020-05-09  2:31       ` Joe Perches
2020-05-09  4:48         ` Michael Chan

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=160ce1ee-3bb5-3357-64f3-e5dea8c0538d@canonical.com \
    --to=colin.king@canonical.com \
    --cc=davem@davemloft.net \
    --cc=joe@perches.com \
    --cc=kernel-janitors@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mchan@broadcom.com \
    --cc=netdev@vger.kernel.org \
    --cc=prashant@broadcom.com \
    --cc=siva.kallam@broadcom.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).