linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* Can't boot since 2.4.21-rc2-ac3 with dvb-kernel
@ 2003-06-02 17:16 Gregoire Favre
  2003-06-05 16:39 ` [linux-dvb] " Gregoire Favre
  0 siblings, 1 reply; 4+ messages in thread
From: Gregoire Favre @ 2003-06-02 17:16 UTC (permalink / raw)
  To: linux-kernel, linux-dvb

Hello,

with 2.4.21-rc2-ac2 I can boot with dvb-kernel (I have recompiled with
latest CVS from dvb-kernel without problem). But since 2.4.21-rc2-ac3 I
don't manage, for example with 2.4.21-rc6-ac1, I got:

ksymoops -v /usr/src/linux-2.4.21-rc6-ac1/vmlinux -K -L -l /lib/modules/2.4.21-rc6-ac1/ -m /usr/src/linux-2.4.21-rc6-ac1/System.map 2.4.21-rc6-ac1-err 
Warning (multi_opt): you specified both -l and -L.  Using '-l /lib/modules/2.4.21-rc6-ac1/'
ksymoops 2.4.8 on i686 2.4.21-rc2-ac2.  Options used
     -v /usr/src/linux-2.4.21-rc6-ac1/vmlinux (specified)
     -K (specified)
     -l /lib/modules/2.4.21-rc6-ac1/ (specified)
     -o /lib/modules/2.4.21-rc2-ac2/ (default)
     -m /usr/src/linux-2.4.21-rc6-ac1/System.map (specified)

No modules in ksyms, skipping objects
No ksyms, skipping lsmod
Unable to handle kernel NULL pointer dereference at virtual address 00000001
*pde = 34094067
Oops: 0000
CPU:    0
EIP:    0010:[<00000001>]    Not tainted
Using defaults from ksymoops -t elf32-i386 -a i386
EFLAGS: 00013202
eax: f5231880   ebx: f4d24dac   ecx: f4964b80   edx: f58dc780
esi: fac163c0   edi: fac163a0   ebp: 00000000   esp: f4923edc
ds: 0018   es: 0018   ss: 0018
Process X (pid: 1432, stackpage=f4923000)
Stack: fac15279 f5231880 f4964b80 f5162b00 f5162b00 f4922000 c0147252 f5162b00 
       f58d4c40 00000000 00000001 f5231880 f5162b00 f4964b80 f5906c80 f5231880 
       f5906c88 c016bbe9 f5231880 f4964b80 c0146952 00000003 ffffffeb f4964b80 
Call Trace:    [<fac15279>] [<c0147252>] [<c016bbe9>] [<c0146952>] [<c013b663>]
  [<c013b588>] [<c013b923>] [<c0107347>]
Code:  Bad EIP value.


>>EIP; 00000001 Before first symbol   <=====

Trace; fac15279 <END_OF_CODE+3a8239a1/????>
Trace; c0147252 <link_path_walk+4e2/6e0>
Trace; c016bbe9 <devfs_open+149/1b0>
Trace; c0146952 <vfs_permission+82/140>
Trace; c013b663 <dentry_open+d3/1d0>
Trace; c013b588 <filp_open+68/70>
Trace; c013b923 <sys_open+53/a0>
Trace; c0107347 <system_call+33/38>


1 warning issued.  Results may not be reliable.
Exit 1

Without dvb-kernel, the system boot perfectly...
I lauch the dvb at boot with initscript like:

/usr/src/CVS/dvb-kernel/driver.av7110 start

Should I provide some other infos?

	Grégoire
__________________________________________________________________
http://www-ima.unil.ch/greg ICQ:16624071 mailto:greg@magma.unil.ch

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [linux-dvb] Can't boot since 2.4.21-rc2-ac3 with dvb-kernel
  2003-06-02 17:16 Can't boot since 2.4.21-rc2-ac3 with dvb-kernel Gregoire Favre
@ 2003-06-05 16:39 ` Gregoire Favre
  2003-06-05 16:47   ` [linux-dvb] " Michael Hunold
  0 siblings, 1 reply; 4+ messages in thread
From: Gregoire Favre @ 2003-06-05 16:39 UTC (permalink / raw)
  To: linux-kernel, linux-dvb

Hello,

as already repported with older ac and older CVS of dvb-kernel, same
Oops with 2.4.21-rc7-ac1:

ksymoops -v /usr/src/linux/vmlinux -l /lib/modules/2.4.21-rc7-ac1 -m /usr/src/linux-2.4.21-rc7-ac1/System.map OOps 
ksymoops 2.4.8 on i686 2.4.21-rc7-ac1.  Options used
     -v /usr/src/linux/vmlinux (specified)
     -k /proc/ksyms (default)
     -l /lib/modules/2.4.21-rc7-ac1 (specified)
     -o /lib/modules/2.4.21-rc7-ac1/ (default)
     -m /usr/src/linux-2.4.21-rc7-ac1/System.map (specified)

Error (regular_file): read_lsmod /lib/modules/2.4.21-rc7-ac1 is not a regular file, ignored
Unable to handle kernel NULL pointer dereference at virtual address 00000001
00000001
*pde = 00000000
Oops: 0000
CPU:    0
EIP:    0010:[<00000001>]    Not tainted
Using defaults from ksymoops -t elf32-i386 -a i386
EFLAGS: 00010202
eax: f6e03980   ebx: e2658dac   ecx: f1466b00   edx: f7302180
esi: fab4b320   edi: fab4b300   ebp: 00000000   esp: d8c5fed8
ds: 0018   es: 0018   ss: 0018
Process v4l-conf (pid: 7132, stackpage=d8c5f000)
Stack: fab4a2bb f6e03980 f1466b00 c0144dce ef295b00 ef295a80 d9d2200f c0145626 
       ef295b00 d8c5ff10 00000000 00000001 c0168164 f6b81e00 f6e03980 f6e03980 
       f1466b00 c0168d88 f6e03980 f1466b00 00000003 c0144c65 00000003 ffffffeb 
Call Trace:    [<fab4a2bb>] [<c0144dce>] [<c0145626>] [<c0168164>] [<c0168d88>]
  [<c0144c65>] [<c013a076>] [<c0139ebd>] [<c013a28e>] [<c01071b7>]
Code:  Bad EIP value.


>>EIP; 00000001 Before first symbol   <=====

>>eax; f6e03980 <_end+36a19a00/3a7520e0>
>>ebx; e2658dac <_end+2226ee2c/3a7520e0>
>>ecx; f1466b00 <_end+3107cb80/3a7520e0>
>>edx; f7302180 <_end+36f18200/3a7520e0>
>>esi; fab4b320 <[videodev]video_fops+0/47>
>>edi; fab4b300 <[videodev]videodev_lock+0/0>
>>esp; d8c5fed8 <_end+18875f58/3a7520e0>

Trace; fab4a2bb <[videodev]video_open+182/1d2>
Trace; c0144dce <cached_lookup+18/5b>
Trace; c0145626 <link_path_walk+616/6b8>
Trace; c0168164 <devfs_get_ops+82/b0>
Trace; c0168d88 <devfs_open+147/1ca>
Trace; c0144c65 <vfs_permission+8a/12b>
Trace; c013a076 <dentry_open+1b4/1f3>
Trace; c0139ebd <filp_open+5c/61>
Trace; c013a28e <sys_open+53/a6>
Trace; c01071b7 <system_call+33/38>


1 error issued.  Results may not be reliable.
Exit 1

Is there anything I could do to make it works?

	Grégoire
__________________________________________________________________
http://www-ima.unil.ch/greg ICQ:16624071 mailto:greg@magma.unil.ch

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [linux-dvb] Re: Can't boot since 2.4.21-rc2-ac3 with dvb-kernel
  2003-06-05 16:39 ` [linux-dvb] " Gregoire Favre
@ 2003-06-05 16:47   ` Michael Hunold
  2003-06-05 17:11     ` Gregoire Favre
  0 siblings, 1 reply; 4+ messages in thread
From: Michael Hunold @ 2003-06-05 16:47 UTC (permalink / raw)
  To: Gregoire Favre; +Cc: linux-kernel, linux-dvb

Hello Gregoire,

> as already repported with older ac and older CVS of dvb-kernel, same
> Oops with 2.4.21-rc7-ac1:

Are you sure you have used the v4l2 "videodev.o" (backported from 2.5) 
that comes from the "build-2.4" directory from the "dvb-kernel" cvs tree?

 > Trace; fab4a2bb <[videodev]video_open+182/1d2>
 > Trace; c0144dce <cached_lookup+18/5b>
 > Trace; c0145626 <link_path_walk+616/6b8>

This looks suspicious...

Please do a
 > find /lib/modules/ -iname "*videodev*"

If you have a "videodev.o" in .../kernel/drivs/media/video, then this 
will be used. But this is the plain old 2.4 video4linux-*1* videodev 
module, which does not work in conjunction with the "dvb-kernel" CVS 
driver, which needs the 2.5 video4linux-*2* videodev.

> 	Grégoire

Please don't CC the linux kernel mailing list the next time, since this 
is a dvd only issue. Thanks!

CU
Michael.



^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [linux-dvb] Re: Can't boot since 2.4.21-rc2-ac3 with dvb-kernel
  2003-06-05 16:47   ` [linux-dvb] " Michael Hunold
@ 2003-06-05 17:11     ` Gregoire Favre
  0 siblings, 0 replies; 4+ messages in thread
From: Gregoire Favre @ 2003-06-05 17:11 UTC (permalink / raw)
  To: Michael Hunold; +Cc: linux-kernel, linux-dvb

On Thu, Jun 05, 2003 at 06:47:40PM +0200, Michael Hunold wrote:

Hello Michael and otherss ;-)

> Are you sure you have used the v4l2 "videodev.o" (backported from 2.5) 
> that comes from the "build-2.4" directory from the "dvb-kernel" cvs tree?

Argh!!!

> Please do a
> > find /lib/modules/ -iname "*videodev*"

/lib/modules/2.4.20-xfs-2003-04-27/kernel/drivers/media/video/videodev.o
/lib/modules/2.4.21-rc1-ac3/misc/videodev.o
/lib/modules/2.4.21-rc2-ac2/misc/videodev.o
/lib/modules/2.4.21-rc2-ac3/misc/videodev.o
/lib/modules/2.4.21-rc2-ac3/kernel/drivers/media/video/videodev.o
/lib/modules/2.4.21-rc6-ac1/misc/videodev.o
/lib/modules/2.4.21-rc6-ac1/kernel/drivers/media/video/videodev.o
/lib/modules/2.4.21-rc7-ac1/misc/videodev.o
/lib/modules/2.4.21-rc7-ac1/kernel/drivers/media/video/videodev.o
/lib/modules/2.4.20-xfs/misc/videodev.o

I completely forgot this!!!

> If you have a "videodev.o" in .../kernel/drivs/media/video, then this 
> will be used. But this is the plain old 2.4 video4linux-*1* videodev 
> module, which does not work in conjunction with the "dvb-kernel" CVS 
> driver, which needs the 2.5 video4linux-*2* videodev.

Well, I have rebooted now under 2.4.21-rc7-ac1 and it works just
great!!!

> Please don't CC the linux kernel mailing list the next time, since this 
> is a dvd only issue. Thanks!

I completely agree with this, unfirtunately, as I completely forgot to
remove the kernel/drivers/media/video/videodev.o to kernels newer than
2.4.21-rc2-ac2 and as the compilation of new dvb-kernel worked perfectly
for 2.4.21-rc2-ac2 I thought it was due to a change in the kernel...

Sorry for the posts!!! But thank you very much,

	Grégoire
__________________________________________________________________
http://www-ima.unil.ch/greg ICQ:16624071 mailto:greg@magma.unil.ch

^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2003-06-05 16:58 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2003-06-02 17:16 Can't boot since 2.4.21-rc2-ac3 with dvb-kernel Gregoire Favre
2003-06-05 16:39 ` [linux-dvb] " Gregoire Favre
2003-06-05 16:47   ` [linux-dvb] " Michael Hunold
2003-06-05 17:11     ` Gregoire Favre

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).