archive mirror
 help / color / mirror / Atom feed
* PPC 440 System
@ 2003-07-14 11:27 simon
  2003-07-14 16:16 ` Roland Dreier
  0 siblings, 1 reply; 5+ messages in thread
From: simon @ 2003-07-14 11:27 UTC (permalink / raw)
  To: linux-kernel

I have an IBM ebony development board which has a PPC 440 
processor. I am trying to build a development system for it. It 
currently loads a cross compiled kernel and kicks out messages via 
the first serial port, no vga. It mounts the root fs via nfs and tries to 
exec /sbin/init. At this point the system appears to hang. 

If I remove /sbin/init from the nfs root the kernel panics as expected, 
so I assume root is mounted ok. I have tried to build a minimum root 
filesystem which contains /dev/console, /dev/ttyS0 and a statically 
linked /sbin/init. The init just does a printf but I do not see this 
message. Does anyone know it this should work ? 

Initially I tried to build a root filesystem from files on a Mac Clone 
running Yellow Dog Linux. I believe this has a PPC 604e processor. 
Should this systems binaries/libraries run on the 440GP ?

Can I expect a statically linked executable, made on the Mac, to run
on the 440GP?

Many Thanks


Simon Haynes - Baydel 
Phone : 44 (0) 1372 378811
Email :

^ permalink raw reply	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2003-07-15 14:21 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2003-07-14 11:27 PPC 440 System simon
2003-07-14 16:16 ` Roland Dreier
2003-07-14 21:55   ` Matt Mackall
2003-07-15  9:24   ` simon
2003-07-15 14:35     ` Matt Porter

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).