linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: "Jean-Luc Coulon (f5ibh)" <jean-luc.coulon@wanadoo.fr>
To: linux-kernel@vger.kernel.org
Subject: Matrox Millenium and framebuffer
Date: Tue, 15 Jul 2003 21:35:45 +0200	[thread overview]
Message-ID: <20030715193545.GA1024@tangerine> (raw)

Hi,

I've a Matrox Millenium card and I want to run the framebuffer.
I've set the following configuration :

# Frame-buffer support
#
CONFIG_FB=y
CONFIG_DUMMY_CONSOLE=y
# CONFIG_FB_RIVA is not set
# CONFIG_FB_CLGEN is not set
# CONFIG_FB_PM2 is not set
# CONFIG_FB_PM3 is not set
# CONFIG_FB_CYBER2000 is not set
# CONFIG_FB_VESA is not set
# CONFIG_FB_VGA16 is not set
# CONFIG_FB_HGA is not set
CONFIG_VIDEO_SELECT=y
CONFIG_FB_MATROX=y
CONFIG_FB_MATROX_MILLENIUM=y
# CONFIG_FB_MATROX_MYSTIQUE is not set
# CONFIG_FB_MATROX_G450 is not set
# CONFIG_FB_MATROX_G100A is not set
CONFIG_FB_MATROX_PROC=m
# CONFIG_FB_MATROX_MULTIHEAD is not set
# CONFIG_FB_ATY is not set
# CONFIG_FB_RADEON is not set
# CONFIG_FB_ATY128 is not set
# CONFIG_FB_INTEL is not set
# CONFIG_FB_SIS is not set
# CONFIG_FB_NEOMAGIC is not set
# CONFIG_FB_3DFX is not set
# CONFIG_FB_VOODOO1 is not set
# CONFIG_FB_TRIDENT is not set
# CONFIG_FB_VIRTUAL is not set
CONFIG_FBCON_ADVANCED=y
CONFIG_FBCON_MFB=y
# CONFIG_FBCON_CFB2 is not set
# CONFIG_FBCON_CFB4 is not set
CONFIG_FBCON_CFB8=y
CONFIG_FBCON_CFB16=y
CONFIG_FBCON_CFB24=y
CONFIG_FBCON_CFB32=y
# CONFIG_FBCON_AFB is not set
# CONFIG_FBCON_ILBM is not set
# CONFIG_FBCON_IPLAN2P2 is not set
# CONFIG_FBCON_IPLAN2P4 is not set
# CONFIG_FBCON_IPLAN2P8 is not set
# CONFIG_FBCON_MAC is not set


And I pass the parameter video=matrox to the kernel.
I tried video=matrox:vesa=<something> without any success.

Here are the boot lines from dmesg :

[root@tangerine] /usr/src/linux/drivers/video/matrox # dmesg | more
Linux version 2.4.21 (root@tangerine) (version gcc 3.3.1 20030626 
(Debian prerel
ease)) #1 mar jui 15 18:40:01 CEST 2003 matroxfb_Ti3026.c
BIOS-provided physical RAM map:50.h     matroxfb_Ti3026.h
  BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
  BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
  BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)s 
matroxfb_base.c  BIOS-e820: 0000000000100000 - 0000000017ffc000 
(usable)ess /boot/
config
  BIOS-e820: 0000000017ffc000 - 0000000017fff000 (ACPI data)
  BIOS-e820: 0000000017fff000 - 0000000018000000 (ACPI NVS)s /boot/
config-2.4.21  BIOS-e820: 00000000ffff0000 - 0000000100000000 (reserved)
383MB LOWMEM available.
On node 0 totalpages: 98300
zone(0): 4096 pages.
zone(1): 94204 pages.
zone(2): 0 pages.
Kernel command line: root=/dev/hda2 reboot=warm hdc=ide-scsi hdd=ide-
scsi pci=bi
osirq video=matrox
ide_setup: hdc=ide-scsi
ide_setup: hdd=ide-scsi
Initializing CPU#0
Detected 501.160 MHz processor.
Console: colour VGA+ 80x25

If I compile a vesa framebuffer, it works but not accelerated.

---
Regards
	Jean-Luc

----------------------------------------------------------------------------
Jean-Luc Coulon
28 rue d'Evette
90350 Evette-Salbert
FRANCE

             reply	other threads:[~2003-07-15 19:21 UTC|newest]

Thread overview: 3+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2003-07-15 19:35 Jean-Luc Coulon (f5ibh) [this message]
2003-07-15 19:51 ` Re : " Jean-Luc Coulon (f5ibh)
2003-07-15 19:55 ` nick black

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20030715193545.GA1024@tangerine \
    --to=jean-luc.coulon@wanadoo.fr \
    --cc=linux-kernel@vger.kernel.org \
    --subject='Re: Matrox Millenium and framebuffer' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).