linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* APIC support prevents power off
@ 2003-07-20 14:36 Roger Luethi
  0 siblings, 0 replies; 7+ messages in thread
From: Roger Luethi @ 2003-07-20 14:36 UTC (permalink / raw)
  To: linux-kernel; +Cc: Ingo Molnar

On some UP boards (e.g. ASUS A7A266) enabling support for local APICs keeps
the machine from powering off on shutdown. It will just hang instead.

This has been observed by others before [1]. A warning in the respective
configuration note seems in order (or a proper fix if anybody has one).

Roger

[1] http://marc.theaimsgroup.com/?l=linux-kernel&m=105561164424871&w=2

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: APIC support prevents power off
  2003-07-22  8:35 Mikael Pettersson
  2003-07-22 11:45 ` Mark McClelland
@ 2003-07-22 23:28 ` Roger Luethi
  1 sibling, 0 replies; 7+ messages in thread
From: Roger Luethi @ 2003-07-22 23:28 UTC (permalink / raw)
  To: Mikael Pettersson; +Cc: linux-kernel, mingo

On Tue, 22 Jul 2003 10:35:36 +0200, Mikael Pettersson wrote:
> You really should check if a BIOS update is available.

Alright. I tried. If the BIOS is at fault, ASUS hasn't fixed it yet.

> Your APM/ACPI config seems Ok, but what does CONFIG_SMP look like?
> Enabling SMP disables APM's power off code, unless one boots with
> apm=power-off.

SMP is off.

> Did your kernel have to actually enable the local APIC, or did
> the BIOS boot us with it already enabled? Please send me a dmesg

$ dmesg|grep APIC
Local APIC disabled by BIOS -- reenabling.
Found and enabled local APIC!
Using local APIC timer interrupts.
calibrating APIC timer ...

> I can't seem to find any place where we disable the local APIC
> on shutdown; reboot seems Ok but not poweroff (as far as I can see).
> I think this might explain why some BIOSen hang at poweroff.

Quite possibly.

Roger

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: APIC support prevents power off
  2003-07-22  8:35 Mikael Pettersson
@ 2003-07-22 11:45 ` Mark McClelland
  2003-07-22 23:28 ` Roger Luethi
  1 sibling, 0 replies; 7+ messages in thread
From: Mark McClelland @ 2003-07-22 11:45 UTC (permalink / raw)
  To: Mikael Pettersson; +Cc: rl, linux-kernel, mingo

Mikael Pettersson wrote:

> Enabling SMP disables APM's power off code, unless one boots with
> apm=power-off.

apm=smp might also be needed on some machines. My Supermicro P6DGU 
running 2.4.21 only powers off when I boot with both of those 
parameters. apm=power-off alone only worked with 2.4.9 (or maybe older; 
can't remember) kernels.

-- 
Mark McClelland
mark@alpha.dyndns.org


^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: APIC support prevents power off
@ 2003-07-22  8:35 Mikael Pettersson
  2003-07-22 11:45 ` Mark McClelland
  2003-07-22 23:28 ` Roger Luethi
  0 siblings, 2 replies; 7+ messages in thread
From: Mikael Pettersson @ 2003-07-22  8:35 UTC (permalink / raw)
  To: rl; +Cc: linux-kernel, mingo

On Mon, 21 Jul 2003 11:54:14 +0200, Roger Luethi wrote:
>On Mon, 21 Jul 2003 03:13:52 +0200, Mikael Pettersson wrote:
>> On Sun, 20 Jul 2003 16:36:13 +0200, Roger Luethi wrote:
>> >On some UP boards (e.g. ASUS A7A266) enabling support for local APICs keeps
>> >the machine from powering off on shutdown. It will just hang instead.
>> >
>> >This has been observed by others before [1]. A warning in the respective
>> >configuration note seems in order (or a proper fix if anybody has one).
>> 
>> Insufficient data to draw anti-local-APIC conclusions.
>> - ensure you have the latest BIOS
>
>I tend not to touch the BIOS unless I have reason to believe an update will
>fix an actual problem.

Powering off invokes the BIOS. BIOSen are known to have bugs.
You really should check if a BIOS update is available.

>> - if you're using APM, ensure that CPU_IDLE and DISPLAY_BLANK are
>>   disabled, and that APM isn't built as a module
>>   (these things are known to cause APM hangs in UP APIC systems)
>> - if you're using ACPI, try without ACPI, or at least with ACPI not
>>   doing any power management
>
>Your suggestions match my current configuration:

Your APM/ACPI config seems Ok, but what does CONFIG_SMP look like?
Enabling SMP disables APM's power off code, unless one boots with
apm=power-off.

Did your kernel have to actually enable the local APIC, or did
the BIOS boot us with it already enabled? Please send me a dmesg
from a boot with local APIC support enabled.

I can't seem to find any place where we disable the local APIC
on shutdown; reboot seems Ok but not poweroff (as far as I can see).
I think this might explain why some BIOSen hang at poweroff.

/Mikael

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: APIC support prevents power off
  2003-07-21  9:54 ` Roger Luethi
@ 2003-07-21 10:16   ` William Gallafent
  0 siblings, 0 replies; 7+ messages in thread
From: William Gallafent @ 2003-07-21 10:16 UTC (permalink / raw)
  To: Roger Luethi; +Cc: linux-kernel


> On Mon, 21 Jul 2003 03:13:52 +0200, Mikael Pettersson wrote:

> > - ensure you have the latest BIOS

On Mon, 21 Jul 2003, Roger Luethi wrote:

> I tend not to touch the BIOS unless I have reason to believe an update will
> fix an actual problem.

FWIW, Updating the BIOS on my Tyan Tiger MP did sort out some (I *think* APIC
related) problems I had with a PCI ethernet card under 2.4.18. I agree with
your `if it ain't broke don't fix it' approach in general, but in this case
updating the BIOS fixed for me a problem that I had not attributed to it!

-- 
Bill Gallafent.

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: APIC support prevents power off
  2003-07-21  1:13 Mikael Pettersson
@ 2003-07-21  9:54 ` Roger Luethi
  2003-07-21 10:16   ` William Gallafent
  0 siblings, 1 reply; 7+ messages in thread
From: Roger Luethi @ 2003-07-21  9:54 UTC (permalink / raw)
  To: Mikael Pettersson; +Cc: linux-kernel, mingo

On Mon, 21 Jul 2003 03:13:52 +0200, Mikael Pettersson wrote:
> On Sun, 20 Jul 2003 16:36:13 +0200, Roger Luethi wrote:
> >On some UP boards (e.g. ASUS A7A266) enabling support for local APICs keeps
> >the machine from powering off on shutdown. It will just hang instead.
> >
> >This has been observed by others before [1]. A warning in the respective
> >configuration note seems in order (or a proper fix if anybody has one).
> 
> Insufficient data to draw anti-local-APIC conclusions.
> - ensure you have the latest BIOS

I tend not to touch the BIOS unless I have reason to believe an update will
fix an actual problem.

> - if you're using APM, ensure that CPU_IDLE and DISPLAY_BLANK are
>   disabled, and that APM isn't built as a module
>   (these things are known to cause APM hangs in UP APIC systems)
> - if you're using ACPI, try without ACPI, or at least with ACPI not
>   doing any power management

Your suggestions match my current configuration:

#
# Power management options (ACPI, APM)
#
CONFIG_PM=y
CONFIG_SOFTWARE_SUSPEND=y

#
# ACPI Support
#
# CONFIG_ACPI is not set
CONFIG_APM=y
# CONFIG_APM_IGNORE_USER_SUSPEND is not set
# CONFIG_APM_DO_ENABLE is not set
# CONFIG_APM_CPU_IDLE is not set
# CONFIG_APM_DISPLAY_BLANK is not set
CONFIG_APM_RTC_IS_GMT=y
# CONFIG_APM_ALLOW_INTS is not set
# CONFIG_APM_REAL_MODE_POWER_OFF is not set

> A very general "may break some BIOSen" warning could be in order.

Mentioning specific symptoms (like breaking power off) wouldn't hurt,
either.

Roger

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: APIC support prevents power off
@ 2003-07-21  1:13 Mikael Pettersson
  2003-07-21  9:54 ` Roger Luethi
  0 siblings, 1 reply; 7+ messages in thread
From: Mikael Pettersson @ 2003-07-21  1:13 UTC (permalink / raw)
  To: linux-kernel, rl; +Cc: mingo

On Sun, 20 Jul 2003 16:36:13 +0200, Roger Luethi wrote:
>On some UP boards (e.g. ASUS A7A266) enabling support for local APICs keeps
>the machine from powering off on shutdown. It will just hang instead.
>
>This has been observed by others before [1]. A warning in the respective
>configuration note seems in order (or a proper fix if anybody has one).
>
>Roger
>
>[1] http://marc.theaimsgroup.com/?l=linux-kernel&m=105561164424871&w=2

Insufficient data to draw anti-local-APIC conclusions.
- ensure you have the latest BIOS
- if you're using APM, ensure that CPU_IDLE and DISPLAY_BLANK are
  disabled, and that APM isn't built as a module
  (these things are known to cause APM hangs in UP APIC systems)
- if you're using ACPI, try without ACPI, or at least with ACPI not
  doing any power management

A very general "may break some BIOSen" warning could be in order.

/Mikael

^ permalink raw reply	[flat|nested] 7+ messages in thread

end of thread, other threads:[~2003-07-22 23:13 UTC | newest]

Thread overview: 7+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2003-07-20 14:36 APIC support prevents power off Roger Luethi
2003-07-21  1:13 Mikael Pettersson
2003-07-21  9:54 ` Roger Luethi
2003-07-21 10:16   ` William Gallafent
2003-07-22  8:35 Mikael Pettersson
2003-07-22 11:45 ` Mark McClelland
2003-07-22 23:28 ` Roger Luethi

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).