linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Hugo Mills <hugo-lkml@carfax.org.uk>
To: Marcelo Tosatti <marcelo@conectiva.com.br>
Cc: Meelis Roos <mroos@math.ut.ee>,
	lkml <linux-kernel@vger.kernel.org>,
	neilb@cse.unsw.edu.au
Subject: Re: NFS server broken in 2.4.22-pre6?
Date: Sat, 26 Jul 2003 16:19:56 +0100	[thread overview]
Message-ID: <20030726151956.GA11253@carfax.org.uk> (raw)
In-Reply-To: <Pine.LNX.4.55L.0307251001480.12492@freak.distro.conectiva>

[-- Attachment #1: Type: text/plain, Size: 1625 bytes --]

On Fri, Jul 25, 2003 at 10:05:33AM -0300, Marcelo Tosatti wrote:
> 
> 
> On Thu, 24 Jul 2003, Meelis Roos wrote:
> 
> > NFS serving seems to be broken in 2.4.22-pre6. I had 2 computers running
> > 2.4.22-pre6 (x86, debian unstable current). Tried to acces them via NFS
> > (using am-utils actually) from a 3rd computer, IO error. Tried to
> > mount directly, mount: RPC: timed out. Rebooted one computer to 2.4.18
> > and NFS started to work.
> >
> > No more details currently but I can test more thoroughly tomorrow.
> 
> Meelis,
> 
> Please report more details.

   I'm also having trouble with NFS, with a 2.4.22-pre6-ac1 server.

   I'm booting a diskless workstation (with a 2.4.21-ac1 client), and
it will boot and mount the root filesystem. When I try to mount any
other filesystems, the client reports

mount: can't get address for vlad

and loses the main NFS mount: attempts to access any file on the root
filesystem gives stale NFS file handle errors. The failure to mount
also breaks the server -- I can no longer boot the diskless client.
Restarting the NFS server allows me to boot the client once again.

   Like Meelis, I'm also using Debian unstable, and I've tried with
both the 1.0.3-1 and 1.0.5 versions of the nfs-tools on both machines.
Both versions give the same error that I reported above.

   Hugo.

-- 
=== Hugo Mills: hugo@... carfax.org.uk | darksatanic.net | lug.org.uk ===
  PGP key: 1C335860 from wwwkeys.eu.pgp.net or http://www.carfax.org.uk
       --- "Are you the man who rules the Universe?" "Well,  I ---       
                              try not to."                               

[-- Attachment #2: Type: application/pgp-signature, Size: 189 bytes --]

  parent reply	other threads:[~2003-07-26 15:11 UTC|newest]

Thread overview: 6+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2003-07-24 17:29 NFS server broken in 2.4.22-pre6? Meelis Roos
2003-07-25 13:05 ` Marcelo Tosatti
2003-07-25 20:30   ` Meelis Roos
2003-07-25 21:02     ` Mike Fedyk
2003-07-26 15:19   ` Hugo Mills [this message]
2003-07-29 17:50     ` Matt C

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20030726151956.GA11253@carfax.org.uk \
    --to=hugo-lkml@carfax.org.uk \
    --cc=linux-kernel@vger.kernel.org \
    --cc=marcelo@conectiva.com.br \
    --cc=mroos@math.ut.ee \
    --cc=neilb@cse.unsw.edu.au \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).