linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Daniele Venzano <webvenza@libero.it>
To: Andrey Borzenkov <arvidjaar@mail.ru>
Cc: Andrew Morton <akpm@osdl.org>, linux-kernel@vger.kernel.org
Subject: Re: 2.6.0-test1 devfs question
Date: Sun, 27 Jul 2003 10:58:56 +0200	[thread overview]
Message-ID: <20030727085856.GA845@renditai.milesteg.arr> (raw)
In-Reply-To: <200307270230.01823.arvidjaar@mail.ru>

On Sun, Jul 27, 2003 at 02:30:01AM +0400, Andrey Borzenkov wrote:
> it is hard to tell with the amount of information provided in bug report (even 
> error message is not given). We have three cases here:
> 
> root=123456 (real major/minor number) or root=/dev/md2 (literal string). In 
> both cases init/do_mount_devfs.c:create_dev() should notice that neither 
> /dev/123456 nor /dev/md2 exist, search /dev for ROOT_DEV and create link from 
> /dev/root to real device. If it does not work somethig is broken here, people 
> who can reproduce it should add printk's to create_dev and find_in_devfs to 
> see what happens. It may fail for /dev/md2 if block device name in sysfs 
> differs from "md2" because then it won't find correct ROOT_DEV
> 
> root=/dev/md/2 (literal string) should work simply because /dev/root is linked 
> directly to /dev/md/2
> 
> I do not have any raid devices nor possibility to create them so I cannot 
> test.

Andrew's patch makes it work, the system boots fine with raid and devfs
mounted automatically.
Also using root=/dev/md/2 as boot option works (just tried).

Before the patch I tried with root=/dev/md2, that is what I'm using with
2.4, but didn't work. The error message is:
VFS: cannot open root device "md2" or md2
please append a correct "root=" boot option
Kernel panic: VFS: unable to mount root fs on md2

Let me know if you need more info, but I think the sysfs
explanation is right.

Bye.


-- 
----------------------------------------
Daniele Venzano
Web: http://digilander.iol.it/webvenza/


  reply	other threads:[~2003-07-27  8:43 UTC|newest]

Thread overview: 14+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2003-07-26 19:51 Andrey Borzenkov
2003-07-26 20:50 ` Andrew Morton
2003-07-26 22:30   ` Andrey Borzenkov
2003-07-27  8:58     ` Daniele Venzano [this message]
  -- strict thread matches above, loose matches on Subject: below --
2003-07-28  7:13 "Andrey Borzenkov" 
2003-07-28  7:22 ` Andrew Morton
2003-07-25 18:53 Balram Adlakha
2003-07-26 10:45 ` Wiktor Wodecki
     [not found]   ` <20030726175214.GA2535@localhost.localdomain>
     [not found]     ` <20030726183750.GB789@gmx.de>
     [not found]       ` <20030726201919.GA5166@localhost.localdomain>
2003-07-26 20:35         ` Wiktor Wodecki
2003-07-25 11:08 Wiktor Wodecki
2003-07-25 11:18 ` Wiktor Wodecki
2003-07-26 11:12 ` Daniele Venzano
2003-07-26 18:25   ` Andrew Morton
2003-07-27 11:17     ` Alan Cox

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20030727085856.GA845@renditai.milesteg.arr \
    --to=webvenza@libero.it \
    --cc=akpm@osdl.org \
    --cc=arvidjaar@mail.ru \
    --cc=linux-kernel@vger.kernel.org \
    --subject='Re: 2.6.0-test1 devfs question' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).