linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Paul <set@pobox.com>
To: linux-kernel@vger.kernel.org
Subject: Re: Unable to burn DVDs (possible pktcdvd problem?)
Date: Wed, 12 Jan 2005 02:25:01 -0500	[thread overview]
Message-ID: <20050112072501.GA6744@squish.home.loc> (raw)
In-Reply-To: <41E2F823.1070608@apartia.fr>

Laurent CARON <lcaron@apartia.fr>, on Mon Jan 10, 2005 [10:48:19 PM] said:
> Hello,
> 
> I recently upgraded to 2.6.10 and tried (today) to burn a dvd with 
> growisofs.
> 
> It seems there is a problem
> 
> Here is the output
> 
> 
> # growisofs -Z /dev/scd0 -R -J ~/foobar
> 
> WARNING: /dev/scd0 already carries isofs!
> About to execute 'mkisofs -R -J /root/sendmail.mc | builtin_dd 
> of=/dev/scd0 obs=32k seek=0'
> INFO:ingISO-8859-15 character encoding detected by locale settings.
>        Assuming ISO-8859-15 encoded filenames on source filesystem,
>        use -input-charset to override.
> Total translation table size: 0
> Total rockridge attributes bytes: 252
> Total directory bytes: 0
> Path table size(bytes): 10
> /dev/scd0: "Current Write Speed" is 4.1x1385KBps.
> :-[ WRITE@LBA=0h failed with SK=4h/ASC=08h/ACQ=03h]: Input/output error
> :-( write failed: Input/output error
> 
> 
> Needless to say it works fine with 2.6.9
> 
> Am I missing something?
> 
> Thanks
> 
> Laurent

	Hi;

	Using 2.6.10... (this hasnt happend under previous kernels,
but I cant swear as to the last one I burned a dvd under.)
	I too had a strange thing happen when I just tried to burn a
dvd with growisofs. First, it didnt work as non-root. (failed
with unable to set MODE, no dmesg) So, I became root, and it burnt all
right. But then the media wouldnt eject when I hit the eject
button. As a regular user I used the 'eject' command, but it
failed. I ran 'eject' as root, and it claimed to fail, but
actually ejected the disc.
	We see this in dmesg:
program eject is using a deprecated SCSI ioctl, p lease convert it to SG_IO
scsi: unknown opcode 0x1e

	After this, though is when things get odd. Xine failed to play
any dvd in the drive-- well, it would play the menu intro, but fail when
you clicked on a title. mplayer did better, but bombed out when I tried
to seek, and the drive refused to eject the disc after using any of 
these programs by hitting the manual button, but required root to run
the 'eject' command. No dmesg errors.
	I rebooted and things work as expected with xine and mplayer
on the dvd drive now. I dont know if the burning process was responsible
for messing up the drive state, or if it was possibly that I had 
previously used the pktcdvd driver... since I notice that there was
a kernel pktcdvd thread running previously, and not now. I wish I
had thought to tear down the pktcdvd association before rebooting...
	Anyway, Ill probably burn another dvd soon, and see what happens.

Paul
set@pobox.com
	


      parent reply	other threads:[~2005-01-12  7:25 UTC|newest]

Thread overview: 19+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2005-01-10 21:48 Unable to burn DVDs Laurent CARON
2005-01-10 22:29 ` Lennart Sorensen
2005-01-10 22:42   ` Laurent CARON
2005-01-10 23:50 ` Kasper Sandberg
2005-01-11  7:08 ` Jan Engelhardt
2005-01-11 16:11   ` Alan Cox
2005-01-11 18:30   ` Laurent CARON
2005-01-11 18:47     ` Grzegorz Kulewski
2005-01-11 19:00       ` Laurent CARON
2005-01-11 19:10       ` Jan Engelhardt
2005-01-11 20:09         ` Sipos Ferenc
2005-01-11 21:51           ` Nick Sanders
2005-01-12 17:00             ` Bill Davidsen
2005-01-18 10:56               ` Michal Schmidt
2005-01-18 23:41                 ` Bill Davidsen
2005-01-19  9:26                 ` Nick Sanders
     [not found]     ` <abdc35ac0501111439dc965e6@mail.gmail.com>
2005-01-11 22:54       ` Laurent CARON
2005-01-11 20:08 ` Peter Osterlund
2005-01-12  7:25 ` Paul [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20050112072501.GA6744@squish.home.loc \
    --to=set@pobox.com \
    --cc=linux-kernel@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).