linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [RFC] kobject_init changes
@ 2007-11-30 19:51 Greg KH
  2007-11-30 19:53 ` [RFC] kobject: add kobject_init_ng and kobject_init_and_add functions Greg KH
  0 siblings, 1 reply; 13+ messages in thread
From: Greg KH @ 2007-11-30 19:51 UTC (permalink / raw)
  To: Cornelia Huck, Kay Sievers, Alan Stern
  Cc: Kernel development list, Jonathan Corbet, Randy Dunlap

New thread time...

Here are two patches, one that adds a two new functions,
kobject_init_ng() and kobject_init_and_add() and then a patch that shows
how a number of different users are converted over to these new
functions.

I choose the name "kobject_init_ng()" for now, so that I can do a patch
series that converts the differnet usages in the kernel tree, and then
do a global rename all at once, making it easier to find any potential
problems that might happen.

Same goes for the _and_add() function, which is really just
kobject_register() but without the uevent call, and it has proper memory
cleanup.

Any objections to these changes?

My plans with this are:
	- clean up the rest of the kernel tree usages of kobject_init()
	- rename kobject_init_ng() to kobject_init().
	- remove all users of kobject_register() and use the new
	  functions and a uevent call.
	- fix up the new kobject_create_and_register() function to be
	  create_and_add() instead.

The last one will require some patch reworking in my tree, but I have
four days of meetings next week, and two plane rides, so I'll need
something real to do :)

I suppose if I really get bored, I can fix up the cdev stuff, but that's
going to take a lot more work...

thanks,

greg k-h

^ permalink raw reply	[flat|nested] 13+ messages in thread

end of thread, other threads:[~2007-12-01  0:59 UTC | newest]

Thread overview: 13+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2007-11-30 19:51 [RFC] kobject_init changes Greg KH
2007-11-30 19:53 ` [RFC] kobject: add kobject_init_ng and kobject_init_and_add functions Greg KH
2007-11-30 19:54   ` [RFC] kobject: convert some users of kobject_init to the new functions Greg KH
2007-11-30 20:25   ` [RFC] kobject: add kobject_init_ng and kobject_init_and_add functions Alan Stern
2007-11-30 21:04     ` Greg KH
2007-11-30 21:07       ` Greg KH
2007-11-30 21:19       ` Alan Stern
2007-11-30 21:48         ` Greg KH
2007-11-30 22:10           ` Alan Stern
2007-11-30 22:26             ` Greg KH
2007-11-30 23:22               ` Alan Stern
2007-12-01  0:58                 ` Greg KH
2007-11-30 22:33             ` Greg KH

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).