From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1758015AbYG3Tvm (ORCPT ); Wed, 30 Jul 2008 15:51:42 -0400 Received: (majordomo@vger.kernel.org) by vger.kernel.org id S1755030AbYG3Tut (ORCPT ); Wed, 30 Jul 2008 15:50:49 -0400 Received: from cantor2.suse.de ([195.135.220.15]:46961 "EHLO mx2.suse.de" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1756130AbYG3Tus (ORCPT ); Wed, 30 Jul 2008 15:50:48 -0400 Date: Wed, 30 Jul 2008 12:43:08 -0700 From: Greg KH To: Martin Schwidefsky Cc: linux-kernel@vger.kernel.org, linux-s390@vger.kernel.org, lf_kernel_messages@lists.linux-foundation.org, Andrew Morton , Michael Holzheu , Gerrit Huizenga , Randy Dunlap , Jan Kara , Pavel Machek , Sam Ravnborg , Joe Perches , Jochen =?iso-8859-1?B?Vm/f?= , Kunai Takashi , Tim Bird Subject: Re: [patch 3/3] kmsg: convert xpram messages to kmsg api. Message-ID: <20080730194308.GB22441@suse.de> References: <20080730165656.118280544@de.ibm.com> <20080730171157.550296160@de.ibm.com> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <20080730171157.550296160@de.ibm.com> User-Agent: Mutt/1.5.16 (2007-06-09) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Wed, Jul 30, 2008 at 06:56:59PM +0200, Martin Schwidefsky wrote: > From: Martin Schwidefsky > > Signed-off-by: Martin Schwidefsky > --- > > Documentation/kmsg/s390/xpram | 54 ++++++++++++++++++++++++++++++++++++++++++ > drivers/s390/block/xpram.c | 41 ++++++++++++++----------------- > 2 files changed, 73 insertions(+), 22 deletions(-) > > Index: linux-2.6/Documentation/kmsg/s390/xpram > =================================================================== > --- /dev/null > +++ linux-2.6/Documentation/kmsg/s390/xpram > @@ -0,0 +1,54 @@ > +/*? > + * Tag: xpram.1 Ick, so you are going to have to define a message number per file? How is that going to work, it looks like you use ids 0-2 below in the .c file, yet in this documentation file they are 1-3. Off by one somewhere? :) > + * Text: "%d is not a valid number of XPRAM devices" > + * Severity: Error > + * Parameter: > + * @1: number of partitions > + * Description: > + * The number of XPRAM partitions specified for the 'devs' module parameter > + * or with the 'xpram.parts' kernel parameter must be an integer in the > + * range 1 to 32. The XPRAM device driver created a maximum of 32 partitions > + * that are probably not configured as intended. > + * User action: > + * If the XPRAM device driver has been compiled as a separate module, > + * unload the module and load it again with a correct value for the > + * 'devs' module parameter. If the XPRAM device driver has been compiled > + * into the kernel, correct the 'xpram.parts' parameter in the kernel > + * parameter line and restart Linux. > + */ Any way to put this stuff in the .c file itself? It's hard enough getting people to update Documentation/ABI/, knowing to go modify something else in the Documentation directory is going to be _very_ difficult. > > +#define KMSG_COMPONENT "xpram" Can't you just use KBUILD_MODULE_NAME instead? That makes it one less thing you have to define in the code (and forget about when moving files around or cut-and-pasting). > /* Check number of devices. */ > if (devs <= 0 || devs > XPRAM_MAX_DEVS) { > - PRINT_ERR("invalid number %d of devices\n",devs); > + kmsg_err(1, "%d is not a valid number of XPRAM devices\n",devs); > return -EINVAL; Magic number "1" here? See comment above about this. thanks, greg k-h