linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Ingo Molnar <mingo@elte.hu>
To: Masami Hiramatsu <mhiramat@redhat.com>
Cc: Andrew Morton <akpm@linux-foundation.org>,
	Mathieu Desnoyers <mathieu.desnoyers@polymtl.ca>,
	Ananth N Mavinakayanahalli <ananth@in.ibm.com>,
	LKML <linux-kernel@vger.kernel.org>,
	systemtap-ml <systemtap@sources.redhat.com>
Subject: Re: [BUGFIX][PATCH -tip] x86: fix text_poke to handle highmem pages
Date: Wed, 8 Apr 2009 16:59:53 +0200	[thread overview]
Message-ID: <20090408145953.GP12931@elte.hu> (raw)
In-Reply-To: <49DCBB53.2020202@redhat.com>


* Masami Hiramatsu <mhiramat@redhat.com> wrote:

> Ingo Molnar wrote:
> > * Masami Hiramatsu <mhiramat@redhat.com> wrote:
> > 
> >> @@ -514,27 +515,39 @@ void *__kprobes text_poke(void *addr, const void *opcode, size_t len)
> >>  {
> >>  	unsigned long flags;
> >>  	char *vaddr;
> >> -	struct page *pages[2];
> >> +	struct page *page;
> >>  	int i;
> >> +	unsigned long endp = ((unsigned long)addr + len) & PAGE_MASK;
> >>
> >> -	if (!core_kernel_text((unsigned long)addr)) {
> >> -		pages[0] = vmalloc_to_page(addr);
> >> -		pages[1] = vmalloc_to_page(addr + PAGE_SIZE);
> >> -	} else {
> >> -		pages[0] = virt_to_page(addr);
> >> -		WARN_ON(!PageReserved(pages[0]));
> >> -		pages[1] = virt_to_page(addr + PAGE_SIZE);
> >> +	/*
> >> +	 * If the written range covers 2 pages, we'll split it, because
> >> +	 * vmalloc pages are not always continuous -- e.g. 1st page is
> >> +	 * lowmem and 2nd page is highmem.
> >> +	 */
> >> +	if (((unsigned long)addr & PAGE_MASK) != endp) {
> >> +		text_poke(addr, opcode, endp - (unsigned long)addr);
> >> +		addr =  (void *)endp;
> >> +		opcode = (char *)opcode + (endp - (unsigned long)addr);
> >> +		len -= endp - (unsigned long)addr;
> >>  	}
> >> -	BUG_ON(!pages[0]);
> >> +
> >> +	if (!core_kernel_text((unsigned long)addr))
> >> +		page = vmalloc_to_page(addr);
> >> +	else
> >> +		page = virt_to_page(addr);
> > 
> > hm, the bug is upstream now. And your fix turns a 
> > supposed-to-be-simpler kmap based patching thing back into something 
> > fragile looking again. We might be better off with a revert - or we 
> > do a real clean patch.
> > 
> > Firstly, that core_kernel_text() distinction above looks 
> > artificially open-coded - dont we have a proper, generic 
> > "look-up-the-page" variant in the MM somewhere?
> 
> Actually, vmalloc_to_page() is generic one. It decodes
> the kernel page table directly to find struct page *.
> virt_to_page() is just a short-cut api.
> 
> > 
> >> +	BUG_ON(!page);
> >>  	local_irq_save(flags);
> >> -	set_fixmap(FIX_TEXT_POKE0, page_to_phys(pages[0]));
> >> -	if (pages[1])
> >> -		set_fixmap(FIX_TEXT_POKE1, page_to_phys(pages[1]));
> >> -	vaddr = (char *)fix_to_virt(FIX_TEXT_POKE0);
> >> +	if (PageHighMem(page))
> >> +		vaddr = kmap_atomic(page, KM_TEXT_POKE);
> >> +	else {
> >> +		set_fixmap(FIX_TEXT_POKE, page_to_phys(page));
> >> +		vaddr = (char *)fix_to_virt(FIX_TEXT_POKE);
> >> +	}
> > 
> > that too looks artificially complex. Why cannot we kmap lowmem pages 
> > too? If the API isnt available on !HIGHMEM kernels .. then the 
> > solution is to make it available, not to branch our way around it.
> 
> Hmm, why don't we enhance fixmap to handle highmem pages?
> (e.g. adding set_fixmap_page())
> Since kmap is only for highmem kernels, I think changing it will effects
> more users...
> 
> Thank you,

Sure, whichever way looks more logical to you - my only condition is 
that it should result in a clean patch! :-)

	Ingo

  reply	other threads:[~2009-04-08 15:01 UTC|newest]

Thread overview: 22+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2009-04-04 14:34 [BUG][-tip] kprobes on module functions hits kernel BUG in text_poke on x86-32 Masami Hiramatsu
2009-04-04 15:42 ` Mathieu Desnoyers
2009-04-04 18:28   ` Masami Hiramatsu
2009-04-04 19:04     ` Masami Hiramatsu
2009-04-05  3:46       ` Masami Hiramatsu
2009-04-05  3:49         ` Masami Hiramatsu
2009-04-06 17:11         ` [BUGFIX][PATCH -tip] x86: fix text_poke to handle highmem pages Masami Hiramatsu
2009-04-06 17:32           ` Mathieu Desnoyers
2009-04-06 17:44             ` Masami Hiramatsu
2009-04-06 17:58               ` Mathieu Desnoyers
2009-04-06 20:23                 ` Masami Hiramatsu
2009-04-08 12:31           ` Ingo Molnar
2009-04-08 14:57             ` Masami Hiramatsu
2009-04-08 14:59               ` Ingo Molnar [this message]
2009-04-09 17:55                 ` [BUGFIX][PATCH] x86: fix set_fixmap to use phys_addr_t Masami Hiramatsu
2009-04-09 18:46                   ` Mathieu Desnoyers
2009-04-09 21:52                     ` Masami Hiramatsu
2009-04-10 14:06                   ` [tip:x86/urgent] " Masami Hiramatsu
2009-04-10 15:20                     ` Masami Hiramatsu
2009-04-10 16:05                       ` Mathieu Desnoyers
2009-04-10 17:48                         ` Masami Hiramatsu
2009-04-10 18:30                   ` Masami Hiramatsu

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20090408145953.GP12931@elte.hu \
    --to=mingo@elte.hu \
    --cc=akpm@linux-foundation.org \
    --cc=ananth@in.ibm.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mathieu.desnoyers@polymtl.ca \
    --cc=mhiramat@redhat.com \
    --cc=systemtap@sources.redhat.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).