linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Alex Chiang <achiang@hp.com>
To: Yinghai Lu <yinghai@kernel.org>
Cc: Jesse Barnes <jbarnes@virtuousgeek.org>,
	Ingo Molnar <mingo@elte.hu>,
	Linus Torvalds <torvalds@linux-foundation.org>,
	Ivan Kokshaysky <ink@jurassic.park.msu.ru>,
	Kenji Kaneshige <kaneshige.kenji@jp.fujitsu.com>,
	Bjorn Helgaas <bjorn.helgaas@hp.com>,
	linux-kernel@vger.kernel.org, linux-pci@vger.kernel.org
Subject: Re: [PATCH 06/11] pci: introduce pci_assign_unassigned_bridge_resources
Date: Fri, 15 Jan 2010 21:47:33 -0700	[thread overview]
Message-ID: <20100116044733.GF22215@ldl.fc.hp.com> (raw)
In-Reply-To: <1263609721-3921-7-git-send-email-yinghai@kernel.org>

> +static void pdev_assign_resources_sorted(struct pci_dev *dev,
> +				 struct resource_list_x *fail_head)
> +{
> +	struct resource *res;
> +	struct resource_list head, *list, *tmp;
> +	int idx;
> +	u16 class = dev->class >> 8;
> +
> +	head.next = NULL;
> +
> +	/* Don't touch classless devices or host bridges or ioapics.  */
> +	if (class == PCI_CLASS_NOT_DEFINED || class == PCI_CLASS_BRIDGE_HOST)
> +		return;
> +
> +	/* Don't touch ioapic devices already enabled by firmware */
> +	if (class == PCI_CLASS_SYSTEM_PIC) {
> +		u16 command;
> +		pci_read_config_word(dev, PCI_COMMAND, &command);
> +		if (command & (PCI_COMMAND_IO | PCI_COMMAND_MEMORY))
> +			return;
> +	}
> +
> +	pdev_sort_resources(dev, &head);
> +
> +	for (list = head.next; list;) {
> +		res = list->res;
> +		idx = res - &list->dev->resource[0];
> +		if (pci_assign_resource(list->dev, idx)) {
> +			if (fail_head && !pci_is_root_bus(list->dev->bus)) {
> +				/*
> +				 * device need to keep flags and size
> +				 * for second try
> +				 */
> +				add_to_failed_list(fail_head, list->dev, res);
> +			}
> +			res->start = 0;
> +			res->end = 0;
> +			res->flags = 0;
> +		}
> +		tmp = list;
> +		list = list->next;
> +		kfree(tmp);
> +	}
> +}

This is extremely similar to pbus_assign_resources_sorted(). Any
chance you could factor out the commonalities and reduce the
amount of duplicated code?

> +static void __ref __pci_bridge_assign_resources(const struct pci_dev *bridge,
> +					 struct resource_list_x *fail_head)
> +{
> +	struct pci_bus *b;
> +
> +	pdev_assign_resources_sorted((struct pci_dev *)bridge, fail_head);
> +
> +	b = bridge->subordinate;
> +	if (!b)
> +		return;
> +
> +	__pci_bus_assign_resources(b, fail_head);
> +
> +	switch (bridge->class >> 8) {
> +	case PCI_CLASS_BRIDGE_PCI:
> +		pci_setup_bridge(b);
> +		break;
> +
> +	case PCI_CLASS_BRIDGE_CARDBUS:
> +		pci_setup_cardbus(b);
> +		break;
> +
> +	default:
> +		dev_info(&bridge->dev, "not setting up bridge for bus "
> +			 "%04x:%02x\n", pci_domain_nr(b), b->number);

I think this should probably be a dev_dbg.

thanks,
/ac

  reply	other threads:[~2010-01-16  4:47 UTC|newest]

Thread overview: 27+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2010-01-16  2:41 [PATCH 00/11] pci: update pci bridge resources Yinghai Lu
2010-01-16  2:41 ` [PATCH 01/11] pci: add pci_bridge_release_unused_res and pci_bus_release_unused_bridge_res Yinghai Lu
2010-01-16  3:57   ` Alex Chiang
2010-01-16 10:10     ` Yinghai Lu
2010-01-16  2:41 ` [PATCH 02/11] pci: add failed_list to record failed one for pci_bus_assign_resources Yinghai Lu
2010-01-16  4:05   ` Alex Chiang
2010-01-16  2:41 ` [PATCH 03/11] pci: reject mmio range start from 0 on pci_bridge read Yinghai Lu
2010-01-16  4:20   ` Alex Chiang
2010-01-16  2:41 ` [PATCH 04/11] pci: don't shrink bridge resources Yinghai Lu
2010-01-16  2:41 ` [PATCH 05/11] pci: update bridge res to get more big range in pci assign unssign Yinghai Lu
2010-01-16  4:38   ` Alex Chiang
2010-01-16  2:41 ` [PATCH 06/11] pci: introduce pci_assign_unassigned_bridge_resources Yinghai Lu
2010-01-16  4:47   ` Alex Chiang [this message]
2010-01-16  2:41 ` [PATCH 07/11] pci: pciehp clean flow in pciehp_configure_device Yinghai Lu
2010-01-16  2:41 ` [PATCH 08/11] pci: pciehp second try to get big range for pcie devices Yinghai Lu
2010-01-16  4:52   ` Alex Chiang
2010-01-16  2:41 ` [PATCH 09/11] pci: pci_bridge_release_res Yinghai Lu
2010-01-16  4:57   ` Alex Chiang
2010-01-16  2:42 ` [PATCH 10/11] pciehp: add support for bridge resource reallocation Yinghai Lu
2010-01-16  4:59   ` Alex Chiang
2010-01-16  5:22     ` Yinghai Lu
2010-01-16  9:34     ` Yinghai Lu
2010-01-16 23:14       ` Bjorn Helgaas
2010-01-17 17:34         ` Jesse Barnes
2010-01-17 22:35           ` Yinghai Lu
2010-01-16  2:42 ` [PATCH 11/11] pci: set PCI_PREF_RANGE_TYPE_64 in pci_bridge_check_ranges Yinghai Lu
2010-01-16 11:07 [PATCH 00/11] pci: update pci bridge resources Yinghai Lu
2010-01-16 11:07 ` [PATCH 06/11] pci: introduce pci_assign_unassigned_bridge_resources Yinghai Lu

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20100116044733.GF22215@ldl.fc.hp.com \
    --to=achiang@hp.com \
    --cc=bjorn.helgaas@hp.com \
    --cc=ink@jurassic.park.msu.ru \
    --cc=jbarnes@virtuousgeek.org \
    --cc=kaneshige.kenji@jp.fujitsu.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-pci@vger.kernel.org \
    --cc=mingo@elte.hu \
    --cc=torvalds@linux-foundation.org \
    --cc=yinghai@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).