LKML Archive on lore.kernel.org
 help / color / Atom feed
From: Marin Mitov <mitov@issp.bas.bg>
To: FUJITA Tomonori <fujita.tomonori@lab.ntt.co.jp>
Cc: linux-kernel@vger.kernel.org, mingo@elte.hu, davej@redhat.com
Subject: Re: [BUG] agpgart-amd64 not initialized in 2.6.33-rc5 if iommu=allowed in kernel command line
Date: Mon, 25 Jan 2010 09:37:53 +0200
Message-ID: <201001250937.53518.mitov@issp.bas.bg> (raw)
In-Reply-To: <20100125141006O.fujita.tomonori@lab.ntt.co.jp>

On Monday 25 January 2010 07:10:47 am FUJITA Tomonori wrote:
> On Sat, 23 Jan 2010 23:14:55 +0200
> Marin Mitov <mitov@issp.bas.bg> wrote:
> 
> > Hi,
> > 
> > If I start the kernel without command line parameters (4GB RAM)
> > iommu-swiotlb is used due to quirk in VIA K8T800Pro Host Bridge.
> > In that case all is OK.
> > 
> > If I put in the kernel command line: iommu=allowed (+other parameters)
> > I have iommu-gart used but no AGP. dmesg output:
> > 
> > [drm:mga_do_agp_dma_bootstrap] *ERROR* Unable to acquire AGP: -19
> > 
> > For debugging I patched the kernel (mostly prink(), shown at the end)
> > producing the output in the dmesg:
> > 
> > no command line
> > MDM: agp_amd64_init entered
> > MDM: agp_off: false
> > MDM: agp_bridges_found: 0
> > MDM: gart_iommu_aperture: 0
> > MDM: agp_amd64_probe entered
> > 
> > command line: iommu=allowed:
> > MDM: gart_iommu_init
> > MDM: before: no_agp = 0
> > MDM: 	agp_amd64_init entered
> > MDM: 	agp_off: false
> > MDM: 	agp_bridges_found: 0
> > MDM: after: no_agp = 1
> > MDM: agp_amd64_init() < 0: 1
> > MDM: agp_copy_info() < 0: -1
> > MDM: 	agp_amd64_init entered
> > MDM: 	agp_off: false
> > MDM: 	agp_bridges_found: 0
> > 
> > One see in the last case ( iommu=allowed) agp_amd64_init()
> > is executed twice, but agp_amd64_probe() is not executed at all
> > (agp_bridges_found is incremented only in agp_amd64_probe())
> > 
> > Is this expected behavior?
> 
> Duh, it's my stupid mistake. Sorry about that.
> 
> This works for you?
> 
> Can you test this patch with set CONFIG_AGP_AMD64 to both y and m
> (also loading/unloading the module twice)?

If CONFIG_AGP_AMD64=y it works (I have agp) both with no kernel command 
line parameters as well as with iommu=allowed in kernel command line.

If CONFIG_AGP_AMD64=m  it works (I have agp)  with no kernel command
line parameters. If I boot to no graphics (runlevel 3 in slackware), 
lsmod output is:

amd64_agp               7463  1
agpgart                   27765  1 amd64_agp

amd64_agp is in use (not known by who), cannot be unloaded and I cannot 
test load/unload.

If CONFIG_AGP_AMD64=m and  iommu=allowed is in kernel command line
I have no agp.
dmesg:
[drm:mga_do_agp_dma_bootstrap] *ERROR* Unable to acquire AGP: -19
If I boot to no graphics and try:
modprobe amd64_agp
FATAL: Error inserting amd64_agp
(/lib/modules/2.6.33-rc5/kernel/drivers/char/agp/amd64-agp.ko): No such
device

For info: iommu=allowed changes gart_iommu_aperture_allowed from 0 to 1.

I am ready for further testing.

Marin Mitov

> 
> Thanks,
> 
> =
> From: FUJITA Tomonori <fujita.tomonori@lab.ntt.co.jp>
> Subject: [PATCH] x86/agp: fix agp_amd64_init regression
> 
> This fixes the regression introduced by the commit
> 42590a75019a50012f25a962246498dead428433.
> 
> The above commit changes agp_amd64_init() not to do anything if
> gart_iommu_aperture is not zero.
> 
> If GART iommu calls agp_amd64_init(), we need to skip agp_amd64_init()
> when it's called later via module_init.
> 
> The problem is that gart_iommu_init() calls agp_amd64_init() with not
> zero gart_iommu_aperture so agp_amd64_init() is never initialized.
> 
> When gart_iommu_init() calls agp_amd64_init(), agp should be always
> initialized.
> 
> Signed-off-by: FUJITA Tomonori <fujita.tomonori@lab.ntt.co.jp>
> ---
>  drivers/char/agp/amd64-agp.c |   13 +++++++++----
>  1 files changed, 9 insertions(+), 4 deletions(-)
> 
> diff --git a/drivers/char/agp/amd64-agp.c b/drivers/char/agp/amd64-agp.c
> index 1afb896..34cf04e 100644
> --- a/drivers/char/agp/amd64-agp.c
> +++ b/drivers/char/agp/amd64-agp.c
> @@ -729,9 +729,6 @@ int __init agp_amd64_init(void)
>  	if (agp_off)
>  		return -EINVAL;
>  
> -	if (gart_iommu_aperture)
> -		return agp_bridges_found ? 0 : -ENODEV;
> -
>  	err = pci_register_driver(&agp_amd64_pci_driver);
>  	if (err < 0)
>  		return err;
> @@ -768,6 +765,14 @@ int __init agp_amd64_init(void)
>  	return err;
>  }
>  
> +static int __init agp_amd64_mod_init(void)
> +{
> +	if (gart_iommu_aperture)
> +		return agp_bridges_found ? 0 : -ENODEV;
> +
> +	return agp_amd64_init();
> +}
> +
>  static void __exit agp_amd64_cleanup(void)
>  {
>  	if (gart_iommu_aperture)
> @@ -777,7 +782,7 @@ static void __exit agp_amd64_cleanup(void)
>  	pci_unregister_driver(&agp_amd64_pci_driver);
>  }
>  
> -module_init(agp_amd64_init);
> +module_init(agp_amd64_mod_init);
>  module_exit(agp_amd64_cleanup);
>  
>  MODULE_AUTHOR("Dave Jones <davej@redhat.com>, Andi Kleen");

  reply index

Thread overview: 9+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2010-01-23 21:14 Marin Mitov
2010-01-25  5:10 ` FUJITA Tomonori
2010-01-25  7:37   ` Marin Mitov [this message]
2010-02-02 11:23     ` FUJITA Tomonori
2010-02-02 15:49       ` FUJITA Tomonori
2010-02-03 15:19         ` Marin Mitov
2010-02-04  0:12           ` FUJITA Tomonori
2010-02-03 16:18         ` Marin Mitov
2010-01-31  8:30   ` [tip:x86/urgent] x86/agp: Fix agp_amd64_init regression tip-bot for FUJITA Tomonori

Reply instructions:

You may reply publically to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=201001250937.53518.mitov@issp.bas.bg \
    --to=mitov@issp.bas.bg \
    --cc=davej@redhat.com \
    --cc=fujita.tomonori@lab.ntt.co.jp \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@elte.hu \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

LKML Archive on lore.kernel.org

Archives are clonable:
	git clone --mirror https://lore.kernel.org/lkml/0 lkml/git/0.git
	git clone --mirror https://lore.kernel.org/lkml/1 lkml/git/1.git
	git clone --mirror https://lore.kernel.org/lkml/2 lkml/git/2.git
	git clone --mirror https://lore.kernel.org/lkml/3 lkml/git/3.git
	git clone --mirror https://lore.kernel.org/lkml/4 lkml/git/4.git
	git clone --mirror https://lore.kernel.org/lkml/5 lkml/git/5.git
	git clone --mirror https://lore.kernel.org/lkml/6 lkml/git/6.git
	git clone --mirror https://lore.kernel.org/lkml/7 lkml/git/7.git
	git clone --mirror https://lore.kernel.org/lkml/8 lkml/git/8.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 lkml lkml/ https://lore.kernel.org/lkml \
		linux-kernel@vger.kernel.org
	public-inbox-index lkml

Example config snippet for mirrors

Newsgroup available over NNTP:
	nntp://nntp.lore.kernel.org/org.kernel.vger.linux-kernel


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git