On Tue, 17 Jan 2012, Eric B Munson wrote: > Changes from V9: > Use kvm_for_each_vcpu to iterate online vcpu's > > Changes from V8: > Make KVM_GUEST_PAUSED a per vm ioctl instead of per vcpu > > Changes from V7: > Define KVM_CAP_GUEST_PAUSED and support check > Call mark_page_dirty () after setting PVCLOCK_GUEST_STOPPED > > Changes from V6: > Use __this_cpu_and when clearing the PVCLOCK_GUEST_STOPPED flag > > Changes from V5: > Collapse generic check_and_clear_guest_stopped into patch 2 > Include check_and_clear_guest_stopped defintion to ia64, s390, and powerpc > Change check_and_clear_guest_stopped to use __get_cpu_var instead of taking the > cpuid arg. > Protect check_and_clear_guest_stopped declaration with CONFIG_KVM_CLOCK check > > Changes from V4: > Rename KVM_GUEST_PAUSED to KVMCLOCK_GUEST_PAUSED > Add description of KVMCLOCK_GUEST_PAUSED ioctl to api.txt > > Changes from V3: > Include CC's on patch 3 > Drop clear flag ioctl and have the watchdog clear the flag when it is reset > > Changes from V2: > A new kvm functions defined in kvm_para.h, the only change to pvclock is the > initial flag definition > > Changes from V1: > (Thanks Marcelo) > Host code has all been moved to arch/x86/kvm/x86.c > KVM_PAUSE_GUEST was renamed to KVM_GUEST_PAUSED > > Eric B Munson (4): > Add flag to indicate that a vm was stopped by the host > Add functions to check if the host has stopped the vm > Add ioctl for KVMCLOCK_GUEST_STOPPED > Add check for suspended vm in softlockup detector > > Documentation/virtual/kvm/api.txt | 13 +++++++++++++ > arch/ia64/include/asm/kvm_para.h | 5 +++++ > arch/powerpc/include/asm/kvm_para.h | 5 +++++ > arch/s390/include/asm/kvm_para.h | 5 +++++ > arch/x86/include/asm/kvm_para.h | 8 ++++++++ > arch/x86/include/asm/pvclock-abi.h | 1 + > arch/x86/kernel/kvmclock.c | 21 +++++++++++++++++++++ > arch/x86/kvm/x86.c | 25 +++++++++++++++++++++++++ > include/asm-generic/kvm_para.h | 14 ++++++++++++++ > include/linux/kvm.h | 3 +++ > kernel/watchdog.c | 12 ++++++++++++ > 11 files changed, 112 insertions(+), 0 deletions(-) > create mode 100644 include/asm-generic/kvm_para.h > Just poking to make sure this set hasn't fallen through the cracks. Eric