linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Kent Overstreet <koverstreet@google.com>
To: Tejun Heo <tj@kernel.org>
Cc: linux-bcache@vger.kernel.org, linux-kernel@vger.kernel.org,
	dm-devel@redhat.com, axboe@kernel.dk, agk@redhat.com,
	neilb@suse.de, drbd-dev@lists.linbit.com, vgoyal@redhat.com,
	mpatocka@redhat.com, sage@newdream.net, yehuda@hq.newdream.net
Subject: Re: [PATCH v5 08/12] block: Introduce new bio_split()
Date: Mon, 13 Aug 2012 14:55:11 -0700	[thread overview]
Message-ID: <20120813215511.GE9541@google.com> (raw)
In-Reply-To: <20120808225839.GG6983@dhcp-172-17-108-109.mtv.corp.google.com>

On Wed, Aug 08, 2012 at 03:58:39PM -0700, Tejun Heo wrote:
> On Mon, Aug 06, 2012 at 03:08:37PM -0700, Kent Overstreet wrote:
> > + *
> > + * BIG FAT WARNING:
> > + *
> > + * If you're calling this from under generic_make_request() (i.e.
> > + * current->bio_list != NULL), you should mask out __GFP_WAIT and punt to
> > + * workqueue if the allocation fails. Otherwise, your code will probably
> > + * deadlock.
> 
> If the condition is detectable, WARN_ON_ONCE() please.

I know I said I liked this idea, but I changed my mind.

Sticking a WARN_ON_ONCE() there is saying that passing __GFP_WAIT from
under generic_make_request() is always wrong - it might as well be a
BUG_ON() except warn is better for the user.

If that's true, then an assertion is completely wrong because we can
just do the right thing instead - mask out __GFP_WAIT if
current->bio_list != NULL and document that it can fail in that
situation.

Which is what my original code did.

The alternative is accepting that there are situations where it is
technically possible to pass __GFP_WAIT from under
generic_make_request() without deadlocking and allow it, but my position
is still that that is far too subtle to expect that it'll be gotten
right (especially considering the ways that the code is wrong today
wrt deadlocks).

But honestly this is turning into bikeshedding. The current bio
splitting and merge_bvec_fn stuff is crap, and there are worse potential
deadlocks/bugs in the existing code than what we're arguing over here.

  parent reply	other threads:[~2012-08-13 21:55 UTC|newest]

Thread overview: 71+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2012-08-06 22:08 [PATCH v5 00/12] Block cleanups Kent Overstreet
2012-08-06 22:08 ` [PATCH v5 01/12] block: Generalized bio pool freeing Kent Overstreet
2012-08-08 22:25   ` Tejun Heo
2012-08-09  0:26     ` Kent Overstreet
2012-08-06 22:08 ` [PATCH v5 02/12] dm: Use bioset's front_pad for dm_rq_clone_bio_info Kent Overstreet
2012-08-08 22:06   ` Tejun Heo
2012-08-08 23:57     ` Kent Overstreet
2012-08-11  5:24       ` Joseph Glanville
2012-08-13 21:44         ` Kent Overstreet
2012-08-14  5:33   ` Jun'ichi Nomura
2012-08-15 20:46     ` Kent Overstreet
2012-08-06 22:08 ` [PATCH v5 03/12] block: Add bio_reset() Kent Overstreet
2012-08-08 22:11   ` Tejun Heo
2012-08-09  0:07     ` Kent Overstreet
2012-08-09  6:00       ` Tejun Heo
2012-08-09  6:06         ` Kent Overstreet
2012-08-09  6:30           ` Tejun Heo
2012-08-06 22:08 ` [PATCH v5 04/12] pktcdvd: Switch to bio_kmalloc() Kent Overstreet
2012-08-08 22:13   ` Tejun Heo
2012-08-09  0:08     ` Kent Overstreet
2012-08-06 22:08 ` [PATCH v5 05/12] block: Kill bi_destructor Kent Overstreet
2012-08-07  3:19   ` Mike Snitzer
2012-08-09  0:14     ` Kent Overstreet
2012-08-08 22:22   ` Tejun Heo
2012-08-09  0:21     ` Kent Overstreet
2012-08-09  6:05       ` Tejun Heo
2012-08-09  6:12         ` Kent Overstreet
2012-08-09  6:34           ` Tejun Heo
2012-08-15 22:19             ` Kent Overstreet
2012-08-06 22:08 ` [PATCH v5 06/12] block: Add an explicit bio flag for bios that own their bvec Kent Overstreet
2012-08-08 22:28   ` Tejun Heo
2012-08-06 22:08 ` [PATCH v5 07/12] block: Rename bio_split() -> bio_pair_split() Kent Overstreet
2012-08-06 22:08 ` [PATCH v5 08/12] block: Introduce new bio_split() Kent Overstreet
2012-08-08 22:58   ` Tejun Heo
2012-08-09  1:19     ` Kent Overstreet
2012-08-09  6:44       ` Tejun Heo
2012-08-13 21:55     ` Kent Overstreet [this message]
2012-08-13 22:05       ` Tejun Heo
2012-08-08 23:05   ` Tejun Heo
2012-08-09  1:39     ` Kent Overstreet
2012-08-09  7:22       ` Tejun Heo
2012-08-09  7:33         ` Kent Overstreet
2012-08-09 17:32           ` Tejun Heo
2012-08-13 22:09             ` Kent Overstreet
2012-08-06 22:08 ` [PATCH v5 09/12] block: Rework bio_pair_split() Kent Overstreet
2012-08-08 23:09   ` Tejun Heo
2012-08-06 22:08 ` [PATCH v5 10/12] block: Add bio_clone_kmalloc() Kent Overstreet
2012-08-08 23:15   ` Tejun Heo
2012-08-09  1:57     ` Kent Overstreet
2012-08-09  6:55       ` Tejun Heo
2012-08-09  7:02         ` Kent Overstreet
2012-08-09  2:38     ` [PATCH] Consolidate bio_clone_bioset(), bio_kmalloc() Kent Overstreet
2012-08-09  6:56       ` Tejun Heo
2012-08-06 22:08 ` [PATCH v5 11/12] block: Add bio_clone_bioset() Kent Overstreet
2012-08-08 23:21   ` Tejun Heo
2012-08-09  2:56     ` Kent Overstreet
2012-08-09  6:52       ` Tejun Heo
2012-08-09  6:59         ` Kent Overstreet
2012-08-06 22:08 ` [PATCH v5 12/12] block: Only clone bio vecs that are in use Kent Overstreet
2012-08-06 23:16   ` [dm-devel] " Mikulas Patocka
2012-08-08 23:28     ` Tejun Heo
2012-08-08 23:47       ` Muthu Kumar
2012-08-09  3:19         ` Kent Overstreet
2012-08-09  3:25           ` Kent Overstreet
2012-08-10  1:50           ` Muthu Kumar
2012-08-09  7:01         ` Tejun Heo
2012-08-10  2:29           ` Muthu Kumar
2012-08-08 23:30   ` Tejun Heo
2012-08-09  3:06     ` Kent Overstreet
2012-08-09 17:37   ` Tejun Heo
2012-08-13 21:46     ` Kent Overstreet

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20120813215511.GE9541@google.com \
    --to=koverstreet@google.com \
    --cc=agk@redhat.com \
    --cc=axboe@kernel.dk \
    --cc=dm-devel@redhat.com \
    --cc=drbd-dev@lists.linbit.com \
    --cc=linux-bcache@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mpatocka@redhat.com \
    --cc=neilb@suse.de \
    --cc=sage@newdream.net \
    --cc=tj@kernel.org \
    --cc=vgoyal@redhat.com \
    --cc=yehuda@hq.newdream.net \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).