linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Maxime Ripard <maxime.ripard@free-electrons.com>
To: Boris BREZILLON <boris.brezillon@free-electrons.com>
Cc: linux@maxim.org.za, Nicolas Ferre <nicolas.ferre@atmel.com>,
	Jean-Christophe Plagniol-Villard <plagnioj@jcrosoft.com>,
	Daniel Lezcano <daniel.lezcano@linaro.org>,
	Boris Brezillon <boris@free-electrons.com>,
	Alexandre Belloni <alexandre.belloni@free-electrons.com>,
	Thomas Petazzoni <thomas@free-electrons.com>,
	linux-arm-kernel@lists.infradead.org,
	linux-kernel@vger.kernel.org
Subject: Re: [PATCH 13/13] AT91: PIT: Move the driver to drivers/clocksource
Date: Thu, 26 Jun 2014 14:54:19 +0200	[thread overview]
Message-ID: <20140626125419.GC3385@lukather> (raw)
In-Reply-To: <53AC0882.3010601@free-electrons.com>

[-- Attachment #1: Type: text/plain, Size: 3723 bytes --]

On Thu, Jun 26, 2014 at 01:48:18PM +0200, Boris BREZILLON wrote:
> 
> On 26/06/2014 11:30, Maxime Ripard wrote:
> > Hi Boris,
> >
> > On Thu, Jun 26, 2014 at 07:26:54AM +0200, Boris BREZILLON wrote:
> >> On 25/06/2014 15:06, Maxime Ripard wrote:
> >>> Now that we don't depend on anyting in the mach-at91 directory, we can just
> >>> move the driver to where it belongs.
> >>>
> >>> Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com>
> >>> ---
> >>>  arch/arm/mach-at91/Kconfig                                     | 4 ----
> >>>  arch/arm/mach-at91/Makefile                                    | 1 -
> >>>  drivers/clocksource/Kconfig                                    | 4 ++++
> >>>  drivers/clocksource/Makefile                                   | 1 +
> >>>  {arch/arm/mach-at91 => drivers/clocksource}/at91sam926x_time.c | 0
> >>>  5 files changed, 5 insertions(+), 5 deletions(-)
> >>>  rename {arch/arm/mach-at91 => drivers/clocksource}/at91sam926x_time.c (100%)
> >>>
> >>> diff --git a/arch/arm/mach-at91/Kconfig b/arch/arm/mach-at91/Kconfig
> >>> index a64412a020d3..b10db0990999 100644
> >>> --- a/arch/arm/mach-at91/Kconfig
> >>> +++ b/arch/arm/mach-at91/Kconfig
> >>> @@ -36,10 +36,6 @@ config AT91_SAM9G45_RESET
> >>>  	bool
> >>>  	default !ARCH_AT91X40
> >>>  
> >>> -config AT91_SAM9_TIME
> >>> -	select CLKSRC_OF if OF
> >>> -	bool
> >>> -
> >>>  config HAVE_AT91_SMD
> >>>  	bool
> >>>  
> >>> diff --git a/arch/arm/mach-at91/Makefile b/arch/arm/mach-at91/Makefile
> >>> index 78e9cec282f4..1a916ececbfd 100644
> >>> --- a/arch/arm/mach-at91/Makefile
> >>> +++ b/arch/arm/mach-at91/Makefile
> >>> @@ -10,7 +10,6 @@ obj-		:=
> >>>  obj-$(CONFIG_OLD_CLK_AT91)	+= clock.o
> >>>  obj-$(CONFIG_AT91_SAM9_ALT_RESET) += at91sam9_alt_reset.o
> >>>  obj-$(CONFIG_AT91_SAM9G45_RESET) += at91sam9g45_reset.o
> >>> -obj-$(CONFIG_AT91_SAM9_TIME)	+= at91sam926x_time.o
> >>>  obj-$(CONFIG_SOC_AT91SAM9)	+= sam9_smc.o
> >>>  
> >>>  # CPU-specific support
> >>> diff --git a/drivers/clocksource/Kconfig b/drivers/clocksource/Kconfig
> >>> index 065131cbfcc0..cd8b73ddbef3 100644
> >>> --- a/drivers/clocksource/Kconfig
> >>> +++ b/drivers/clocksource/Kconfig
> >>> @@ -118,6 +118,10 @@ config CLKSRC_ARM_GLOBAL_TIMER_SCHED_CLOCK
> >>>  	help
> >>>  	 Use ARM global timer clock source as sched_clock
> >>>  
> >>> +config AT91_SAM9_TIME
> >>> +	select CLKSRC_OF if OF
> >>> +	bool
> >>> +
> >>>  config CLKSRC_METAG_GENERIC
> >>>  	def_bool y if METAG
> >>>  	help
> >>> diff --git a/drivers/clocksource/Makefile b/drivers/clocksource/Makefile
> >>> index 800b1303c236..3088928070f8 100644
> >>> --- a/drivers/clocksource/Makefile
> >>> +++ b/drivers/clocksource/Makefile
> >>> @@ -1,5 +1,6 @@
> >>>  obj-$(CONFIG_CLKSRC_OF)	+= clksrc-of.o
> >>>  obj-$(CONFIG_ATMEL_TCB_CLKSRC)	+= tcb_clksrc.o
> >>> +obj-$(CONFIG_AT91_SAM9_TIME)	+= at91sam926x_time.o
> >> I would rename both Kconfig and source file name into ATMEL_PIT and
> >> atmel_pit.c (or AT91_PIT and atmel_pit.c) to cleary show that this
> >> driver add support for the PIT block.
> > I actually had the same idea, but older AT91 SoCs (rm9200, for
> > example) also mention the PIT, even though the IP is different.
> 
> I checked at91rm9200 datasheet, and indeed it mention the concept of PIT
> (Periodic Interval Timer), but the HW block is called ST (System Timer).
> 
> How about using the name ATMEL_PIT for this driver and later use
> ATMEL_ST when we decide to move at91rm9200_time.c driver into
> drivers/clocksource ?

Works for me.

Maxime

-- 
Maxime Ripard, Free Electrons
Embedded Linux, Kernel and Android engineering
http://free-electrons.com

[-- Attachment #2: Digital signature --]
[-- Type: application/pgp-signature, Size: 819 bytes --]

  reply	other threads:[~2014-06-26 12:55 UTC|newest]

Thread overview: 21+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2014-06-25 13:06 [PATCH 00/13] AT91: PIT: Cleanups and move to drivers/clocksource Maxime Ripard
2014-06-25 13:06 ` [PATCH 01/13] AT91: PIT: Follow the general coding rules Maxime Ripard
2014-06-25 13:06 ` [PATCH 02/13] AT91: generic.h: Add include safe guards Maxime Ripard
2014-06-25 13:06 ` [PATCH 03/13] AT91: PIT: Use of_have_populated_dt instead of CONFIG_OF Maxime Ripard
2014-06-25 13:06 ` [PATCH 04/13] AT91: PIT: Rework probe functions Maxime Ripard
2014-06-25 13:06 ` [PATCH 05/13] AT91: dt: Remove init_time definitions Maxime Ripard
2014-06-25 13:06 ` [PATCH 06/13] AT91: PIT: Use consistent exit path in probe Maxime Ripard
2014-06-25 13:06 ` [PATCH 07/13] AT91: PIT: Use pr_fmt Maxime Ripard
2014-06-25 13:06 ` [PATCH 08/13] AT91: PIT: use request_irq instead of setup_irq Maxime Ripard
2014-06-25 13:06 ` [PATCH 09/13] AT91: PIT: (Almost) remove the global variables Maxime Ripard
2014-06-26  5:12   ` Boris BREZILLON
2014-06-26  9:28     ` Maxime Ripard
2014-06-25 13:06 ` [PATCH 10/13] AT91: soc: Add init_time callback Maxime Ripard
2014-06-25 13:06 ` [PATCH 11/13] AT91: Convert the boards to the " Maxime Ripard
2014-06-25 13:06 ` [PATCH 12/13] AT91: PIT: Convert to an early_platform_device Maxime Ripard
2014-06-25 13:06 ` [PATCH 13/13] AT91: PIT: Move the driver to drivers/clocksource Maxime Ripard
2014-06-26  5:26   ` Boris BREZILLON
2014-06-26  9:30     ` Maxime Ripard
2014-06-26 11:48       ` Boris BREZILLON
2014-06-26 12:54         ` Maxime Ripard [this message]
2014-06-26  5:30 ` [PATCH 00/13] AT91: PIT: Cleanups and move " Boris BREZILLON

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20140626125419.GC3385@lukather \
    --to=maxime.ripard@free-electrons.com \
    --cc=alexandre.belloni@free-electrons.com \
    --cc=boris.brezillon@free-electrons.com \
    --cc=boris@free-electrons.com \
    --cc=daniel.lezcano@linaro.org \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux@maxim.org.za \
    --cc=nicolas.ferre@atmel.com \
    --cc=plagnioj@jcrosoft.com \
    --cc=thomas@free-electrons.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).