linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Peter Zijlstra <peterz@infradead.org>
To: Peter Hurley <peter@hurleysoftware.com>
Cc: Fengguang Wu <fengguang.wu@intel.com>,
	Jet Chen <jet.chen@intel.com>, Su Tao <tao.su@intel.com>,
	Yuanhan Liu <yuanhan.liu@intel.com>, LKP <lkp@01.org>,
	linux-kernel@vger.kernel.org,
	Marcel Holtmann <marcel@holtmann.org>
Subject: Re: [rfcomm_run] WARNING: CPU: 1 PID: 79 at kernel/sched/core.c:7156 __might_sleep()
Date: Thu, 2 Oct 2014 15:41:56 +0200	[thread overview]
Message-ID: <20141002134156.GA10583@worktop.programming.kicks-ass.net> (raw)
In-Reply-To: <542D4DA6.2090607@hurleysoftware.com>

On Thu, Oct 02, 2014 at 09:05:42AM -0400, Peter Hurley wrote:

> >>> While at it, rename rfcomm_schedule to rfcomm_wake, since that is what
> >>> it actually does.
> >>
> >> rfcomm_schedule() as in schedule_work(), which is how it's used.
> > 
> > Not really, all it does is wake the rfcomm_thread. The thread then does
> > a linear walk of all known sessions looking for work -- which is clearly
> > suboptimal as well, but I didn't feel like fixing that.
> > 
> > Also, the current implementation already disagrees with you, all it
> > basically does it call wake_up_process() which is a big clue right
> > there.
> 
> You're thinking of it from the point of view of the scheduler, so to you
> it should be named what it does.

Of course I am, that thing is called 'schedule' so its natural to think
about the scheduler :-)

> However, from the users' point of view, it's an abstraction of work
> dispatching; the fact that a kthread (which needs waking) does the work
> is irrelevant.

Still a misnomer, see below.

> Consider if the kthread is converted to work_structs instead and your now-
> renamed rfcomm_wake() is calling schedule_work().

Then it would probably be less buggy and more efficient -- where I'm
assuming it would queue work per session and avoid the endless scanning
of sessions.

Also schedule_work() is somewhat sanely named in that you schedule the
work for later execution, so here we can use the term. The thread
however might already be scheduled or even running, so there it is not
appropriate.

  reply	other threads:[~2014-10-02 13:42 UTC|newest]

Thread overview: 26+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
     [not found] <20140930080228.GD9561@wfg-t540p.sh.intel.com>
2014-10-02 11:09 ` [rfcomm_run] WARNING: CPU: 1 PID: 79 at kernel/sched/core.c:7156 __might_sleep() Peter Zijlstra
2014-10-02 12:31   ` Peter Zijlstra
2014-10-02 12:38     ` Peter Hurley
2014-10-02 12:54       ` Peter Zijlstra
2014-10-02 13:05         ` Peter Hurley
2014-10-02 13:41           ` Peter Zijlstra [this message]
2014-10-02 12:42     ` Peter Zijlstra
2014-10-02 13:49       ` Peter Hurley
2014-10-02 13:52         ` Peter Zijlstra
2014-10-02 13:58           ` Peter Zijlstra
2014-10-02 14:16             ` Peter Hurley
2014-10-02 16:57               ` Peter Zijlstra
2014-10-02 19:18                 ` Oleg Nesterov
2014-10-02 19:11             ` Oleg Nesterov
2014-10-02 19:49               ` Peter Hurley
2014-10-02 19:57               ` Peter Zijlstra
2014-10-02 20:10       ` Oleg Nesterov
2014-10-03 11:50         ` Peter Zijlstra
2014-10-03 17:56           ` Oleg Nesterov
2014-10-03 19:30             ` Oleg Nesterov
2014-10-04  8:42               ` Peter Zijlstra
2014-10-06  0:25                 ` Oleg Nesterov
2014-10-06  9:19                   ` Peter Zijlstra
2014-10-06 10:59                     ` Paul E. McKenney
2014-10-06 16:21                     ` Oleg Nesterov
2014-10-04  8:44             ` Peter Zijlstra

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20141002134156.GA10583@worktop.programming.kicks-ass.net \
    --to=peterz@infradead.org \
    --cc=fengguang.wu@intel.com \
    --cc=jet.chen@intel.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=lkp@01.org \
    --cc=marcel@holtmann.org \
    --cc=peter@hurleysoftware.com \
    --cc=tao.su@intel.com \
    --cc=yuanhan.liu@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).