From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S933487AbbCQJ72 (ORCPT ); Tue, 17 Mar 2015 05:59:28 -0400 Received: from userp1040.oracle.com ([156.151.31.81]:51447 "EHLO userp1040.oracle.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S932396AbbCQJ7T (ORCPT ); Tue, 17 Mar 2015 05:59:19 -0400 Date: Tue, 17 Mar 2015 11:00:46 +0100 From: Quentin Casasnovas To: Borislav Petkov Cc: Quentin Casasnovas , Oleg Nesterov , Dave Hansen , Ingo Molnar , Andy Lutomirski , Linus Torvalds , Pekka Riikonen , Rik van Riel , Suresh Siddha , LKML , "Yu, Fenghua" , "H. Peter Anvin" Subject: Re: [PATCH RFC 0/2] x86/fpu: avoid "xstate_fault" in xsave_user/xrestore_user Message-ID: <20150317100046.GA19131@chrystal.uk.oracle.com> References: <54F74F59.5070107@intel.com> <20150315164948.GA28149@redhat.com> <20150316223743.GA14575@chrystal.uk.oracle.com> <20150317094750.GD18917@pd.tnic> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <20150317094750.GD18917@pd.tnic> User-Agent: Mutt/1.5.22 (2013-10-16) X-Source-IP: ucsinet21.oracle.com [156.151.31.93] Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Tue, Mar 17, 2015 at 10:47:50AM +0100, Borislav Petkov wrote: > On Mon, Mar 16, 2015 at 11:37:44PM +0100, Quentin Casasnovas wrote: > > ... > > > __user_insn("btl [var2], %0 \n\t", > > , /* no outputs, no need for dummy arg */ > > SINGLE_ARG("r" (var1), [var2] "r" (var2)), /* two inputs */ > > "cc"); > > So this becomes pretty unreadable IMO. And we shouldn't go nuts with > optimizing this and sacrifice readability a lot. > > TBH, I'd much prefer: > > if (static_cpu_has_safe(X86_FEATURE_XSAVEOPT)) { > check_insn(XSAVEOPT, ...); ^ > return; > } > > if (static_cpu_has_safe(X86_FEATURE_XSAVES)) { > check_insn(XSAVES); > return; > } > > check_insn(XSAVE, ...) > > which is pretty clear. > Fair point, but AFAIUI we can't do check_insn(XSAVES) alone as of today, and the "..." in your "check_isns(XSAVEOPT, ...)" code above would still need to contain the outputs operands. My suggestion was to rework (check|user)_insn() so it can accept zero to N inputs, outputs or clobbers to make it generic enough so the snippet of code you've written becomes valid, and maybe move those macro where they can be used for other sub-systems? Am I missing something? Quentin