linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Pavel Machek <pavel@ucw.cz>
To: Kishon Vijay Abraham I <kishon@ti.com>
Cc: NeilBrown <neil@brown.name>, Tony Lindgren <tony@atomide.com>,
	linux-api@vger.kernel.org, linux-kernel@vger.kernel.org,
	GTA04 owners <gta04-owner@goldelico.com>,
	NeilBrown <neilb@suse.de>
Subject: Re: [PATCH 1/5] usb: phy: twl4030: make runtime pm more reliable.
Date: Thu, 26 Mar 2015 07:39:50 +0100	[thread overview]
Message-ID: <20150326063950.GA755@amd> (raw)
In-Reply-To: <55132965.3090002@ti.com>

> > diff --git a/drivers/phy/phy-twl4030-usb.c
    b/drivers/phy/phy-twl4030-usb.c
> > index 8e87f54671f3..1a244f34b748 100644
> > --- a/drivers/phy/phy-twl4030-usb.c
> > +++ b/drivers/phy/phy-twl4030-usb.c
> > @@ -144,6 +144,16 @@
> >  #define PMBR1				0x0D
> >  #define GPIO_USB_4PIN_ULPI_2430C	(3 << 0)
> >  
> > +/*
> > + * If VBUS is valid or ID is ground, then we know a
> > + * cable is present and we need to be runtime-enabled
> > + */
> > +static inline bool cable_present(enum omap_musb_vbus_id_status stat)
> 
> twl4030_cable_present?

It is static function, no need for prefixes, they just make code
harder to read.
									Pavel

-- 
(english) http://www.livejournal.com/~pavelmachek
(cesky, pictures) http://atrey.karlin.mff.cuni.cz/~pavel/picture/horses/blog.html

  reply	other threads:[~2015-03-26  6:39 UTC|newest]

Thread overview: 17+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2015-03-22 22:35 [PATCH 0/5] Enhancements to twl4030 phy to support better charging - V2 NeilBrown
2015-03-22 22:35 ` [PATCH 5/5] usb: phy: twl4030: test ID resistance to see if charger is present NeilBrown
2015-03-22 22:35 ` [PATCH 4/5] usb: phy: twl4030: add support for reading restore on ID pin NeilBrown
2015-03-22 22:35 ` [PATCH 3/5] usb: phy: twl4030: add ABI documentation NeilBrown
2015-03-22 22:35 ` [PATCH 2/5] usb: phy: twl4030: allow charger to see usb current draw limits NeilBrown
2015-03-22 22:35 ` [PATCH 1/5] usb: phy: twl4030: make runtime pm more reliable NeilBrown
2015-03-25 21:32   ` Kishon Vijay Abraham I
2015-03-26  6:39     ` Pavel Machek [this message]
2015-03-23 21:25 ` [PATCH 0/5] Enhancements to twl4030 phy to support better charging - V2 Pavel Machek
2015-03-25 21:16 ` Kishon Vijay Abraham I
2015-03-25 21:22   ` NeilBrown
2015-03-25 23:59     ` Kishon Vijay Abraham I
2015-03-26  0:16       ` NeilBrown
2015-04-01  4:41       ` NeilBrown
2015-04-03 13:38         ` Kishon Vijay Abraham I
2015-04-04  0:28           ` NeilBrown
2015-04-14 10:54             ` Kishon Vijay Abraham I

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20150326063950.GA755@amd \
    --to=pavel@ucw.cz \
    --cc=gta04-owner@goldelico.com \
    --cc=kishon@ti.com \
    --cc=linux-api@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=neil@brown.name \
    --cc=neilb@suse.de \
    --cc=tony@atomide.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).