linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Borislav Petkov <bp@suse.de>
To: Andy Lutomirski <luto@kernel.org>
Cc: x86@kernel.org, Peter Zijlstra <peterz@infradead.org>,
	John Stultz <john.stultz@linaro.org>,
	linux-kernel@vger.kernel.org, Len Brown <lenb@kernel.org>,
	Huang Rui <ray.huang@amd.com>,
	Denys Vlasenko <dvlasenk@redhat.com>
Subject: Re: [PATCH v2 15/17] x86: Add rdtsc_ordered() and use it in trivial call sites
Date: Sat, 13 Jun 2015 11:02:11 +0200	[thread overview]
Message-ID: <20150613090211.GC3796@pd.tnic> (raw)
In-Reply-To: <fe0e48a2c5fb7b76c125437994991e29676ada09.1434152603.git.luto@kernel.org>

On Fri, Jun 12, 2015 at 04:44:55PM -0700, Andy Lutomirski wrote:
> barrier_before_rdtsc(); rdtsc_unordered() is an unnecessary mouthful and
> requires more thought than should be necessary.  Add an rdtsc_ordered()
> helper and replace the trivial call sites with it.
> 
> This should not change generated code.
> 
> Signed-off-by: Andy Lutomirski <luto@kernel.org>
> ---

...

> diff --git a/arch/x86/include/asm/msr.h b/arch/x86/include/asm/msr.h
> index a47fb11af5f5..22d69d2d1f0d 100644
> --- a/arch/x86/include/asm/msr.h
> +++ b/arch/x86/include/asm/msr.h
> @@ -148,6 +148,20 @@ static __always_inline void barrier_before_rdtsc(void)
>  			  "lfence", X86_FEATURE_LFENCE_RDTSC);
>  }
>  
> +/**
> + * rdtsc_ordered() - read the current TSC in program order
> + *
> + * rdtsc_ordered() returns the result of RDTSC as a 64-bit integer.
> + * It is ordered like a load to a global in-memory counter.  It should
> + * be impossible to observe non-monotonic rdtsc_unordered() behavior
> + * across multiple CPUs as long as the TSC is synced.
> + */
> +static __always_inline unsigned long long rdtsc_ordered(void)
> +{
> +	barrier_before_rdtsc();
> +	return rdtsc_unordered();
> +}
> +

I don't see the final tree state with all those applied (too lazy to
apply them) but why not simply kill barrier_before_rdtsc() and inline
the alternative into rdtsc_ordered()?

I mean, I don't see usage for it somewhere else...

-- 
Regards/Gruss,
    Boris.

ECO tip #101: Trim your mails when you reply.
--

  reply	other threads:[~2015-06-13  9:02 UTC|newest]

Thread overview: 31+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2015-06-12 23:44 [PATCH v2 00/17] x86/tsc: Clean up rdtsc helpers Andy Lutomirski
2015-06-12 23:44 ` [PATCH v2 01/17] x86/tsc: Inline native_read_tsc and remove __native_read_tsc Andy Lutomirski
2015-06-12 23:44 ` [PATCH v2 02/17] x86/msr/kvm: Remove vget_cycles() Andy Lutomirski
2015-06-12 23:44 ` [PATCH v2 03/17] x86/tsc/paravirt: Remove the read_tsc and read_tscp paravirt hooks Andy Lutomirski
2015-06-12 23:44 ` [PATCH v2 04/17] x86/tsc: Replace rdtscll with native_read_tsc Andy Lutomirski
2015-06-12 23:44 ` [PATCH v2 05/17] x86/tsc: Remove the rdtscp and rdtscpll macros Andy Lutomirski
2015-06-12 23:44 ` [PATCH v2 06/17] x86/tsc: Use the full 64-bit tsc in tsc_delay Andy Lutomirski
2015-06-12 23:44 ` [PATCH v2 07/17] x86/cpu/amd: Use the full 64-bit TSC to detect the 2.6.2 bug Andy Lutomirski
2015-06-12 23:44 ` [PATCH v2 08/17] baycom_epp: Replace rdtscl() with native_read_tsc() Andy Lutomirski
2015-06-13 10:45   ` walter harms
2015-06-15 23:15     ` Andy Lutomirski
2015-06-12 23:44 ` [PATCH v2 09/17] staging/lirc_serial: Remove TSC-based timing Andy Lutomirski
2015-06-19 13:02   ` Dan Carpenter
2015-06-19 16:15   ` Andy Lutomirski
2015-06-12 23:44 ` [PATCH v2 10/17] input/joystick/analog: Switch from rdtscl() to native_read_tsc() Andy Lutomirski
2015-06-16 23:03   ` Dmitry Torokhov
2015-06-16 23:09     ` Andy Lutomirski
2015-06-16 23:15       ` Dmitry Torokhov
2015-06-12 23:44 ` [PATCH v2 11/17] drivers/input/gameport: Replace rdtscl() with native_read_tsc() Andy Lutomirski
2015-06-16 23:04   ` Dmitry Torokhov
2015-06-12 23:44 ` [PATCH v2 12/17] x86/tsc: Remove rdtscl() Andy Lutomirski
2015-06-12 23:44 ` [PATCH v2 13/17] x86/tsc: Rename native_read_tsc() to rdtsc_unordered() Andy Lutomirski
2015-06-13  8:57   ` Borislav Petkov
2015-06-13 18:25     ` Andy Lutomirski
2015-06-14 11:54       ` Borislav Petkov
2015-06-12 23:44 ` [PATCH v2 14/17] x86/tsc: Move rdtsc_barrier() and rename it to barrier_before_rdtsc() Andy Lutomirski
2015-06-12 23:44 ` [PATCH v2 15/17] x86: Add rdtsc_ordered() and use it in trivial call sites Andy Lutomirski
2015-06-13  9:02   ` Borislav Petkov [this message]
2015-06-13 18:25     ` Andy Lutomirski
2015-06-12 23:44 ` [PATCH v2 16/17] x86/tsc: Use rdtsc_ordered() in check_tsc_warp() and drop extra barriers Andy Lutomirski
2015-06-12 23:44 ` [PATCH v2 17/17] x86/tsc: In read_tsc, use rdtsc_ordered() instead of get_cycles() Andy Lutomirski

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20150613090211.GC3796@pd.tnic \
    --to=bp@suse.de \
    --cc=dvlasenk@redhat.com \
    --cc=john.stultz@linaro.org \
    --cc=lenb@kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=luto@kernel.org \
    --cc=peterz@infradead.org \
    --cc=ray.huang@amd.com \
    --cc=x86@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).