From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S932138AbbFRJ5q (ORCPT ); Thu, 18 Jun 2015 05:57:46 -0400 Received: from mail-wi0-f178.google.com ([209.85.212.178]:33933 "EHLO mail-wi0-f178.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1754726AbbFRJ5Z (ORCPT ); Thu, 18 Jun 2015 05:57:25 -0400 Date: Thu, 18 Jun 2015 11:57:20 +0200 From: Ingo Molnar To: Andy Lutomirski Cc: Andy Lutomirski , "Paul E. McKenney" , X86 ML , "linux-kernel@vger.kernel.org" , =?iso-8859-1?Q?Fr=E9d=E9ric?= Weisbecker , Rik van Riel , Oleg Nesterov , Denys Vlasenko , Borislav Petkov , Kees Cook , Brian Gerst Subject: Re: [RFC/INCOMPLETE 01/13] context_tracking: Add context_tracking_assert_state Message-ID: <20150618095719.GA4528@gmail.com> References: <1d95640676a92a5ff7382e9c87517c12ea23ccd9.1434485184.git.luto@kernel.org> <20150617094114.GA3940@gmail.com> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: User-Agent: Mutt/1.5.23 (2014-03-12) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org * Andy Lutomirski wrote: > On Wed, Jun 17, 2015 at 2:41 AM, Ingo Molnar wrote: > > > > * Andy Lutomirski wrote: > > > >> This will let us sprinkle sanity checks around the kernel without > >> making too much of a mess. > >> > >> Signed-off-by: Andy Lutomirski > >> --- > >> include/linux/context_tracking.h | 8 ++++++++ > >> 1 file changed, 8 insertions(+) > >> > >> diff --git a/include/linux/context_tracking.h b/include/linux/context_tracking.h > >> index 2821838256b4..0fbea4b152e1 100644 > >> --- a/include/linux/context_tracking.h > >> +++ b/include/linux/context_tracking.h > >> @@ -57,6 +57,13 @@ static inline void context_tracking_task_switch(struct task_struct *prev, > >> if (context_tracking_is_enabled()) > >> __context_tracking_task_switch(prev, next); > >> } > >> + > >> +static inline void context_tracking_assert_state(enum ctx_state state) > >> +{ > >> + rcu_lockdep_assert(!context_tracking_is_enabled() || > >> + this_cpu_read(context_tracking.state) == state, > >> + "context tracking state was wrong"); > >> +} > > > > Please don't introduce assert() style debug check interfaces! > > > > (And RCU should be fixed too I suspect.) > > > > They are absolutely horrible on the brain when mixed with WARN_ON() interfaces, > > which are the dominant runtime check interface in the kernel. > > > > Instead make it something like: > > > > #define ct_state() (this_cpu_read(context_tracking.state)) > > > > #define CT_WARN_ON(cond) \ > > WARN_ON(context_tracking_is_enabled() && (cond)) > > > > and then the debug checks can be written as: > > > > CT_WARN_ON(ct_state() != CONTEXT_KERNEL); > > > > This is IMHO _far_ more readable than: > > > > context_tracking_assert_state(CONTEXT_KERNEL); > > > > ok? > > > > (Assuming people will accept 'ct/CT' as an abbreviation for context tracking.) > > Hmm, ok I guess. The part I don't like is having ct_state() at all on > non-context-tracking kernels -- it seems like it's asking for trouble. Well: - if # CONFIG_CONTEXT_TRACKING is not se, then CT_WARN_ON() does nothing. - if CONFIG_CONTEXT_TRACKING=y, but !context_tracking_is_enabled(), then CT_WARN_ON() will evaluate 'cond', but won't calculate it. - only if CONFIG_CONTEXT_TRACKING=y && context_tracking_is_enabled() should we get as far as ct_state() evaluation. so I'm not sure I see the problem you are seeing. > We could make CT_WARN_ON not even evaluate its argument if > !CONFIG_CONTEXT_TRACKING, but then we still have ct_state() returning garbage if > !context_tracking_is_enabled(). My understanding is that if !context_tracking_is_enabled() then the compiler should not even try to evaluate the rest. This is why doing a NULL pointer check like this is safe: if (tsk && tsk->field) { ... } > The assert macro avoids all these problems despite being a bit ugly. but writing good kernel code is all about not being ugly... Thanks, Ingo