From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1754596AbbGFKdJ (ORCPT ); Mon, 6 Jul 2015 06:33:09 -0400 Received: from mail-la0-f43.google.com ([209.85.215.43]:35484 "EHLO mail-la0-f43.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1752715AbbGFKdE (ORCPT ); Mon, 6 Jul 2015 06:33:04 -0400 Date: Mon, 6 Jul 2015 12:33:10 +0200 From: Johan Hovold To: SF Markus Elfring Cc: Greg Kroah-Hartman , Johan Hovold , linux-usb@vger.kernel.org, LKML , kernel-janitors@vger.kernel.org, Julia Lawall Subject: Re: [PATCH] USB-mxuport: Delete an unnecessary check before the function call "release_firmware" Message-ID: <20150706103310.GC32202@localhost> References: <530C5E18.1020800@users.sourceforge.net> <530CD2C4.4050903@users.sourceforge.net> <530CF8FF.8080600@users.sourceforge.net> <530DD06F.4090703@users.sourceforge.net> <5317A59D.4@users.sourceforge.net> <558FF1EC.2060605@users.sourceforge.net> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <558FF1EC.2060605@users.sourceforge.net> User-Agent: Mutt/1.5.23 (2014-03-12) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Sun, Jun 28, 2015 at 03:09:00PM +0200, SF Markus Elfring wrote: > From: Markus Elfring > Date: Sun, 28 Jun 2015 14:59:04 +0200 > > The release_firmware() function tests whether its argument is NULL and then > returns immediately. Thus the test around the call is not needed. > > This issue was detected by using the Coccinelle software. > > Signed-off-by: Markus Elfring > --- > drivers/usb/serial/mxuport.c | 3 +-- > 1 file changed, 1 insertion(+), 2 deletions(-) > > diff --git a/drivers/usb/serial/mxuport.c b/drivers/usb/serial/mxuport.c > index 460a406..92f7aee 100644 > --- a/drivers/usb/serial/mxuport.c > +++ b/drivers/usb/serial/mxuport.c > @@ -1101,8 +1101,7 @@ static int mxuport_probe(struct usb_serial *serial, > */ > usb_set_serial_data(serial, (void *)id->driver_info); > out: > - if (fw_p) > - release_firmware(fw_p); > + release_firmware(fw_p); > return err; > } You sent the exact same patch last year and it was rejected then as it does not improve readability: https://www.marc.info/?l=linux-usb&m=141682024201419&w=3 So I'll drop this one again. Johan