From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1753778AbbHTOrV (ORCPT ); Thu, 20 Aug 2015 10:47:21 -0400 Received: from mail-wi0-f178.google.com ([209.85.212.178]:36564 "EHLO mail-wi0-f178.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1753731AbbHTOrR (ORCPT ); Thu, 20 Aug 2015 10:47:17 -0400 Date: Thu, 20 Aug 2015 15:47:06 +0100 From: Matt Fleming To: "Lee, Chun-Yi" Cc: linux-kernel@vger.kernel.org, linux-efi@vger.kernel.org, linux-pm@vger.kernel.org, "Rafael J. Wysocki" , Matthew Garrett , Len Brown , Pavel Machek , Josh Boyer , Vojtech Pavlik , Matt Fleming , Jiri Kosina , "H. Peter Anvin" , Ingo Molnar , "Lee, Chun-Yi" Subject: Re: [PATCH v2 05/16] x86/efi: Get entropy through EFI random number generator protocol Message-ID: <20150820144706.GD2567@codeblueprint.co.uk> References: <1439273796-25359-1-git-send-email-jlee@suse.com> <1439273796-25359-6-git-send-email-jlee@suse.com> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <1439273796-25359-6-git-send-email-jlee@suse.com> User-Agent: Mutt/1.5.21 (2010-09-15) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Tue, 11 Aug, at 02:16:25PM, Lee, Chun-Yi wrote: > To grab random numbers through EFI protocol as one of the entropies > source of swsusp key, this patch adds the logic for accessing EFI RNG > (random number generator) protocol that's introduced since UEFI 2.4. > > Signed-off-by: Lee, Chun-Yi > --- > arch/x86/boot/compressed/efi_random.c | 209 ++++++++++++++++++++++++++++++++++ > include/linux/efi.h | 13 +++ > 2 files changed, 222 insertions(+) [...] Most of this looks good. > +static unsigned long efi_get_rng(efi_system_table_t *sys_table) > +{ > + const struct efi_config *efi_early = __efi_early(); > + unsigned long random = 0; > + efi_status_t status; > + void **rng_handle = NULL; > + > + status = efi_locate_rng(sys_table, &rng_handle); > + if (status != EFI_SUCCESS) > + return 0; > + > + if (efi_early->is64) > + random = efi_get_rng64(sys_table, rng_handle); > + else > + random = efi_get_rng32(sys_table, rng_handle); > + > + efi_call_early(free_pool, rng_handle); > + > + return random; > +} I think this function is named particularly poorly in the UEFI spec (GetRNG), can we maybe make this efi_get_rng_number(), efi_get_rng_value() or efi_get_rng_long() to match the existing naming? > diff --git a/include/linux/efi.h b/include/linux/efi.h > index 85ef051..8914d60 100644 > --- a/include/linux/efi.h > +++ b/include/linux/efi.h > @@ -427,6 +427,16 @@ typedef struct { > #define EFI_PCI_IO_ATTRIBUTE_VGA_PALETTE_IO_16 0x20000 > #define EFI_PCI_IO_ATTRIBUTE_VGA_IO_16 0x40000 > > +typedef struct { > + u32 get_info; > + u32 get_rng; > +} efi_rng_protocol_32; > + > +typedef struct { > + u64 get_info; > + u64 get_rng; > +} efi_rng_protocol_64; > + We've been kinda slack with the naming conventions in efi.h but these should really both be 'efi_rng_protocol_*_t'. -- Matt Fleming, Intel Open Source Technology Center