On Tue, Mar 08, 2016 at 05:32:05PM +0530, Laxman Dewangan wrote: > Print the error number of GPIO hog failed during > its configurations. This helps in identifying the > failure without instrumenting the code. Please use up all 72 characters per line at your disposal. Excessively short lines are hard to read. > Signed-off-by: Laxman Dewangan > --- > drivers/gpio/gpiolib.c | 9 +++++---- > 1 file changed, 5 insertions(+), 4 deletions(-) > > diff --git a/drivers/gpio/gpiolib.c b/drivers/gpio/gpiolib.c > index bc788b9..7575ebb 100644 > --- a/drivers/gpio/gpiolib.c > +++ b/drivers/gpio/gpiolib.c > @@ -2621,15 +2621,16 @@ int gpiod_hog(struct gpio_desc *desc, const char *name, > > local_desc = gpiochip_request_own_desc(chip, hwnum, name); > if (IS_ERR(local_desc)) { > - pr_err("requesting hog GPIO %s (chip %s, offset %d) failed\n", > - name, chip->label, hwnum); > + status = PTR_ERR(local_desc); > + pr_err("requesting hog GPIO %s, chip %s, offset %d failed %d\n", > + name, chip->label, hwnum, status); I find this type of format hard to read. I prefer a semi-colon to separate the message from the failure reason (i.e. error code). Besides that I don't understand why you're dropping the parentheses around the "chip %s, offset %d", I found that easier on the eye. Thierry