From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1752731AbcDDGBb (ORCPT ); Mon, 4 Apr 2016 02:01:31 -0400 Received: from LGEAMRELO13.lge.com ([156.147.23.53]:44370 "EHLO lgeamrelo13.lge.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751150AbcDDGBa (ORCPT ); Mon, 4 Apr 2016 02:01:30 -0400 X-Original-SENDERIP: 156.147.1.126 X-Original-MAILFROM: minchan@kernel.org X-Original-SENDERIP: 165.244.98.150 X-Original-MAILFROM: minchan@kernel.org X-Original-SENDERIP: 10.177.223.161 X-Original-MAILFROM: minchan@kernel.org Date: Mon, 4 Apr 2016 15:01:34 +0900 From: Minchan Kim To: Balbir Singh CC: Andrew Morton , linux-kernel@vger.kernel.org, linux-mm@kvack.org, jlayton@poochiereds.net, bfields@fieldses.org, Vlastimil Babka , Joonsoo Kim , koct9i@gmail.com, aquini@redhat.com, virtualization@lists.linux-foundation.org, Mel Gorman , Hugh Dickins , Sergey Senozhatsky , Rik van Riel , rknize@motorola.com, Gioh Kim , Sangseok Lee , Chan Gyun Jeong , Al Viro , YiPing Xu , Naoya Horiguchi Subject: Re: [PATCH v3 01/16] mm: use put_page to free page instead of putback_lru_page Message-ID: <20160404060134.GA7555@bbox> References: <1459321935-3655-1-git-send-email-minchan@kernel.org> <1459321935-3655-2-git-send-email-minchan@kernel.org> <57020177.60006@gmail.com> MIME-Version: 1.0 In-Reply-To: <57020177.60006@gmail.com> User-Agent: Mutt/1.5.21 (2010-09-15) X-MIMETrack: Itemize by SMTP Server on LGEKRMHUB07/LGE/LG Group(Release 8.5.3FP6|November 21, 2013) at 2016/04/04 15:01:27, Serialize by Router on LGEKRMHUB07/LGE/LG Group(Release 8.5.3FP6|November 21, 2013) at 2016/04/04 15:01:27, Serialize complete at 2016/04/04 15:01:27 Content-Type: text/plain; charset="us-ascii" Content-Disposition: inline Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Mon, Apr 04, 2016 at 03:53:59PM +1000, Balbir Singh wrote: > > > On 30/03/16 18:12, Minchan Kim wrote: > > Procedure of page migration is as follows: > > > > First of all, it should isolate a page from LRU and try to > > migrate the page. If it is successful, it releases the page > > for freeing. Otherwise, it should put the page back to LRU > > list. > > > > For LRU pages, we have used putback_lru_page for both freeing > > and putback to LRU list. It's okay because put_page is aware of > > LRU list so if it releases last refcount of the page, it removes > > the page from LRU list. However, It makes unnecessary operations > > (e.g., lru_cache_add, pagevec and flags operations. It would be > > not significant but no worth to do) and harder to support new > > non-lru page migration because put_page isn't aware of non-lru > > page's data structure. > > > > To solve the problem, we can add new hook in put_page with > > PageMovable flags check but it can increase overhead in > > hot path and needs new locking scheme to stabilize the flag check > > with put_page. > > > > So, this patch cleans it up to divide two semantic(ie, put and putback). > > If migration is successful, use put_page instead of putback_lru_page and > > use putback_lru_page only on failure. That makes code more readable > > and doesn't add overhead in put_page. > So effectively when we return from unmap_and_move() the page is either > put_page or putback_lru_page() and the page is gone from under us. I didn't get your point. Could you elaborate it more what you want to say about this patch?