linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Arnaldo Carvalho de Melo <acme@kernel.org>
To: Alexei Starovoitov <alexei.starovoitov@gmail.com>
Cc: David Ahern <dsahern@gmail.com>,
	Arnaldo Carvalho de Melo <arnaldo.melo@gmail.com>,
	Peter Zijlstra <peterz@infradead.org>,
	Frederic Weisbecker <fweisbec@gmail.com>,
	Ingo Molnar <mingo@kernel.org>,
	Adrian Hunter <adrian.hunter@intel.com>,
	Brendan Gregg <brendan.d.gregg@gmail.com>,
	Alexander Shishkin <alexander.shishkin@linux.intel.com>,
	Alexei Starovoitov <ast@kernel.org>,
	He Kuang <hekuang@huawei.com>, Jiri Olsa <jolsa@redhat.com>,
	Masami Hiramatsu <mhiramat@kernel.org>,
	Milian Wolff <milian.wolff@kdab.com>,
	Namhyung Kim <namhyung@kernel.org>,
	Stephane Eranian <eranian@google.com>,
	Thomas Gleixner <tglx@linutronix.de>,
	Vince Weaver <vincent.weaver@maine.edu>,
	Wang Nan <wangnan0@huawei.com>, Zefan Li <lizefan@huawei.com>,
	Linux Kernel Mailing List <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH/RFC v2] perf core: Allow setting up max frame stack depth via sysctl
Date: Mon, 25 Apr 2016 17:17:50 -0300	[thread overview]
Message-ID: <20160425201750.GD25218@kernel.org> (raw)
In-Reply-To: <20160425200646.GA23875@ast-mbp.thefacebook.com>

Em Mon, Apr 25, 2016 at 01:06:48PM -0700, Alexei Starovoitov escreveu:
> On Mon, Apr 25, 2016 at 04:22:29PM -0300, Arnaldo Carvalho de Melo wrote:
> > Em Mon, Apr 25, 2016 at 01:27:06PM -0300, Arnaldo Carvalho de Melo escreveu:
> > > Em Mon, Apr 25, 2016 at 01:14:25PM -0300, Arnaldo Carvalho de Melo escreveu:
> > > > Em Fri, Apr 22, 2016 at 03:18:08PM -0700, Alexei Starovoitov escreveu:
> > > > > right... and looking into it further, realized that the patch is broken,
> > > > > since get_callchain_entry() is doing:
> > > > >   return &entries->cpu_entries[cpu][*rctx];
> > > > > whereas it should be dynamic offset based on sysctl_perf_event_max_stack*8
> > > > > So definitely needs another respin.
> > 
> > > struct perf_callchain_entry {
> > >         __u64     nr;
> > >         __u64     ip[0]; /* /proc/sys/kernel/perf_event_max_stack */
> > > };
> >  
> > > But perf_callchain_entry->ip is not a pointer... Got it ;-\
> > 
> > This is what I am building now, a patch on top of the previous, that
> > will be combined and sent as v3, if I don't find any more funnies:
> > 
> > diff --git a/kernel/events/callchain.c b/kernel/events/callchain.c
> > index 6fe77349fa9d..40657892a7e0 100644
> > --- a/kernel/events/callchain.c
> > +++ b/kernel/events/callchain.c
> > @@ -20,11 +20,10 @@ struct callchain_cpus_entries {
> >  
> >  int sysctl_perf_event_max_stack __read_mostly = PERF_MAX_STACK_DEPTH;
> >  
> > -static size_t perf_callchain_entry__sizeof(void)
> > -{
> > -	return sizeof(struct perf_callchain_entry) +
> > -	       sizeof(__u64) * sysctl_perf_event_max_stack;
> > -}
> > +#define __perf_callchain_entry_size(entries) \
> > +	(sizeof(struct perf_callchain_entry) + sizeof(__u64) * entries)
> > +
> > +static size_t perf_callchain_entry_size __read_mostly = __perf_callchain_entry_size(PERF_MAX_STACK_DEPTH);
> >  
> >  static DEFINE_PER_CPU(int, callchain_recursion[PERF_NR_CONTEXTS]);
> >  static atomic_t nr_callchain_events;
> > @@ -81,7 +80,7 @@ static int alloc_callchain_buffers(void)
> >  	if (!entries)
> >  		return -ENOMEM;
> >  
> > -	size = perf_callchain_entry__sizeof() * PERF_NR_CONTEXTS;
> > +	size = perf_callchain_entry_size * PERF_NR_CONTEXTS;
> >  
> >  	for_each_possible_cpu(cpu) {
> >  		entries->cpu_entries[cpu] = kmalloc_node(size, GFP_KERNEL,
> > @@ -155,7 +154,8 @@ static struct perf_callchain_entry *get_callchain_entry(int *rctx)
> >  
> >  	cpu = smp_processor_id();
> >  
> > -	return &entries->cpu_entries[cpu][*rctx];
> > +	return (((void *)&entries->cpu_entries[cpu][0]) +
> > +		(*rctx * perf_callchain_entry_size));
> 
> I think the following would be easier to read:
> 
> +	return (void *)entries->cpu_entries[cpu] +
> +		*rctx * perf_callchain_entry_size;

Well, I thought that multiline expressions required parentheses, to make
them easier to read for someone, maybe Ingo? ;-)

Whatever, both generate the same result, really want me to change this?

> ?
> if didn't mixed up the ordering...

If you are not sure, then its not clearer, huh? ;-P
 
> and probably we could do the math on the spot instead of introducing
> perf_callchain_entry_size global variable?

I was trying to avoid the calc for each alloc, just doing it when we
change that number via the sysctl, probably not that big a deal, do you
really think we should do the math per-alloc instead of
per-sysctl-changing?

- Arnaldo

  reply	other threads:[~2016-04-25 20:17 UTC|newest]

Thread overview: 38+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-04-20 22:47 [PATCH/RFC] perf core: Allow setting up max frame stack depth via sysctl Arnaldo Carvalho de Melo
2016-04-20 23:04 ` Alexei Starovoitov
2016-04-22 20:52   ` [PATCH/RFC v2] " Arnaldo Carvalho de Melo
2016-04-22 21:37     ` Alexei Starovoitov
2016-04-22 22:05     ` David Ahern
2016-04-22 22:18       ` Alexei Starovoitov
2016-04-25 16:14         ` Arnaldo Carvalho de Melo
2016-04-25 16:27           ` Arnaldo Carvalho de Melo
2016-04-25 19:22             ` Arnaldo Carvalho de Melo
2016-04-25 20:06               ` Alexei Starovoitov
2016-04-25 20:17                 ` Arnaldo Carvalho de Melo [this message]
2016-04-25 21:59                   ` Alexei Starovoitov
2016-04-25 23:41                     ` Arnaldo Carvalho de Melo
2016-04-26  0:07                       ` Alexei Starovoitov
2016-04-26  0:29                         ` [PATCH/RFC v3] " Arnaldo Carvalho de Melo
2016-04-26  0:44                           ` Alexei Starovoitov
2016-04-26  0:47                             ` Arnaldo Carvalho de Melo
2016-04-26  0:49                               ` Brendan Gregg
2016-04-26 16:33                                 ` Arnaldo Carvalho de Melo
2016-04-26 16:45                                   ` David Ahern
2016-04-27 13:20                                     ` Arnaldo Carvalho de Melo
2016-04-26 20:02                                 ` Brendan Gregg
2016-04-26 21:05                                   ` Arnaldo Carvalho de Melo
2016-04-26 21:55                                     ` Peter Zijlstra
2016-04-27 12:53                                       ` Arnaldo Carvalho de Melo
2016-04-26 21:58                                     ` Brendan Gregg
2016-04-26 22:10                                       ` Peter Zijlstra
2016-04-27 12:56                                       ` Arnaldo Carvalho de Melo
2016-04-26 21:58                           ` Frederic Weisbecker
2016-04-27 12:53                             ` Arnaldo Carvalho de Melo
2016-04-27 16:09                               ` Frederic Weisbecker
2016-04-27 16:27                                 ` David Ahern
2016-04-27 15:39                           ` [tip:perf/core] " tip-bot for Arnaldo Carvalho de Melo
2016-04-20 23:10 ` [PATCH/RFC] " David Ahern
2016-04-21  0:18   ` Arnaldo Carvalho de Melo
2016-04-21 10:48 ` Peter Zijlstra
2016-04-21 15:17   ` Arnaldo Carvalho de Melo
2016-04-21 15:42     ` Arnaldo Carvalho de Melo

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20160425201750.GD25218@kernel.org \
    --to=acme@kernel.org \
    --cc=adrian.hunter@intel.com \
    --cc=alexander.shishkin@linux.intel.com \
    --cc=alexei.starovoitov@gmail.com \
    --cc=arnaldo.melo@gmail.com \
    --cc=ast@kernel.org \
    --cc=brendan.d.gregg@gmail.com \
    --cc=dsahern@gmail.com \
    --cc=eranian@google.com \
    --cc=fweisbec@gmail.com \
    --cc=hekuang@huawei.com \
    --cc=jolsa@redhat.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=lizefan@huawei.com \
    --cc=mhiramat@kernel.org \
    --cc=milian.wolff@kdab.com \
    --cc=mingo@kernel.org \
    --cc=namhyung@kernel.org \
    --cc=peterz@infradead.org \
    --cc=tglx@linutronix.de \
    --cc=vincent.weaver@maine.edu \
    --cc=wangnan0@huawei.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).