From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1755162AbcHSNYU (ORCPT ); Fri, 19 Aug 2016 09:24:20 -0400 Received: from foss.arm.com ([217.140.101.70]:36138 "EHLO foss.arm.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1752305AbcHSNYS (ORCPT ); Fri, 19 Aug 2016 09:24:18 -0400 Date: Fri, 19 Aug 2016 14:24:28 +0100 From: Will Deacon To: Punit Agrawal Cc: linux-kernel@vger.kernel.org, kvm@vger.kernel.org, kvmarm@lists.cs.columbia.edu, linux-arm-kernel@lists.infradead.org, Mark Rutland , Christoffer Dall , Marc Zyngier , Steven Rostedt , Ingo Molnar , Catalin Marinas Subject: Re: [RFC PATCH 4/7] arm64: tlbflush.h: add __tlbi() macro Message-ID: <20160819132427.GD9893@arm.com> References: <1471344312-26685-1-git-send-email-punit.agrawal@arm.com> <1471344312-26685-5-git-send-email-punit.agrawal@arm.com> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <1471344312-26685-5-git-send-email-punit.agrawal@arm.com> User-Agent: Mutt/1.5.23 (2014-03-12) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Tue, Aug 16, 2016 at 11:45:09AM +0100, Punit Agrawal wrote: > From: Mark Rutland > > As with dsb() and isb(), add a __tbli() helper so that we can avoid Minor typo: s/__tbli/__tlbi/ > distracting asm boilerplate every time we want a TLBI. As some TLBI > operations take an argument while others do not, some pre-processor is > used to handle these two cases with different assembly blocks. > > The existing tlbflush.h code is moved over to use the helper. > > Signed-off-by: Mark Rutland > Cc: Catalin Marinas > Cc: Marc Zyngier > Cc: Will Deacon > [ rename helper to __tlbi, update commit log ] > Signed-off-by: Punit Agrawal > --- > arch/arm64/include/asm/tlbflush.h | 31 +++++++++++++++++++++++-------- > 1 file changed, 23 insertions(+), 8 deletions(-) > > diff --git a/arch/arm64/include/asm/tlbflush.h b/arch/arm64/include/asm/tlbflush.h > index b460ae2..d57a0be 100644 > --- a/arch/arm64/include/asm/tlbflush.h > +++ b/arch/arm64/include/asm/tlbflush.h > @@ -25,6 +25,21 @@ > #include > > /* > + * Raw TLBI operations. Drivers and most kernel code should use the TLB > + * management routines below in preference to these. Where necessary, these can > + * be used to avoid asm() boilerplate. > + * > + * Can be used as __tlbi(op) or __tlbi(op, arg), depending on whether a > + * particular TLBI op takes an argument or not. The macros below handle invoking > + * the asm with or without the register argument as appropriate. > + */ > +#define TLBI_0(op, arg) asm ("tlbi " #op) > +#define TLBI_1(op, arg) asm ("tlbi " #op ", %0" : : "r" (arg)) > +#define TLBI_N(op, arg, n, ...) TLBI_##n(op, arg) Should this be prefixed with underscores, too? Will