linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Eugene Korenevsky <ekorenevsky@gmail.com>
To: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Cc: linux-kernel@vger.kernel.org, linux-usb@vger.kernel.org,
	Luiz Capitulino <lcapitulino@redhat.com>,
	Linus Torvalds <torvalds@linux-foundation.org>,
	Chase Metzger <chasemetzger15@gmail.com>,
	Alan Stern <stern@rowland.harvard.edu>,
	Mathias Nyman <mathias.nyman@linux.intel.com>,
	Lu Baolu <baolu.lu@linux.intel.com>,
	Oliver Neukum <oneukum@suse.com>, Hans Yang <hansy@nvidia.com>
Subject: Re: [PATCH v2] USB hub_probe: remove ugly goto-into-compound-statement
Date: Mon, 7 Nov 2016 21:42:57 +0300	[thread overview]
Message-ID: <20161107184256.GA18770@vnote> (raw)
In-Reply-To: <20161107090917.GA4949@kroah.com>

On Mon, Nov 07, 2016 at 10:09:17AM +0100, Greg Kroah-Hartman wrote:

> > Rework smelling code (goto inside compound statement). Perhaps this is legacy.
> > Anyway such code is not appropriate for Linux kernel.
> > 
> > Signed-off-by: Eugene Korenevsky <ekorenevsky@gmail.com>
> > ---
> >  drivers/usb/core/hub.c | 24 +++++++++++-------------
> >  1 file changed, 11 insertions(+), 13 deletions(-)
> 
> What changed from v1?

Fixed faults: missed 'Signed-off-by', spaces instead of tab.


> > diff --git a/drivers/usb/core/hub.c b/drivers/usb/core/hub.c
> > index cbb1467..4081672 100644
> > --- a/drivers/usb/core/hub.c
> > +++ b/drivers/usb/core/hub.c
> > @@ -1802,23 +1802,21 @@ static int hub_probe(struct usb_interface *intf, const struct usb_device_id *id)
> >  
> >  	/* Some hubs have a subclass of 1, which AFAICT according to the */
> >  	/*  specs is not defined, but it works */
> > -	if ((desc->desc.bInterfaceSubClass != 0) &&
> > -	    (desc->desc.bInterfaceSubClass != 1)) {
> > -descriptor_error:
> > +
> > +	/* Reject in following cases:
> > +	 * - Interface subclass is not 0 or 1
> > +	 * - Multiple endpoints
> > +	 * - Not an interrupt in endpoint
> > +	 */
> > +	endpoint = &desc->endpoint[0].desc;
> > +	if ((desc->desc.bInterfaceSubClass != 0 &&
> > +	     desc->desc.bInterfaceSubClass != 1) ||
> > +	    desc->desc.bNumEndpoints != 1 ||
> > +	    !usb_endpoint_is_int_in(endpoint)) {
> >  		dev_err(&intf->dev, "bad descriptor, ignoring hub\n");
> >  		return -EIO;
> >  	}
> >  
> > -	/* Multiple endpoints? What kind of mutant ninja-hub is this? */
> > -	if (desc->desc.bNumEndpoints != 1)
> > -		goto descriptor_error;
> > -
> > -	endpoint = &desc->endpoint[0].desc;
> > -
> > -	/* If it's not an interrupt in endpoint, we'd better punt! */
> > -	if (!usb_endpoint_is_int_in(endpoint))
> > -		goto descriptor_error;
> > -
> 
> As "horrible" as the original code might be, it's much easier to read
> and follow, which is the key thing here, right?  What's so bad about a
> goto backwards?

OK, this patch is still not perfect. But jumping *back* into
*compound* *statement* hurts reader's eyes. Really. Maybe it's better to
extract this code to static function, compiler will inline it. See v3
patchset.

-- 
Eugene

      reply	other threads:[~2016-11-07 18:44 UTC|newest]

Thread overview: 3+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-11-02 17:59 [PATCH v2] USB hub_probe: remove ugly goto-into-compound-statement Eugene Korenevsky
2016-11-07  9:09 ` Greg Kroah-Hartman
2016-11-07 18:42   ` Eugene Korenevsky [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20161107184256.GA18770@vnote \
    --to=ekorenevsky@gmail.com \
    --cc=baolu.lu@linux.intel.com \
    --cc=chasemetzger15@gmail.com \
    --cc=gregkh@linuxfoundation.org \
    --cc=hansy@nvidia.com \
    --cc=lcapitulino@redhat.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-usb@vger.kernel.org \
    --cc=mathias.nyman@linux.intel.com \
    --cc=oneukum@suse.com \
    --cc=stern@rowland.harvard.edu \
    --cc=torvalds@linux-foundation.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).