linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Milo Kim <woogyom.kim@gmail.com>
To: Sebastian Reichel <sre@kernel.org>
Cc: Enric Balletbo i Serra <enric.balletbo@collabora.com>,
	linux-pm@vger.kernel.org, linux-kernel@vger.kernel.org,
	Milo Kim <woogyom.kim@gmail.com>
Subject: [PATCH v2 3/8] power: supply: tps65217: Remove IRQ data from driver data
Date: Fri,  9 Dec 2016 16:49:01 +0900	[thread overview]
Message-ID: <20161209074906.27545-4-woogyom.kim@gmail.com> (raw)
In-Reply-To: <20161209074906.27545-1-woogyom.kim@gmail.com>

IRQ number is only used on requesting the interrupt, so no need to keep
it inside the driver data.

Signed-off-by: Milo Kim <woogyom.kim@gmail.com>
---
 drivers/power/supply/tps65217_charger.c | 2 --
 1 file changed, 2 deletions(-)

diff --git a/drivers/power/supply/tps65217_charger.c b/drivers/power/supply/tps65217_charger.c
index 55371d6..482ee9f 100644
--- a/drivers/power/supply/tps65217_charger.c
+++ b/drivers/power/supply/tps65217_charger.c
@@ -48,8 +48,6 @@ struct tps65217_charger {
 	int	prev_ac_online;
 
 	struct task_struct	*poll_task;
-
-	int	irq;
 };
 
 static enum power_supply_property tps65217_ac_props[] = {
-- 
2.9.3

  parent reply	other threads:[~2016-12-09  7:49 UTC|newest]

Thread overview: 11+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-12-09  7:48 [PATCH v2 0/8] power: supply: tps65217: Support USB charger feature Milo Kim
2016-12-09  7:48 ` [PATCH v2 1/8] power: supply: tps65217: Support USB charger interrupt Milo Kim
2016-12-09  7:49 ` [PATCH v2 2/8] power: supply: tps65217: Use 'poll_task' on unloading the module Milo Kim
2016-12-09  7:49 ` Milo Kim [this message]
2016-12-09  7:49 ` [PATCH v2 4/8] power: supply: tps65217: Use generic name for charger online Milo Kim
2016-12-09  7:49 ` [PATCH v2 5/8] power: supply: tps65217: Use generic name for power supply structure Milo Kim
2016-12-09  7:49 ` [PATCH v2 6/8] power: supply: tps65217: Use generic name for power supply property Milo Kim
2016-12-09  7:49 ` [PATCH v2 7/8] power: supply: tps65217: Use generic name for get_property() Milo Kim
2016-12-09  7:49 ` [PATCH v2 8/8] power: supply: tps65217: Use generic charger name Milo Kim
2016-12-17 16:24 ` [PATCH v2 0/8] power: supply: tps65217: Support USB charger feature Sebastian Reichel
2016-12-18  2:57   ` Milo Kim

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20161209074906.27545-4-woogyom.kim@gmail.com \
    --to=woogyom.kim@gmail.com \
    --cc=enric.balletbo@collabora.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-pm@vger.kernel.org \
    --cc=sre@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).