linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH] sbus: char: Move D7S_MINOR to include/linux/miscdevice.h
@ 2016-12-15 19:47 Corentin Labbe
  2016-12-17  1:05 ` Julian Calaby
  2017-01-10 17:37 ` Greg KH
  0 siblings, 2 replies; 5+ messages in thread
From: Corentin Labbe @ 2016-12-15 19:47 UTC (permalink / raw)
  To: davem, sparclinux, arnd, gregkh; +Cc: linux-kernel, Corentin Labbe

This patch move the define for D7S_MINOR to include/linux/miscdevice.h.
It's better that all minor number are in the same place.

Signed-off-by: Corentin Labbe <clabbe.montjoie@gmail.com>
---
 drivers/sbus/char/display7seg.c | 1 -
 include/linux/miscdevice.h      | 1 +
 2 files changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/sbus/char/display7seg.c b/drivers/sbus/char/display7seg.c
index 33fbe82..48a5df0 100644
--- a/drivers/sbus/char/display7seg.c
+++ b/drivers/sbus/char/display7seg.c
@@ -22,7 +22,6 @@
 
 #include <asm/display7seg.h>
 
-#define D7S_MINOR	193
 #define DRIVER_NAME	"d7s"
 #define PFX		DRIVER_NAME ": "
 
diff --git a/include/linux/miscdevice.h b/include/linux/miscdevice.h
index 5385d95..b1ba37aef 100644
--- a/include/linux/miscdevice.h
+++ b/include/linux/miscdevice.h
@@ -33,6 +33,7 @@
 #define I2O_MINOR		166
 #define HWRNG_MINOR		183
 #define MICROCODE_MINOR		184
+#define D7S_MINOR		193
 #define VFIO_MINOR		196
 #define TUN_MINOR		200
 #define CUSE_MINOR		203
-- 
2.10.2

^ permalink raw reply related	[flat|nested] 5+ messages in thread

* Re: [PATCH] sbus: char: Move D7S_MINOR to include/linux/miscdevice.h
  2016-12-15 19:47 [PATCH] sbus: char: Move D7S_MINOR to include/linux/miscdevice.h Corentin Labbe
@ 2016-12-17  1:05 ` Julian Calaby
  2017-01-10 17:37 ` Greg KH
  1 sibling, 0 replies; 5+ messages in thread
From: Julian Calaby @ 2016-12-17  1:05 UTC (permalink / raw)
  To: Corentin Labbe
  Cc: David S. Miller, sparclinux, Arnd Bergmann, Greg KH, linux-kernel

Hi Corentin,

On Fri, Dec 16, 2016 at 6:47 AM, Corentin Labbe
<clabbe.montjoie@gmail.com> wrote:
> This patch move the define for D7S_MINOR to include/linux/miscdevice.h.
> It's better that all minor number are in the same place.
>
> Signed-off-by: Corentin Labbe <clabbe.montjoie@gmail.com>
> ---
>  drivers/sbus/char/display7seg.c | 1 -
>  include/linux/miscdevice.h      | 1 +
>  2 files changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/sbus/char/display7seg.c b/drivers/sbus/char/display7seg.c
> index 33fbe82..48a5df0 100644
> --- a/drivers/sbus/char/display7seg.c
> +++ b/drivers/sbus/char/display7seg.c
> @@ -22,7 +22,6 @@
>
>  #include <asm/display7seg.h>
>
> -#define D7S_MINOR      193
>  #define DRIVER_NAME    "d7s"
>  #define PFX            DRIVER_NAME ": "
>
> diff --git a/include/linux/miscdevice.h b/include/linux/miscdevice.h
> index 5385d95..b1ba37aef 100644
> --- a/include/linux/miscdevice.h
> +++ b/include/linux/miscdevice.h
> @@ -33,6 +33,7 @@
>  #define I2O_MINOR              166
>  #define HWRNG_MINOR            183
>  #define MICROCODE_MINOR                184
> +#define D7S_MINOR              193

I was going to say "why not change the name to something more
descriptive" however they're all very abbreviated, so maybe consider a
second patch series to describe what each of these is for?

>  #define VFIO_MINOR             196
>  #define TUN_MINOR              200
>  #define CUSE_MINOR             203

Thanks,

-- 
Julian Calaby

Email: julian.calaby@gmail.com
Profile: http://www.google.com/profiles/julian.calaby/

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [PATCH] sbus: char: Move D7S_MINOR to include/linux/miscdevice.h
  2016-12-15 19:47 [PATCH] sbus: char: Move D7S_MINOR to include/linux/miscdevice.h Corentin Labbe
  2016-12-17  1:05 ` Julian Calaby
@ 2017-01-10 17:37 ` Greg KH
  1 sibling, 0 replies; 5+ messages in thread
From: Greg KH @ 2017-01-10 17:37 UTC (permalink / raw)
  To: Corentin Labbe; +Cc: davem, sparclinux, arnd, linux-kernel

On Thu, Dec 15, 2016 at 08:47:03PM +0100, Corentin Labbe wrote:
> This patch move the define for D7S_MINOR to include/linux/miscdevice.h.
> It's better that all minor number are in the same place.
> 
> Signed-off-by: Corentin Labbe <clabbe.montjoie@gmail.com>
> ---
>  drivers/sbus/char/display7seg.c | 1 -
>  include/linux/miscdevice.h      | 1 +
>  2 files changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/drivers/sbus/char/display7seg.c b/drivers/sbus/char/display7seg.c
> index 33fbe82..48a5df0 100644
> --- a/drivers/sbus/char/display7seg.c
> +++ b/drivers/sbus/char/display7seg.c
> @@ -22,7 +22,6 @@
>  
>  #include <asm/display7seg.h>
>  
> -#define D7S_MINOR	193
>  #define DRIVER_NAME	"d7s"
>  #define PFX		DRIVER_NAME ": "
>  
> diff --git a/include/linux/miscdevice.h b/include/linux/miscdevice.h
> index 5385d95..b1ba37aef 100644
> --- a/include/linux/miscdevice.h
> +++ b/include/linux/miscdevice.h
> @@ -33,6 +33,7 @@
>  #define I2O_MINOR		166
>  #define HWRNG_MINOR		183
>  #define MICROCODE_MINOR		184
> +#define D7S_MINOR		193
>  #define VFIO_MINOR		196
>  #define TUN_MINOR		200
>  #define CUSE_MINOR		203
> -- 

Doesn't apply to my tree :(

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [PATCH] sbus: char: Move D7S_MINOR to include/linux/miscdevice.h
  2017-09-18 18:10 Corentin Labbe
@ 2017-09-28  4:52 ` David Miller
  0 siblings, 0 replies; 5+ messages in thread
From: David Miller @ 2017-09-28  4:52 UTC (permalink / raw)
  To: clabbe.montjoie; +Cc: arnd, gregkh, sparclinux, linux-kernel

From: Corentin Labbe <clabbe.montjoie@gmail.com>
Date: Mon, 18 Sep 2017 20:10:36 +0200

> This patch move the define for D7S_MINOR to include/linux/miscdevice.h.
> It's better that all minor number are in the same place.
> 
> Signed-off-by: Corentin Labbe <clabbe.montjoie@gmail.com>

Applied.

^ permalink raw reply	[flat|nested] 5+ messages in thread

* [PATCH] sbus: char: Move D7S_MINOR to include/linux/miscdevice.h
@ 2017-09-18 18:10 Corentin Labbe
  2017-09-28  4:52 ` David Miller
  0 siblings, 1 reply; 5+ messages in thread
From: Corentin Labbe @ 2017-09-18 18:10 UTC (permalink / raw)
  To: davem, arnd, gregkh; +Cc: sparclinux, linux-kernel, Corentin Labbe

This patch move the define for D7S_MINOR to include/linux/miscdevice.h.
It's better that all minor number are in the same place.

Signed-off-by: Corentin Labbe <clabbe.montjoie@gmail.com>
---
 drivers/sbus/char/display7seg.c | 1 -
 include/linux/miscdevice.h      | 1 +
 2 files changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/sbus/char/display7seg.c b/drivers/sbus/char/display7seg.c
index f32765d3cbd8..5c8ed7350a04 100644
--- a/drivers/sbus/char/display7seg.c
+++ b/drivers/sbus/char/display7seg.c
@@ -22,7 +22,6 @@
 
 #include <asm/display7seg.h>
 
-#define D7S_MINOR	193
 #define DRIVER_NAME	"d7s"
 #define PFX		DRIVER_NAME ": "
 
diff --git a/include/linux/miscdevice.h b/include/linux/miscdevice.h
index 58751eae5f77..05c3892b3e92 100644
--- a/include/linux/miscdevice.h
+++ b/include/linux/miscdevice.h
@@ -35,6 +35,7 @@
 #define HWRNG_MINOR		183
 #define MICROCODE_MINOR		184
 #define IRNET_MINOR		187
+#define D7S_MINOR		193
 #define VFIO_MINOR		196
 #define TUN_MINOR		200
 #define CUSE_MINOR		203
-- 
2.13.5

^ permalink raw reply related	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2017-09-28  4:52 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2016-12-15 19:47 [PATCH] sbus: char: Move D7S_MINOR to include/linux/miscdevice.h Corentin Labbe
2016-12-17  1:05 ` Julian Calaby
2017-01-10 17:37 ` Greg KH
2017-09-18 18:10 Corentin Labbe
2017-09-28  4:52 ` David Miller

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).